Duplicate, Identical Road Segments being created... (again)

The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.

Moderators: Unholy, bextein

Re: Duplicate, Identical Road Segments being created... (aga

Postby AlanOfTheBerg » Tue Sep 11, 2012 3:41 pm

This bug is still present in the current beta editor.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23614
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1128 times
Been thanked: 4819 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby DonJ2 » Tue Sep 11, 2012 1:11 pm

I remember this happening to me in the past, but have not seen it in a long time. Sorry to hear that it's back.
DonJ2
 
Posts: 281
Joined: Sat Oct 01, 2011 9:00 pm
Location: Central Florida, USA
Has thanked: 46 times
Been thanked: 10 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby AlanOfTheBerg » Mon Sep 10, 2012 3:39 pm

Still not resolved. Not fixed in the current beta version of the editor either I believe.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23614
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1128 times
Been thanked: 4819 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby gregers » Mon Sep 10, 2012 1:46 pm

Is this bug still not resolved? (http://world.waze.com/wiki/index.php/Known_issues)

I've found many, many places in Norway where this has happened. Resulting in LOTS of disconnected roads. They are also difficult to fix, since the editor pops up all sorts of error messages when trying to save.

Last week I reported a bug-report for the editor issues along with some examples of duplicate roads:
viewtopic.php?f=10&t=24994&start=20#p230448

This weekend Waze couldn't find a route that has previously worked. When going to fix it I noticed yet another duplicate road. Tried to delete it and fix the roads, but then the editor wouldn't let me allow turns or adjust road geometry at close zoom-levels (only when zooming so far out that it was impossible to alter junctions).

When will you fix this bug? How are you planning on fixing all the map-problems caused by this bug? It's close to impossible for the community to fix these map errors, caused by this bug, because of other editor bugs. *sigh*
gregers
 
Posts: 17
Joined: Mon Jan 04, 2010 10:54 pm
Location: Oslo, Norway
Has thanked: 6 times
Been thanked: 5 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby AlanOfTheBerg » Thu Mar 15, 2012 2:25 pm

bgodette wrote:But did you pan back before saving?

Nope. IMO, the interface should either disallow panning at the point where it would cause issues or disallow panning altogether, or handle the long panning.

Ori has confirmed this situation and has sent the bug report on to R&D.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23614
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1128 times
Been thanked: 4819 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby bgodette » Thu Mar 15, 2012 12:30 am

AlanOfTheBerg wrote:
bgodette wrote:From watching the video I can understand where the bug is coming from, and it is sort of understandable. The bug is you've split the original segment, then panned that split segment far enough off screen that it exits the segment cache for your current view, then once you pan back it reloads the original unedited segment.

That is a plausible cause, but this bug isn't consistent. I've drawn similarly in the past with an initial segment junction and panned the screen 2-3 times without having the split segment do this.

But did you pan back before saving?
bgodette
Waze Global Champs
Waze Global Champs
 
Posts: 3436
Joined: Wed Jul 06, 2011 8:19 pm
Location: Denver, CO
Has thanked: 115 times
Been thanked: 538 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby AlanOfTheBerg » Thu Mar 15, 2012 12:07 am

bgodette wrote:From watching the video I can understand where the bug is coming from, and it is sort of understandable. The bug is you've split the original segment, then panned that split segment far enough off screen that it exits the segment cache for your current view, then once you pan back it reloads the original unedited segment.

That is a plausible cause, but this bug isn't consistent. I've drawn similarly in the past with an initial segment junction and panned the screen 2-3 times without having the split segment do this.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23614
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1128 times
Been thanked: 4819 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby bgodette » Wed Mar 14, 2012 11:52 pm

AlanOfTheBerg wrote:I just had this problem happen to me today. I'm not sure how long the segment needs to be before the first road "splits" but this sure is obnoxious. Same situation as before: the original road is a single segment and this happens only when you pan a few times during the segment drawing.

The original segment is split into two new segments with different temp ID numbers, but the original remains as well.


From watching the video I can understand where the bug is coming from, and it is sort of understandable. The bug is you've split the original segment, then panned that split segment far enough off screen that it exits the segment cache for your current view, then once you pan back it reloads the original unedited segment.

The obvious work-around is to split, draw the first bit of new segment in your current view, save, then continue to extend the new segment. Or alternatively, not pan back to the original segment before saving (this may work, may not).
bgodette
Waze Global Champs
Waze Global Champs
 
Posts: 3436
Joined: Wed Jul 06, 2011 8:19 pm
Location: Denver, CO
Has thanked: 115 times
Been thanked: 538 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby jasonh300 » Wed Mar 14, 2012 9:49 pm

AlanOfTheBerg wrote:
jasonh300 wrote:I hit undo and started over and it happened again. A save and permalink solved it.

The only thing that worked for me is to draw a shorter segment. (The video starts with a fresh permalink load.)


Didn't realize it was a video. :duh:

Anyway, now that I think about it, the permalink didn't fix it. It was a pretty long segment I had drawn and I ended up drawing it and saving without connecting it to the offending segment. Then I connected it and it was fine.
jasonh300
 
Posts: 7568
Joined: Fri Oct 28, 2011 4:26 pm
Location: New Orleans, LA, USA
Has thanked: 408 times
Been thanked: 986 times

Re: Duplicate, Identical Road Segments being created... (aga

Postby Mike-1323 » Wed Mar 14, 2012 9:18 pm

I had this happen for the first time today. I didn't know it until I tried to add a road junction and save it. I kept getting the generic an error occurred message. Eventually I accidentally found the layered road and deleted it. Then I got the error during save but when I OK'ed out of the message everything had gone non-orange, the duplicate road was gone, and editing resumed normal operation. I just kind of scratched my head and assumed it was a synch error of some type and forgot about it until reading this thread.
Mike-1323
Area Manager
Area Manager
 
Posts: 1026
Joined: Fri Jul 15, 2011 11:06 pm
Location: Lorton, Va
Has thanked: 3 times
Been thanked: 186 times

Next

Return to Waze Map Editor

Who is online

Users browsing this forum: aviaron, Bing [Bot], Google Feedfetcher, Twister-UK, world_a84ncruf