While you were editing, the elements...

The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.

Moderators: krankyd, Unholy

Re: While you were editing, the elements...

Postby AlanOfTheBerg » Fri Jan 18, 2013 5:23 pm

kodi75 wrote:
Caradellino wrote: It is especially delicate, when you delete segments to redo them. I recomend to save after deleting and then perform the redo.


Just to clarify - I recall the wiki prefers that, if at all possible, to reuse existing segments rather than deleting and redrawing. There is speed and other data already associated with segments that would be lost.

That's true. Very much situation dependent, too.
Wiki Resources: Map Editing Manual | Oregon Project/To-Do List
Oregon-based US Country Manager | iPhone5 - VZ - iOS 7.0.6 | Waze v3.7.9.992
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 19485
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 653 times
Been thanked: 2255 times

Re: While you were editing, the elements...

Postby anti-S-crap » Fri Jan 18, 2013 7:02 pm

RJ_McKenzie wrote:"While you were editing, the elements you're trying to save have been modified and/or deleted.
Please refresh and try again."


When I run into this error. I just hit the permalink to refresh. You would think that you would lose your changes queried in the save button. But you don't (most of the time). Everything is all ready saved.
anti-S-crap
 
Posts: 55
Joined: Tue Nov 09, 2010 1:52 am
Location: Burbs of NW Detroit, MI
Has thanked: 6 times
Been thanked: 1 time

Re: While you were editing, the elements...

Postby Caradellino » Fri Jan 18, 2013 2:26 pm

RJ_McKenzie wrote:Am I the only one that is having this issue?


Surely not ;)

It happens to me too when I save too many edits at once. It is especially delicate, when you delete segments to redo them. I recomend to save after deleting and then perform the redo. Sometimes you still get the message, if you happen to experiance a sync error, but far less often.

Hope this works for you too :)
Greets...and keep on wazing
Caradellino, CM for:
Image
AT-Wiki | Team Austria | Wie Waze Routen kalkuliert
Australian Wiki
Samsung Galaxy Note 2
Caradellino
Waze Global Champs
Waze Global Champs
 
Posts: 1405
Joined: Mon Apr 16, 2012 5:09 am
Location: Austria
Has thanked: 206 times
Been thanked: 488 times

Re: While you were editing, the elements...

Postby Caradellino » Fri Jan 18, 2013 9:28 pm

kodi75 wrote:wiki prefers that, if at all possible, to reuse existing segments rather than deleting and redrawing. There is speed and other data already associated with segments that would be lost.

Agreed, but this does not apply in every case: i.e. when I find unfinished roads with a bad geometry and lots of unnecessary nodes, drawn or paved long ago, I simply delete them for they never had shown in the client and so no data is lost - and redoing them is far more efficient than spending time cleaning the geometry.
Greets...and keep on wazing
Caradellino, CM for:
Image
AT-Wiki | Team Austria | Wie Waze Routen kalkuliert
Australian Wiki
Samsung Galaxy Note 2
Caradellino
Waze Global Champs
Waze Global Champs
 
Posts: 1405
Joined: Mon Apr 16, 2012 5:09 am
Location: Austria
Has thanked: 206 times
Been thanked: 488 times

Re: While you were editing, the elements...

Postby harling » Sat Jan 19, 2013 2:07 pm

anti-S-crap wrote:
RJ_McKenzie wrote:"While you were editing, the elements you're trying to save have been modified and/or deleted. Please refresh and try again."

When I run into this error. I just hit the permalink to refresh. You would think that you would lose your changes queried in the save button. But you don't (most of the time). Everything is all ready saved.

Sometimes a sequence of edits makes reference to a map element (e.g., a junction or road) that was deleted by an earlier edit. Closed-loop roads (only possible these days via basemap or roundabout creation) seem to get that a lot.
svx-biker wrote:Could be the same as here. Maybe we should merge these topics or have a link to one and close others?

That is the most likely cause, since everyone is experiencing this lag. If you delete a junction, hit "save", and the junction is still there when the map refreshes, if you try to delete it again it will generate this error, because it is already queued for deletion from the map database.
Image
Area Manager, Eastern MA & Southern NH. Country Manager, USA.
Help wanted. Drop me a line!
Wiki Resources: Area Manager Wiki | Map Editing | Best Practices | Known Issues List
harling
Waze Global Champs
Waze Global Champs
 
Posts: 1730
Joined: Wed Oct 27, 2010 8:42 pm
Location: Eastern MA
Has thanked: 16 times
Been thanked: 114 times

Re: While you were editing, the elements...

Postby kodi75 » Fri Jan 18, 2013 5:16 pm

Caradellino wrote: It is especially delicate, when you delete segments to redo them. I recomend to save after deleting and then perform the redo.


Just to clarify - I recall the wiki prefers that, if at all possible, to reuse existing segments rather than deleting and redrawing. There is speed and other data already associated with segments that would be lost.
kodi75
 
Posts: 301
Joined: Mon Jul 02, 2012 3:43 am
Location: Central Maryland
Has thanked: 216 times
Been thanked: 46 times

While you were editing, the elements...

Postby RJ_McKenzie » Fri Jan 18, 2013 10:25 am

"While you were editing, the elements you're trying to save have been modified and/or deleted.
Please refresh and try again."

I see the above message alot at times when editing in my area. It's very annoying. It's coming from roads that I've moved slightly or ones that I've deleted to redo. The new roads are attaching to touching the area the old one was. I've erased browser data in Chrome, I've refreshed, ect. Still happening..

Am I the only one that is having this issue?
RJ_McKenzie
 
Posts: 17
Joined: Fri Dec 21, 2012 12:54 pm
Location: Daegu, South Korea
Has thanked: 0 time
Been thanked: 0 time

Re: While you were editing, the elements...

Postby RJ_McKenzie » Fri Jan 18, 2013 11:17 pm

Ah I didn't know that it kept speed an other data. I've never seen that anywhere in the interface. The maps around me are so bad from not many users here using Waze. It is sometimes just easier to just wipe out the road and start over.
RJ_McKenzie
 
Posts: 17
Joined: Fri Dec 21, 2012 12:54 pm
Location: Daegu, South Korea
Has thanked: 0 time
Been thanked: 0 time

Re: While you were editing, the elements...

Postby svx-biker » Sat Jan 19, 2013 11:38 am

Could be the same as here. Maybe we should merge these topics or have a link to one and close others?
svx-biker
Waze Global Champs
Waze Global Champs
 
Posts: 2469
Joined: Sat Oct 01, 2011 5:43 am
Location: Germany, Austria and Switzerland (DACH)
Has thanked: 267 times
Been thanked: 273 times


Return to Waze Map Editor

Who is online

Users browsing this forum: bluemotard