Trouble editing a section of my area

The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.

Moderators: Unholy, bextein

Re: Trouble editing a section of my area

Postby PHPProgrammer » Mon Nov 01, 2010 7:57 pm

I just emailed you what I'm getting in my Firebug log when the internal server error happens.
PHPProgrammer
 
Posts: 102
Joined: Fri Aug 13, 2010 3:42 am
Has thanked: 0 time
Been thanked: 0 time

Re: Trouble editing a section of my area

Postby unwallflower » Mon Nov 01, 2010 7:59 pm

RightTurnOnRed wrote:I just emailed you what I'm getting in my Firebug log when the internal server error happens.


Would you mind posting it here for us to see? Email is definitely the best way to get support to respond... but I'm curious about where the error lies as well. :oops:
unwallflower
 
Posts: 1564
Joined: Thu May 06, 2010 6:43 pm
Location: San Diego, CA
Has thanked: 0 time
Been thanked: 1 time

Re: Trouble editing a section of my area

Postby The Fej » Mon Nov 01, 2010 8:10 pm

OK. Update time.

We have worked on the issue throughout the day and we think we managed to identify and resolve the problem, or at least the deletion problem (which is what most of you referred to).

So as not to go to a lenghty process, we updated the world server (only) with the fix and would be grateful if you can recheck and see if that issue was resolved. The issue is probably due to the server upgrade made yesterday that for some reason caused this issue.

Small note about the firebug - it's a bit of a longshot and as we do not know where the error might be, we hope it can be 'captured'. In the example below you can see (in the lower left corner) a success code in the 'response' tab, hopefully when you have a fault - you can open the last line (which usually has the error) and get more information from there (the query/action and the bad response) from the 'params, 'Header', 'Json' and 'response' tabs.

[ img ]
The Fej
Waze Management
Waze Management
 
Posts: 1063
Joined: Sun Feb 22, 2009 12:02 pm
Has thanked: 0 time
Been thanked: 45 times

Re: Trouble editing a section of my area

Postby deeggo » Mon Nov 01, 2010 8:18 pm

The problem is still here on the world server. And it's reproducible, just try to delete this junction: http://world.waze.com/cartouche/?zoom=8 ... 1=96400728

Also adding a junction causes an error.
Global Champ. Country manager Nederland & België
NL: Wiki: hoe label ik een (snel)weg correct?
HTC One M8 | Follow me on Twitter
Join Dropbox, free online file sync! Register through this link and give you and me 250MB extra for free. Thanks!
deeggo
Waze Global Champs
Waze Global Champs
 
Posts: 4312
Joined: Thu Mar 04, 2010 1:21 pm
Has thanked: 718 times
Been thanked: 704 times

Re: Trouble editing a section of my area

Postby waynemcdougall » Mon Nov 01, 2010 8:20 pm

Copy of email sent to alpha@waze.com

Dear Waze

About 2000 UTC 31 Oct problems started occurring on the Cartouche editor on the World server. The same problems are occurring on the WWW server but I can't confirm they started at the same time.

The problems all seem to be with junctions. Adding junctions, deleting junctions, creating roundabout, setting connectivity.

@KrankyD asked in one forum thread for a Firebug trace. One very smart user, and also me, can't figure out just what we need to do to give you what you want. I also suspect that you won't get anything useful. It's not a Javascript error - we just get back messages about the Waze server had an error. It should be easy to reproduce:

1. Try creating a roundabout (8m) here:
http://world.waze.com/cartouche/#?zoom= ... =110226197
2. Try creating a roundabout here
http://world.waze.com/cartouche/#?zoom= ... FTFFFFTTTT
3. Try deleting a junction here
http://world.waze.com/cartouche/?zoom=8 ... 1=96400728


Discussed in these forum threads:
viewtopic.php?f=10&t=6399&p=48080#p48080
viewtopic.php?p=47994#p47994
viewtopic.php?p=48010#p48010

http://www.waze.com/wiki/index.php/Waze_Service_Status
Waze User Manuals, Map Editing guide and support at http://www.waze.com/wiki
Wayne McDougall
Make Friends with me on Facebook and we'll compete against each other on the Scoreboard
http://www.facebook.com/wayne.w.mcdougall
waynemcdougall
 
Posts: 517
Joined: Mon Mar 08, 2010 3:59 am
Has thanked: 0 time
Been thanked: 6 times

Re: Trouble editing a section of my area

Postby dmcconachie » Mon Nov 01, 2010 8:28 pm

Hmm, not sure if it's related or not but I still can't do things such as split a two-way road!?

https://world.waze.com/cartouche/#?zoom=7&lat=56.48017&lon=-2.95226&layers=BTFTFFFFFFFFFFFFFFTTTT
dmcconachie • Former Global Champ

UK WikiUK FB PageCurrent status
dmcconachie
 
Posts: 6119
Joined: Sat May 22, 2010 11:44 pm
Location: Edinburgh, UK
Has thanked: 104 times
Been thanked: 302 times

Re: Trouble editing a section of my area

Postby PHPProgrammer » Mon Nov 01, 2010 8:31 pm

Here is what I sent to alpha@waze.com:


Internal Server Error

Response Headersview source
x-ua-compatible
IE=EmulateIE7
Server
Apache-Coyote/1.1
Cache-Control
max-age=0, no-cache
Content-Type
text/html;charset=utf-8
Content-Length
21
Date
Mon, 01 Nov 2010 19:52:25 GMT
Request Headersview source
Host
http://www.waze.com
User-Agent
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Accept
application/json, text/javascript, */*
Accept-Language
en-us,en;q=0.5
Accept-Encoding
gzip,deflate
Accept-Charset
ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive
115
Connection
keep-alive
Content-Type
application/x-www-form-urlencoded; charset=UTF-8
X-Requested-With
XMLHttpRequest
Referer
http://www.waze.com/cartouche/
Content-Length
92
Cookie
__utma=23975868.531612278.1285604824.1288628456.1288639875.93; __utmz=23975868.1288621385.91.3.utmcsr=facebook.com|utmccn=(referral)|utmcmd=referral|utmcct=/l.php; country=US&country_version=1.1; phpbb3_tk9ob_u=594786; phpbb3_tk9ob_k=8884895320829ea9; phpbb3_tk9ob_sid=fc472082653776f6ac09885b0eab06ae; keep_me_logged_in=undefined; cartouche={"map":{"left":-80.171761276479,"right":-80.166675808187,"top":26.106132646941,"bottom":26.103557726287,"type":"WMS"},"layers":{"speed_cams":false,"restrictions":false,"update_requests":true,"street_ranges":false,"users_notes":false,"map_problems":false,"gps_points":false,"landmarks":false,"unknown_roads":false,"line_roads":false,"no_name_roads":false,"roads":true,"managers":false,"aerial":true},"panels":{"layersPanel":{"left":"1206.5","top":"87"},"editPanel":{"left":"17.5","top":"8"},"mapControlPanel":{"left":"11.5","top":"311"},"viewPanel":{"left":"14.5","top":"558"},"updateRequestPanel":{"left":"180","top":"80"},"archivePanel":{"left":"0","top":"0"},"pendingPanel":{"left":"223","top":"26"}},"version":1.1,"gps_points_prefs":{"gps_points_arrows":true,"gps_points_colors":"1","filter_low_weight":false},"boom_additional_prefs":{"road_show_turns":true},"map_problems_prefs":{"problem_type_filter":"all","map_problems_colors":"0","map_problems_show_resolved":false,"map_problems_show_low_priority":false}}; style_cookie=printonly; __utmc=23975868; __utmb=23975868.22.10.1288639875; USERAUTH=





Parametersapplication/x-www-form-urlencoded
allow_all_turns
true
lat
26.105478187942
lon
-80.169025423284
metric_buffer
5.97164280155859
Source
metric_buffer=5.97164280155859&lon=-80.169025423284&lat=26.105478187942&allow_all_turns=true
Last edited by PHPProgrammer on Mon Nov 01, 2010 8:52 pm, edited 1 time in total.
PHPProgrammer
 
Posts: 102
Joined: Fri Aug 13, 2010 3:42 am
Has thanked: 0 time
Been thanked: 0 time

Re: Trouble editing a section of my area

Postby waynemcdougall » Mon Nov 01, 2010 8:47 pm

RightTurnOnRed wrote:Here is what I sent to alpha@waze.com:


Maybe you should edit that to remove the cookie part that has USERAUTH

Me no hacker. Maybe you know it's safe. I'd be worried about my password.
Waze User Manuals, Map Editing guide and support at http://www.waze.com/wiki
Wayne McDougall
Make Friends with me on Facebook and we'll compete against each other on the Scoreboard
http://www.facebook.com/wayne.w.mcdougall
waynemcdougall
 
Posts: 517
Joined: Mon Mar 08, 2010 3:59 am
Has thanked: 0 time
Been thanked: 6 times

Re: Trouble editing a section of my area

Postby PHPProgrammer » Mon Nov 01, 2010 8:53 pm

Good point. That's actually why I didnt' just post it here originally. :shock:

Thanks for catching that.
PHPProgrammer
 
Posts: 102
Joined: Fri Aug 13, 2010 3:42 am
Has thanked: 0 time
Been thanked: 0 time

Re: Trouble editing a section of my area

Postby QuickOK » Mon Nov 01, 2010 8:54 pm

... but I wanted his password... for educational purposes only...
QuickOK
 
Posts: 384
Joined: Wed Oct 28, 2009 8:55 pm
Location: Edmond, Oklahoma
Has thanked: 0 time
Been thanked: 1 time

PreviousNext

Return to Waze Map Editor

Who is online

Users browsing this forum: jm6087