Forum email notifications not clickable

If you think you've found a bug on the website which isn't specifically an App or Map Editor problem, or have a request for new or modified feature of the Community, Forums, or Waze website, use this forum.

Moderator: Unholy

Re: Forum email notifications not clickable

Postby GangMan » Mon Sep 02, 2013 1:54 pm

asterix06 wrote:For what i can remember this service has been disabled


If you're referring to the mandrillapp.com service - the links are still there. Even in the now clickable version. It does forward to the correct forum address so it has to be active in some way.

paulkok_my wrote:I received email notification to this thread and the link is clickable already. :D


Yeah, it's working again, although there problem still exists for subscribed forums and PMs. But Liz is already on it.

Wolfgang
GangMan
Waze Local Champs
Waze Local Champs
 
Posts: 1032
Joined: Sat Oct 30, 2010 6:53 am
Location: Pregarten, Austria
Has thanked: 128 times
Been thanked: 274 times

Re: Forum email notifications not clickable

Postby paulkok_my » Mon Sep 02, 2013 12:20 pm

I received email notification to this thread and the link is clickable already. :D
paulkok_my
Waze Global Champs
Waze Global Champs
 
Posts: 1153
Joined: Thu Jul 19, 2012 4:34 am
Location: Selangor, Malaysia
Has thanked: 327 times
Been thanked: 245 times

Re: Forum email notifications not clickable

Postby asterix06 » Mon Sep 02, 2013 12:03 pm

For what i can remember this service has been disabled

Inviato dal mio Nexus 7 con Tapatalk 4
asterix06
Coordinators
Coordinators
 
Posts: 4338
Joined: Sat Nov 14, 2009 9:23 am
Location: Italy
Has thanked: 955 times
Been thanked: 1815 times

Re: Forum email notifications not clickable

Postby GangMan » Mon Sep 02, 2013 11:23 am

I forwarded the issue to our community manager Liz and she was kind enough to pass it on. The emails work fine again for me - problem seems to be solved.

Thanks to everyone who was involved!

Wolfgang
GangMan
Waze Local Champs
Waze Local Champs
 
Posts: 1032
Joined: Sat Oct 30, 2010 6:53 am
Location: Pregarten, Austria
Has thanked: 128 times
Been thanked: 274 times

Re: Forum email notifications not clickable

Postby paulrissaweg » Wed Aug 28, 2013 2:24 pm

GangMan wrote:It is!

Sorry, you´re absolutely right...! :oops:
paulrissaweg
 
Posts: 156
Joined: Tue Jun 11, 2013 7:15 am
Has thanked: 68 times
Been thanked: 36 times

Re: Forum email notifications not clickable

Postby GangMan » Wed Aug 28, 2013 2:10 pm

paulrissaweg wrote:this is a sourcecode-example of my notification in Outlook (yes, clickable):
Code: Select all
<a href="http://mandrillapp.com/track/click.php?u=9825135&id=29dda5a56b354684a33c7e2b165119c9&url=http%3A%2F%2Fworld.waze.com%2Fforum%2Fviewtopic.php%3Ff%3D16%26t%3D59777%26e%3D533240&url_id=1912dfe64639cba4465f94805fed49b682a23ddb"></a>http://world.waze.com/forum/viewtopic.php?f=16&t=59777&e=533240<br><br>

So your <a>-tag thing is not the problem...

It is! Look closely (I'll leave out the long URL from mandrillapp.com):
<a href="http://mandrillapp.com/..."></a>http://world.waze.com/forum/viewtopic.php?f=16&t=59777&e=533240<br><br>

The <a> Element with the href Attribute opens and then </a> closes again. Then afterward there's the Forum URL. This is how it should be:

<a href="http://mandrillapp.com/...">http://world.waze.com/forum/viewtopic.php?f=16&t=59777&e=533240</a><br><br>
The text needs to be between <a> and </a> to be recognized as a link. It seems like that some clients such as Outlook or even webbrowsers perform some sort of HTML Sanitation. Thunderbird on the other hand seems to be strict. Since there's no text within the <a> element, there's nothing to click on.

I'm still puzzled that this problem still exists. There is an extension called "URL Link" for Thunderbird that allows to select a URL, right click and select "open" (just like paulkok_my described). But still, it's annoying as hell.

I'll see if I can forward this to someone in the Waze staff.

Wolfgang
GangMan
Waze Local Champs
Waze Local Champs
 
Posts: 1032
Joined: Sat Oct 30, 2010 6:53 am
Location: Pregarten, Austria
Has thanked: 128 times
Been thanked: 274 times

Re: Forum email notifications not clickable

Postby paulkok_my » Wed Aug 28, 2013 1:10 pm

I'm also facing the same problem on the URL not clickable. Luckily I'm using Chrome. I just highlight the URL address, right click and select goto the URL address. Chrome will open another tab to the URL address.
paulkok_my
Waze Global Champs
Waze Global Champs
 
Posts: 1153
Joined: Thu Jul 19, 2012 4:34 am
Location: Selangor, Malaysia
Has thanked: 327 times
Been thanked: 245 times

Re: Forum email notifications not clickable

Postby paulrissaweg » Wed Aug 28, 2013 1:05 pm

this is a sourcecode-example of my notification in Outlook (yes, clickable):
Code: Select all
<a href="http://mandrillapp.com/track/click.php?u=9825135&id=29dda5a56b354684a33c7e2b165119c9&url=http%3A%2F%2Fworld.waze.com%2Fforum%2Fviewtopic.php%3Ff%3D16%26t%3D59777%26e%3D533240&url_id=1912dfe64639cba4465f94805fed49b682a23ddb"></a>http://world.waze.com/forum/viewtopic.php?f=16&t=59777&e=533240<br><br>

So your <a>-tag thing is not the problem...


could this be something like email-forewarding without external content...?

Your example looks exactly like what I get when I try to foreward my html-newsletter without allowing outlook to "download external content from other servers" (mandrillapp.com)...!

Do you use only thunderbird, even on the mentioned different computers...?
Last edited by paulrissaweg on Wed Aug 28, 2013 1:22 pm, edited 3 times in total.
paulrissaweg
 
Posts: 156
Joined: Tue Jun 11, 2013 7:15 am
Has thanked: 68 times
Been thanked: 36 times

Re: Forum email notifications not clickable

Postby GangMan » Wed Aug 28, 2013 12:35 am

Changing the email address to GMail didn't change anything in Thunderbird. When accessing the email though mail.google.com it shows that GMail is obviously auto-correcting the error because the links are clickable. But when looking at the message source the link text still comes right after <a></a> and the link itself is empty. So this seems to be an email template issue. Could someone from the staff please look into it? I can't believe I'm the only one facing this weird issue.

Wolfgang
GangMan
Waze Local Champs
Waze Local Champs
 
Posts: 1032
Joined: Sat Oct 30, 2010 6:53 am
Location: Pregarten, Austria
Has thanked: 128 times
Been thanked: 274 times

Re: Forum email notifications not clickable

Postby GangMan » Wed Aug 28, 2013 12:11 am

No news from my side. It's still happening and I don't have the slightest clue why. It happens on multiple computers as well as on my webmail client so I guess it's not a thing of a anti virus changing mail content or something like that. Worst case it's my mail server that changes something before the messages even reach the clients (who knows). I'll switch my email address to GMail and see if this changes anything.

Wolfgang
GangMan
Waze Local Champs
Waze Local Champs
 
Posts: 1032
Joined: Sat Oct 30, 2010 6:53 am
Location: Pregarten, Austria
Has thanked: 128 times
Been thanked: 274 times

Next

Return to Website & Community Issues and Requests

Who is online

Users browsing this forum: No registered users