New Android Beta Version - 1.8.99.106

Important messages to community users. This forum is locked (waze staff only).

Moderators: Jackson, krankyd, Unholy

Re: New Android Beta Version - 1.8.99.106

Postby Vikos » Thu Sep 02, 2010 9:59 am

Downgraded to version 1.5.2 yesterday and actually now wazing is fun again on my HTC Hero!

What happened in v1.9 that made it so much slower even when all fancy stuff is disabled? Will the v2.0 be faster or will it only fix crash issues?

Ivar

Will be faster, will have groups, facebook integration and will be stable (i hope for this one)

Sent from my HTC Desire using Tapatalk
:!: Než začnete editovat: :!:
* Waze Czech wiki / Editace / Značení cest / POI - překlad / video návody *

HTC Desire (Android 2.2) + Waze release 2.0.2.4 (Beta :) )
Area manager: Ostravsko, Opavsko a Frýdecko
Vikos
 
Posts: 224
Joined: Tue Jan 26, 2010 1:16 pm
Has thanked: 0 time
Been thanked: 1 time

Re: New Android Beta Version - 1.8.99.106

Postby Vikos » Fri Sep 03, 2010 5:54 am

but will it ever come ?

it will come early...i think in one or two weeks. But now I can only wait for this new version.

Sent from my HTC Desire using Tapatalk
:!: Než začnete editovat: :!:
* Waze Czech wiki / Editace / Značení cest / POI - překlad / video návody *

HTC Desire (Android 2.2) + Waze release 2.0.2.4 (Beta :) )
Area manager: Ostravsko, Opavsko a Frýdecko
Vikos
 
Posts: 224
Joined: Tue Jan 26, 2010 1:16 pm
Has thanked: 0 time
Been thanked: 1 time

Re: New Android Beta Version - 1.8.99.105

Postby Watt25 » Tue Jun 22, 2010 7:54 pm

damaniac wrote:Hi,

I found a little bug in the new version 1.8.99.105. If you go to the Scoreboard and try to enter your Facebook name and password it doesn't allow any text. First it takes forever with the "Loading" message and when it displays the FB screen, you can click on the fields for name and pw, but it doesn't open the on-screen keyboard and if you use the Milestone hardware keyboard you can't enter any text.

BR
damaniac

PS: Trying the alternative login screen doesn't work too.

Same problem here with version 104 and 105 too.
Samsung Galaxy SIII LTE - Android 4.3
Area Manager: Érd - Martonvásár - Dunaújváros háromszögben
Ford Mondeo Tournier
Watt25
Waze Global Champs
Waze Global Champs
 
Posts: 1430
Joined: Thu Mar 25, 2010 4:36 pm
Location: Hungary - Érd
Has thanked: 10 times
Been thanked: 29 times

Re: New Android Beta Version - 1.8.99.106

Postby Watt25 » Thu Sep 09, 2010 6:00 am

I've got an anticipation.
Everybody suffering from Waze restarting phone should try to turn off Orientation. (In the OS' Settings / Sound & display settings)
Any improvement?
Samsung Galaxy SIII LTE - Android 4.3
Area Manager: Érd - Martonvásár - Dunaújváros háromszögben
Ford Mondeo Tournier
Watt25
Waze Global Champs
Waze Global Champs
 
Posts: 1430
Joined: Thu Mar 25, 2010 4:36 pm
Location: Hungary - Érd
Has thanked: 10 times
Been thanked: 29 times

Re: New Android Beta Version - 1.8.99.106

Postby Wekkel » Tue Aug 17, 2010 9:32 pm

I got the same random crash issues with 1.9.0.0 and Froyo 2.2 (official HTC Desire update). Guess Waze team needs to rework the Android client a bit more.
Wekkel
 
Posts: 31
Joined: Mon Nov 30, 2009 10:24 pm
Has thanked: 0 time
Been thanked: 0 time

Re: New Android Beta Version - 1.8.99.106

Postby zottel » Mon Aug 16, 2010 6:48 am

I have a Nexus One running Froyo, too, and I had reboots, too. Very frequently at times, quite seldomly lately.

This leads me to a new suspicion: I had reboots nearly all the time when it was so hot in Germany in June/July. When it became so much cooler, I suddenly didn't experience any reboots anymore. Then I got several reboots again last Wednesday, and guess what, it was the hottest day since weks.

Above all, the sun was shining quite fiercely when I drove home, and it seems to me that my phone gets heated up much more if the sun is shining directly at it through the windshield and/or the open roof.

So, my current theory is that the problem with reboots (maybe not with the force closes some seem to experience, but I've seen none) is not really a bug in waze's code but the fact that waze is the one app that heats up my phone most.

If it's quite hot in the car, the phone might overheat and either be rebooted by some security function in Android (though other means like the iPhone's "Please wait for the phone to cool down" would make more sense here) or be forced to reboot by some flipped-over bits in kernel memory or random outcomes of CPU calculations. If some bits run havoc within waze's memory, this might even explain force closes.

I guess it's more likely flipped bits than a security function as I sometimes had no reboots although the phone got so hot I could barely touch it while on other days it was only "rather hot" but there were reboots.

Still, I never experienced a reboot on those cloudy days when the car was not heated up when I drove home, nor did I ever get one when I drove to work in the morning, so I do suspect that heat is at least one of the problems here. My car being quite dark und thus very hot on sunny days might add to the problem.

Any similar experiences?

Best regards,

Christian
zottel
 
Posts: 109
Joined: Wed May 26, 2010 11:38 am
Has thanked: 1 time
Been thanked: 2 times

Re: New Android Beta Version - 1.8.99.106

Postby zottel » Mon Aug 23, 2010 6:45 am

My experiences on a Nexus One, daily use in weekdays:

  • I didn't have problems with 1.8.99.106 ot the other betas before, but I also didn't have Froyo at that time. (Was on Enomther's Eclair ROM at that point that caused reboots (even reboot loops) by itself, but that was completely unrelated to waze, and I don't remember a reboot loop starting when waze was running.)
  • I'm not 100% sure when the rebooting actually started, but I think it was after I updated to stock Froyo.
  • I had quite frequent reboots for some time. They were unrelated to whether the display was on or off or whether I tried to interact with waze or not. (At first I even thought it happened only when the display was off because my first few reboots were in that state.)
  • The reboots seemed to happen only shortly after waze startup at first, but later I found that they also could took place at any other time during the drive.
  • Then the rebooting suddenly stopped maybe three or four weeks ago. I've been driving around daily since then with waze on and without a single reboot—except one day one and a half weeks ago when I had two or three reboots during waze use on one single day.
  • I didn't ever experience any freezes or other, non-rebooting issues; I never had to remove the battery. There are hangs sometimes where waze doesn't update the display and can't be interacted with for ten or twenty seconds, but it always gets back to normal after that. (Though I think when a reboot occurs, it starts with a similar state, for at the few times when I directly saw it happen, there was a frozen display, too.)

The fact that I had so few reboots lately and the only ones on a rather hot day led to me speculating that it could be a temperature issue. But since then there was a much hotter day that showed no issues at all. While temperature issues would of course show unpredictable behaviour, I don't think it's very probable to get several reboots on a rather hot day and later none on a very hot day.

On the reboot day, OTOH, I drove routes that were unkown yet, which has become rather seldom for me. Most routes I drive are different ways to work which have all been well-known to ways for a while now.

But then again, this day was not the only time when I drove unknown roads. Could be the one with the most on one day, though.

Very difficult to nail down, it seems. I hope the waze team will be able to find a solution, but this definitely looks like a horribly difficult-to-fix problem.
zottel
 
Posts: 109
Joined: Wed May 26, 2010 11:38 am
Has thanked: 1 time
Been thanked: 2 times

Previous

Return to Official announcements

Who is online

Users browsing this forum: No registered users