Duda sobre toolbox

Moderators: adriansinger, Unholy, calandraca, robindlc, Brshk1, ukume

Forum rules
Visita nuestra WIKI.

Re: Duda sobre toolbox

Postby crusdepelos » Sat Apr 05, 2014 11:02 pm

Pues un servidor no usa scripts, por lo que si el problema es del editor de Waze entonces la llevo clara.
crusdepelos
Local Champs Localizers
Local Champs Localizers
 
Posts: 1944
Joined: Wed Feb 20, 2013 5:44 am
Has thanked: 1133 times
Been thanked: 831 times

Re: Duda sobre toolbox

Postby crusdepelos » Mon Apr 07, 2014 12:53 pm

elche2011 wrote:
crusdepelos wrote:Pues un servidor no usa scripts, por lo que si el problema es del editor de Waze entonces la llevo clara.

Pues visto lo expuesto aquí es posible, y digo posible, que se te pasen ciertos "detalles"

Aunque ahora entiendo mejor el tema no comprendo a que se debe que tengamos que revisar los permisos de giro que en teoría Waze no debería tener en cuenta pues son de un sentido de la marcha que entiendo que se deshabilita.

A partir de ahora procuraré revisar todos los permisos antes de dar una edición por terminada pero no me extrañaría que en todas las ediciones que he hecho hasta ahora unas cuantas dean error.
Last edited by crusdepelos on Mon Apr 07, 2014 6:03 pm, edited 1 time in total.
crusdepelos
Local Champs Localizers
Local Champs Localizers
 
Posts: 1944
Joined: Wed Feb 20, 2013 5:44 am
Has thanked: 1133 times
Been thanked: 831 times

Duda sobre toolbox

Postby FranciscoLol6 » Sat Apr 05, 2014 11:57 am

Cuando tenemos marcado en toolbox que nos muestre los Soft-Turns como en la imagen nos marca los nodos en color amarillo
Image

Aquí os marco un nodo al azar y me indica que tiene dos Soft-Turns
Image

Sin embargo, al marcar el segmento en cuestión me indica los giros como hard
Image

Según la wiki los Soft-Turns se marcan con un símbolo de interrogación en un círculo de color púrpura
Image

El problema persiste aunque se prohíban los giros en la tercera imagen y se vuelvan a permitir. La única solución que he encontrado es marcar el botón "Prohibir todos los giros" a la izquierda en la segunda imagen y luego ir marcando las flechas rojas una a una (siempre se te puede pasar alguna, sobre todo en tramos largos que no caben en la pantalla)

Mi duda es si el problema es de Waze que no marca bien todos los Soft-Turns o de la herramienta Toolbox. Supongo que si es problema de la herramienta se resolverá en próximas versiones, pero si el problema es de waze hay que tener en cuenta que no todos los editores usan toolbox y puede que las rutas no se calculen correctamente.
"Hay dos cosas infinitas: el Universo y la estupidez humana. Y del Universo no estoy seguro"
Albert Einstein (1879-1955) Científico alemán nacionalizado estadounidense
FranciscoLol6
 
Posts: 165
Joined: Sun Sep 04, 2011 8:57 am
Has thanked: 82 times
Been thanked: 35 times

Re: Duda sobre toolbox

Postby FranciscoLol6 » Mon Apr 07, 2014 11:00 am

ommrianxo wrote:Por lo que veo son segmentos unidireccionales. Los que ves son los giros del sentido habilitado.

Pero los qe no ves, los giros del otro sentido, son los que dan error, y puede dar tres errores:
- los giros ocultos del segmento estan habilitados
- los giros ocultos del segmento estan soft
- los segmentos adyacentes tienen giros permitidos hacia el sentido que no esta habilitado.

Para corregirlo, se pone el segmento con doble sentido, y luego se des/habilitan los giros. Y luego se vuelve a poner todo como estaba.

Enviado como podo


Gracias.

He probado la solución que has indicado y efectivamente se ha solucionado.

El método que yo usaba es más rápido, aunque tal y como yo lo hacía sabía que se arreglaba el problema pero no sabía porqué.

Supongo que este... ¿bug? será el que provoca a veces "curiosas" rutas por las penalizaciones que llevan esos giros ocultos que al ser calles de una sola dirección no vemos. Yo creía que en las calles de una sola dirección sólo había que controlar los giros en el sentido de la marcha (no se me había ocurrido nunca poner estas calles en doble dirección y prohibir los giros del otro sentido)

Image
Image

crusdepelos wrote:Pues un servidor no usa scripts, por lo que si el problema es del editor de Waze entonces la llevo clara.

Pues visto lo expuesto aquí es posible, y digo posible, que se te pasen ciertos "detalles"
"Hay dos cosas infinitas: el Universo y la estupidez humana. Y del Universo no estoy seguro"
Albert Einstein (1879-1955) Científico alemán nacionalizado estadounidense
FranciscoLol6
 
Posts: 165
Joined: Sun Sep 04, 2011 8:57 am
Has thanked: 82 times
Been thanked: 35 times

Re: Duda sobre toolbox

Postby FranciscoLol6 » Mon Apr 07, 2014 5:00 pm

crusdepelos wrote:
crusdepelos wrote:Pues un servidor no usa scripts, por lo que si el problema es del editor de Waze entonces la llevo clara.


Aunque ahora entiendo mejor el tema no comprendo a que se debe que tengamos que revisar los permisos de giro que en teoría Waze no debería tener en cuenta pues son de un sentido de la marcha que entiendo que se deshabilita.

A partir de ahora procuraré revisar todos los permisos antes de dar una edición por terminada pero no me extrañaría que en todas las ediciones que he hecho hasta ahora unas cuantas dean error.


Yo también me he quedado sorprendido
"Hay dos cosas infinitas: el Universo y la estupidez humana. Y del Universo no estoy seguro"
Albert Einstein (1879-1955) Científico alemán nacionalizado estadounidense
FranciscoLol6
 
Posts: 165
Joined: Sun Sep 04, 2011 8:57 am
Has thanked: 82 times
Been thanked: 35 times

Re: Duda sobre toolbox

Postby ommrianxo » Sun Apr 06, 2014 8:47 am

Por lo que veo son segmentos unidireccionales. Los que ves son los giros del sentido habilitado.

Pero los qe no ves, los giros del otro sentido, son los que dan error, y puede dar tres errores:
- los giros ocultos del segmento estan habilitados
- los giros ocultos del segmento estan soft
- los segmentos adyacentes tienen giros permitidos hacia el sentido que no esta habilitado.

Para corregirlo, se pone el segmento con doble sentido, y luego se des/habilitan los giros. Y luego se vuelve a poner todo como estaba.

Enviado como podo
"Sólo sé que no sé nada." Sócrates
"Sólo hay una verdad, el universo es infinito." Proverbio Antiguo, Stargate SG1
Image
ommrianxo
 
Posts: 233
Joined: Fri Aug 23, 2013 2:55 pm
Location: Rianxo, Galicia
Has thanked: 136 times
Been thanked: 85 times

Re: Duda sobre toolbox

Postby ommrianxo » Mon Apr 07, 2014 4:37 pm

crusdepelos wrote:
crusdepelos wrote:Pues un servidor no usa scripts, por lo que si el problema es del editor de Waze entonces la llevo clara.

Pues visto lo expuesto aquí es posible, y digo posible, que se te pasen ciertos "detalles"
Aunque ahora entiendo mejor el tema no comprendo a que se debe que tengamos que revisar los permisos de giro que en teoría Waze no debería tener en cuenta pues son de un sentido de la marcha que entiendo que se deshabilita.

A partir de ahora procuraré revisar todos los permisos antes de dar una edición por terminada pero no me extrañaría que en todas las ediciones que he hecho hasta ahora unas cuantas dean error.


Puede ser error de Waze por no desechar esos datos, o exceso de celo de los script.


https://wiki.waze.com/wiki/How_Waze_calculates_routes
"Sólo sé que no sé nada." Sócrates
"Sólo hay una verdad, el universo es infinito." Proverbio Antiguo, Stargate SG1
Image
ommrianxo
 
Posts: 233
Joined: Fri Aug 23, 2013 2:55 pm
Location: Rianxo, Galicia
Has thanked: 136 times
Been thanked: 85 times


Return to Edición de mapas

Who is online

Users browsing this forum: ifaesfu