Il navigatore mi manda "di lato"

Moderators: asterix06, anto64, Italy Admins

Re: Il navigatore mi manda "di lato"

Postby AndreaDFC » Wed Oct 24, 2012 3:15 pm

Mi sono sempre chiesto una cosa però: con la rotta impostata, Waze rimane agganciato alla strada secondaria, ma se cancello la rotta Waze capisce dove realmente sono e lì si posiziona. Quindi vuol dire che le tracce gps, quelle che poi il sistema visualizza sull'editor, sono corrette; e se Waze usa queste tracce gps per il calcolo della velocità media di un tratto di strada (deve essere così, visto che la raccolta dati funziona anche senza rotta impostata), mi viene il dubbio che questo "magheggio" non serva. Però non ne sono sicuro e quindi per tranquillità anche io faccio come scrive Paolo!
AndreaDFC
Waze Local Champs
Waze Local Champs
 
Posts: 2683
Joined: Wed Nov 24, 2010 2:11 pm
Location: Dueville (Vicenza, Italia)
Has thanked: 1024 times
Been thanked: 576 times

Re: Il navigatore mi manda "di lato"

Postby AndreaDFC » Thu Oct 25, 2012 7:18 am

lopaolo69 wrote:Fai caso che quando annulli un percorso, dopo qualche secondo, se stai realmente percorrendo una strada parallela, diversa da quella evidenziata dal client, Waze, ti sposta su quella giusta (precisione e vicinanza delle strade permettendo).

Esatto, è per questo motivo che ho il dubbio che Waze in realtà registri sempre correttamente la traccia gps sopra la strada giusta e tenda ad agganciare l'icona sulla rotta impostata solo per "motivi grafici" (perchè appena cancelli la rotta, quindi tolto il vincolo "grafico", usa l'unico dato che gli rimane, cioè la posizione gps, e ti rimette sulla parallela giusta: da qui ne deduco che la registrazione gps potrebbe sempre essere corretta).
Ma sono solo ipotesi, non saprei provarle definitivamente.
AndreaDFC
Waze Local Champs
Waze Local Champs
 
Posts: 2683
Joined: Wed Nov 24, 2010 2:11 pm
Location: Dueville (Vicenza, Italia)
Has thanked: 1024 times
Been thanked: 576 times

Re: Il navigatore mi manda "di lato"

Postby Energia00 » Tue Nov 06, 2012 11:30 am

Anche sulla Cristoforo Colombo c'è lo stesso problema.
Prima fa prendere la corsia centrale, poi ti fa spostare a quella laterale (se, ovviamente, non stai puntando al centro...). Io, per motivi di sicurezza, evito sempre questo cambio perché quelle uscite le considero pericolose. Si vede poco e si rischia di avere un incidente. Ancora non capisco perché il comune non le toglie.

In ogni caso, queste due strade parallele creano grande confusione a waze.
Ieri, per esempio, la corsia centrale era bloccata (forse da un incidente). Waze credeva fossi nella corsia centrale, come da lui indicato, mentre io scorrevo veloce nella corsia laterale.
Quindi waze prima mi ha (avrebbe) fatto prendere la corsia centrale per poi passare a quella laterale quando ha visto l'incidente. Superato il blocco mi ha chiesto di tornare nella corsia centrale per poi tornare a quella laterale quando ero in procinto di svoltare per via cilicia.
Un percorso assurdo che non ho assolutamente seguito.

Tecnicamente non è colpa di waze ma del comune che permette questi cambi di corsia. Tuttavia è da tempo che penso che noi potremmo togliere tutti quei cambi di corsia (anche se ci sono...)
Energia00
 
Posts: 331
Joined: Sun Jan 15, 2012 7:53 pm
Has thanked: 1 time
Been thanked: 26 times

Re: Il navigatore mi manda "di lato"

Postby francesco_75 » Mon Oct 22, 2012 8:41 pm

Ciao Francesco, per quanto riguarda il primo problema dipende da qualche permesso di svolta errato in fondo a via Caldarola. In questi giorni devo rivedere quella zona, credo che dalle complanari non sia consentito svoltare a sinistra. Questo risolverebbe il problema.
Per quanto riguarda il secondo, è il solito problema che si verifica con quelle strade di accesso secondarie che sono inutili al pari di quelle nei benzinai, parcheggi, ecc. ecc. che si diramano dalla strada principale per poi reimmettersi più avanti. L'unica alternativa all'eliminazione è metterle come parking lot road.
francesco_75
 
Posts: 144
Joined: Thu Sep 22, 2011 9:09 pm
Location: Bari, Italy
Has thanked: 0 time
Been thanked: 0 time

Re: Il navigatore mi manda "di lato"

Postby francesco_75 » Tue Oct 23, 2012 7:37 am

Le ho messe come parking, al prossimo update il problema sparirà ;)

Edit:
aggiungo che la motivazione per cui ti manda sulla strada secondaria è che quel tratto di SP60 ha una velocità media di appena 3 km/h :shock:
Attachments
sp60.png
sp60.png (9.91 KiB) Viewed 428 times
francesco_75
 
Posts: 144
Joined: Thu Sep 22, 2011 9:09 pm
Location: Bari, Italy
Has thanked: 0 time
Been thanked: 0 time

Re: Il navigatore mi manda "di lato"

Postby francesco_75 » Wed Oct 24, 2012 9:18 am

Concordo con lopaolo69, inoltre nel secondo caso c'è anche un altro problema: ci sono molte tracce GPS che passano sulla strada secondaria. Spesso mi è capitato di vedere su queste strade velocità medie superiori a quelle della strada principale e me lo sono spiegato in questo modo: io penso che passando col navigatore acceso e senza una rotta impostata può capitare che l'imprecisione del GPS faccia credere al navigatore che si stia passando per la strada secondaria andando difatti a modificare la velocità media di quella strada. Quindi, anche ammesso che si voglia farlo, passare lentamente per quella strada non farebbe altro che rimandare il problema. Tutto questo IMHO, naturalmente.
francesco_75
 
Posts: 144
Joined: Thu Sep 22, 2011 9:09 pm
Location: Bari, Italy
Has thanked: 0 time
Been thanked: 0 time

Re: Il navigatore mi manda "di lato"

Postby francesco_75 » Mon Oct 29, 2012 11:52 pm

FrengoOhFrengo wrote:
francesco_75 wrote:Ciao Francesco, per quanto riguarda il primo problema dipende da qualche permesso di svolta errato in fondo a via Caldarola. In questi giorni devo rivedere quella zona, credo che dalle complanari non sia consentito svoltare a sinistra.


Credo di sì invece (ricontrollerò appena torno sul posto)

Secondo le velocità medie riportate nello script il percorso sulla primary sarebbe più favorevole, forse in alcune fasce orarie la strada laterale ha una media migliore. Ho comunque modificato un po' la geometria delle strade, vediamo al prossimo update.

FrengoOhFrengo wrote:
francesco_75 wrote:Per quanto riguarda il secondo, è il solito problema che si verifica con quelle strade di accesso secondarie che sono inutili al pari di quelle nei benzinai, parcheggi, ecc. ecc. che si diramano dalla strada principale per poi reimmettersi più avanti. L'unica alternativa all'eliminazione è metterle come parking lot road.


francesco_75 wrote:Le ho messe come parking, al prossimo update il problema sparirà ;)

Edit:
aggiungo che la motivazione per cui ti manda sulla strada secondaria è che quel tratto di SP60 ha una velocità media di appena 3 km/h :shock:


Giuro che io ci passo un po' più veloce :?

Diciamo che si tratta di un bug dell'algoritmo di routing, allora.

Sempre con lo script rilevo una velocità simile sia sulla SP60 che sulla strada laterale (82 vs 79) e accade la stessa cosa anche con le altre strade secondarie che si trovano lì vicino. Direi che la soluzione ottimale in questo caso è metterle come parking lot.
francesco_75
 
Posts: 144
Joined: Thu Sep 22, 2011 9:09 pm
Location: Bari, Italy
Has thanked: 0 time
Been thanked: 0 time

Il navigatore mi manda "di lato"

Postby FrengoOhFrengo » Mon Oct 22, 2012 7:31 pm

Mi succede sempre quando passo da questi due tratti di strada:

il primo https://it.waze.com/editor/?lon=16.9049 ... TTTTTTTTFT

Waze Map Editor_1350930766538.jpg
Bari, Via Caldarola
Waze Map Editor_1350930766538.jpg (236.18 KiB) Viewed 470 times


percorrendo Via Caldarola, che è una primary street che per un certo tratto è affiancata da una street, separata da un marciapiede. Waze mi fa sempre andare sulla street, senza motivo.


il secondo: https://it.waze.com/editor/?lon=16.9424 ... TTTTTTTTFT

Waze Map Editor_1350930851851.jpg
Triggiano (BA), SP60
Waze Map Editor_1350930851851.jpg (164.23 KiB) Viewed 474 times


qui, passando dalla SP60, Waze vuol sempre mandarmi a fare un giretto sulla service road a fianco. Anche qui, senza nessuna ragione.


Non mi pare che ci siano problemi nelle mappe, però.
FrengoOhFrengo
 
Posts: 25
Joined: Tue Sep 11, 2012 7:03 pm
Has thanked: 0 time
Been thanked: 1 time

Re: Il navigatore mi manda "di lato"

Postby FrengoOhFrengo » Thu Oct 25, 2012 9:00 pm

francesco_75 wrote:Ciao Francesco, per quanto riguarda il primo problema dipende da qualche permesso di svolta errato in fondo a via Caldarola. In questi giorni devo rivedere quella zona, credo che dalle complanari non sia consentito svoltare a sinistra.


Credo di sì invece (ricontrollerò appena torno sul posto)


francesco_75 wrote:Per quanto riguarda il secondo, è il solito problema che si verifica con quelle strade di accesso secondarie che sono inutili al pari di quelle nei benzinai, parcheggi, ecc. ecc. che si diramano dalla strada principale per poi reimmettersi più avanti. L'unica alternativa all'eliminazione è metterle come parking lot road.


francesco_75 wrote:Le ho messe come parking, al prossimo update il problema sparirà ;)

Edit:
aggiungo che la motivazione per cui ti manda sulla strada secondaria è che quel tratto di SP60 ha una velocità media di appena 3 km/h :shock:


Giuro che io ci passo un po' più veloce :?

Diciamo che si tratta di un bug dell'algoritmo di routing, allora.
FrengoOhFrengo
 
Posts: 25
Joined: Tue Sep 11, 2012 7:03 pm
Has thanked: 0 time
Been thanked: 1 time

Re: Il navigatore mi manda "di lato"

Postby IN3FQC » Wed Oct 24, 2012 5:33 am

Per sistemarle ci sono due trucchi:
  1. se possibile percorrerle, ti prendi un po' di tempo e le percorri per alcuni giorni a bassissima velocità, finché Waze non cala di molto la velocità media;
  2. fai perdere a Waze la voglia di passare su quella strada, per esempio puoi:
    • togliere il senso di marcia mettendolo su unknown;
    • cancellare e ridisegnare da capo la strada;
    • bloccare le svolte in quella strada;
    • trasformare la strada in pedestrian boardwalk.
La prima soluzione è immediata ed efficace: l'ho sfruttata quando Waze mi consigliava di passare per un'area di servizio e la volta dopo il problema era risolto. La seconda soluzione richiede un po' più di tempo, perché devi aspettare l'aggiornamento delle map tiles, l'acquisizione della corretta velocità media sul tratto di vera strada, reimpostare le secondarie com'erano e infine, attendere nuovamente l'aggiornamento delle map tiles, che si traduce in due mesi di lavoro quando va bene. :ugeek:
IN3FQC
 
Posts: 960
Joined: Wed Aug 03, 2011 7:30 pm
Has thanked: 2 times
Been thanked: 9 times

Next

Return to Client: il nostro navigatore sul telefono

Who is online

Users browsing this forum: No registered users