iPhone beta version 3.0.99.20 - Official feedback post

These forums are specific to the Waze mobile app. Post here if you experienced a problem while using the app, have a question about the app functionality or a feature such as navigation or search.

Moderators: Unholy, bextein

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby RallyChris » Tue Feb 07, 2012 6:42 pm

I can also report that it appears to be fixed for road munching. I have though filed a separate report for it doing the same behavior on long standing roads. My guestimate is that it had to do with network switching between 3g and edge a couple times in a short distance.
RallyChris
 
Posts: 2084
Joined: Thu Aug 20, 2009 8:19 pm
Has thanked: 0 time
Been thanked: 13 times

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby AlanOfTheBerg » Tue Feb 07, 2012 5:54 pm

Road munching stable (when not navigating)
I munched some new roads this morning and can report that the iPhone client correctly followed the location instead of doing the jumping back-and-forth thing which has been reported previously. I was not in navigation mode, so it remains to be seen if navigation mode may affect proper display behavior.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23612
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1126 times
Been thanked: 4797 times

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby AlanOfTheBerg » Mon Feb 06, 2012 6:53 pm

Dave2084 wrote:CamerAlert hasn't been updated since march but it's only in this Waze beta I've noticed this issue.

The code has changed trying to deal with the "play output to speaker" option to work better, which it does. But it seems to have negatively affected the stability and reliability of the audio output overall.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23612
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1126 times
Been thanked: 4797 times

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby AlanOfTheBerg » Mon Feb 06, 2012 4:19 pm

Dave2084 wrote:I've experienced two occurrences of the audio stopping; once on Thursday evening and once at 6am this morning. I just uploaded the debug mode logs, hopefully they will be useful.

Did you have any other audio running from the phone at the same time, like a streaming app or the music app? If so, what interface? (headphone jack, USB/dock, or BT) I also experience this issue from time-to-time and a restart of Waze is the only solution. As I've mentioned above in a couple posts, the audio has issues. I think it would be worth it to lay out the options from scratch and come up with a stable solution.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23612
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1126 times
Been thanked: 4797 times

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby FrisbeeDog » Sun Feb 05, 2012 8:34 pm

Long-time, super minor annoyance (not just in this version):

Settings > Advanced > Data Transfer

The "Refresh map of my area" button should not be in the "Reduce data usage" section. From what it does it actually induces more data usage (albeit very little) while the client pulls down the latest tiles.

You just need to move the button above the label for it to make sense.
FrisbeeDog
 
Posts: 310
Joined: Tue Dec 01, 2009 2:13 am
Location: Apex, NC
Has thanked: 0 time
Been thanked: 0 time

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby AlanOfTheBerg » Thu Feb 02, 2012 7:05 pm

sketch wrote:I see. I have play through speaker off. Does that now work reliably?

More or less. I haven't done exhaustive testing. I have noted that it will sometimes stop sending audio to the speaker, but then haven't gone to see if it's sending it over BT. (I don't always have BT streaming running.)

With the current setup, the playback/pause also seems to get confused, and the audio playback gets paused "permanently." I can restart it in the Music app or from the car stereo, but again, haven't tested that enough to come up with a repeatable scenario.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23612
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1126 times
Been thanked: 4797 times

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby sketch » Thu Feb 02, 2012 7:02 pm

I see. I have play through speaker off. Does that now work reliably?

The best way to test this would be to cycle through each type of audio connection and each of those two settings, with Bluetooth handsfree on or off, and keep track of the results. I don't have Bluetooth audio (A2DP) capability, but I can do everything else.
sketch
Waze Global Champs
Waze Global Champs
 
Posts: 6076
Joined: Sat Aug 08, 2009 6:13 pm
Location: New Orleans, LA
Has thanked: 1534 times
Been thanked: 2074 times

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby AlanOfTheBerg » Thu Feb 02, 2012 6:59 pm

sketch wrote:Alan, what were your settings? Were you listening through USB or through the headphone jack?

Waze Prefer BT off
Waze play audio through speaker always on
Audio is playing from the Music app through BT to the car stereo
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23612
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1126 times
Been thanked: 4797 times

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby sketch » Thu Feb 02, 2012 6:54 pm

Please, please, please, please, please make the pause an option.

It's nice for audiobooks and podcasts, yeah, but I never listen to those. When I'm listening to music and it pauses the song, I'm thrown off the rhythm entirely. It's pretty jarring.

As it stands now, I haven't tested it much, but this is how it seems to work:

Prefer Bluetooth on: Music fades out. Music pauses. Instruction plays through audio connection. Music resumes. Music fades in.

Prefer Bluetooth off: Music fades out but continues to play. Instruction plays over music through audio connection. Music fades in.

These scenarios assume that music is playing through a USB audio connection and that a Bluetooth handsfree device is connected.

Also, and this is the weird one: whether or not Prefer Bluetooth is enabled, if music is playing right when the app is launched, the music will fade out, pause for a couple seconds, then start and fade back in, as if a turn instruction were being given with Prefer Bluetooth on.

Alan, what were your settings? Were you listening through USB or through the headphone jack?
sketch
Waze Global Champs
Waze Global Champs
 
Posts: 6076
Joined: Sat Aug 08, 2009 6:13 pm
Location: New Orleans, LA
Has thanked: 1534 times
Been thanked: 2074 times

Re: iPhone beta version 3.0.99.20 - Official feedback post

Postby AlanOfTheBerg » Thu Feb 02, 2012 6:31 pm

Audio ducking/pausing
I was really pleasantly surprised to discover that Waze is pausing my Music (iPod) playback of an audiobook in order to give me the navigation instructions. This is very nice.

But, there is a problem with the implementation. Here's the process:

  1. The audio fades out
  2. The audio pauses
  3. Waze announcement plays
  4. Audio unpauses
  5. Audio fades in

This sounds reasonable, and in general, is mostly OK. However, during the fade-out and fade-in, when listening to an audiobook especially, words are lost and it is a bit difficult to follow the sentence with 2-3 words being inaudible.

I am not sure what the best answer to this is. I think a hard-stop would be OK, but if it's possible, I would make the fade-out a lot shorter. Even as short as .1 seconds.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23612
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1126 times
Been thanked: 4797 times

Next

Return to Waze App

Who is online

Users browsing this forum: Google [Bot]