Missing drives since iOS app 3.5 upgrade

These forums are specific to the Waze mobile app. Post here if you experienced a problem while using the app, have a question about the app functionality or a feature such as navigation or search.

Moderators: Unholy, bextein

Missing drives since iOS app 3.5 upgrade

Postby AlanOfTheBerg » Sun Nov 04, 2012 3:28 pm

Did you submit any map issues in the missing drive ?
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23614
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1128 times
Been thanked: 4823 times

Re: Missing drives since iOS app 3.5 upgrade

Postby therubinator » Sun Nov 04, 2012 8:29 pm

AlanOfTheBerg wrote:Did you submit any map issues in the missing drive ?


I don't think so. But I'll keep that in mind next time I notice a missing drive.
therubinator
 
Posts: 37
Joined: Fri Aug 17, 2012 4:57 pm
Location: Toronto
Has thanked: 4 times
Been thanked: 0 time

Re: Missing drives since iOS app 3.5 upgrade

Postby zexpe » Tue Nov 06, 2012 3:18 pm

My current theory is that these are drives that were shared with friends _and_ a friend actually viewed the link.
zexpe
 
Posts: 195
Joined: Mon Sep 24, 2012 2:40 pm
Has thanked: 15 times
Been thanked: 11 times

Re: Missing drives since iOS app 3.5 upgrade

Postby therubinator » Tue Nov 06, 2012 3:19 pm

zexpe wrote:My current theory is that these are drives that were shared with friends _and_ a friend actually viewed the link.


Not mine. Haven't shared any drives at all.
therubinator
 
Posts: 37
Joined: Fri Aug 17, 2012 4:57 pm
Location: Toronto
Has thanked: 4 times
Been thanked: 0 time

Re: Missing drives since iOS app 3.5 upgrade

Postby jasonh300 » Tue Nov 06, 2012 3:34 pm

My theory is that if you end a drive and Waze can't immediately make an internet connection to upload the drive, the drive gets lost. I thought it had to do with leaving Update Requests, but proved that wrong. And sharing drives has never been done on any drive that has been lost for me.

This issue has been reported to the developers and they have acknowledged it and are looking into it, so I'll report back here as soon as I hear something.
jasonh300
 
Posts: 7568
Joined: Fri Oct 28, 2011 4:26 pm
Location: New Orleans, LA, USA
Has thanked: 408 times
Been thanked: 986 times

Re: Missing drives since iOS app 3.5 upgrade

Postby CBenson » Tue Nov 06, 2012 3:38 pm

jasonh300 wrote:My theory is that if you end a drive and Waze can't immediately make an internet connection to upload the drive, the drive gets lost.

But you shouldn't lose the whole drive. At worst shouldn't you only lose from where you lost the internet connection.
CBenson
 
Posts: 10330
Joined: Wed Nov 03, 2010 9:13 pm
Location: Crownsville, MD, US
Has thanked: 1069 times
Been thanked: 2356 times

Re: Missing drives since iOS app 3.5 upgrade

Postby WeeeZer14 » Tue Nov 06, 2012 4:18 pm

CBenson wrote:
jasonh300 wrote:My theory is that if you end a drive and Waze can't immediately make an internet connection to upload the drive, the drive gets lost.

But you shouldn't lose the whole drive. At worst shouldn't you only lose from where you lost the internet connection.

1.) URs may be involved in that it means there is more data for the drive thus more data to upload.
2.) Data compression is turned on by default now. Client must be caching data to compress chunks and send. So it is possible we lose the buffer on shut down if it isn't successfully flushed.

If buffer is based on size alone, it may be good to change to size OR time if the size is fairly large (say over 10 minutes worth of driving).
WeeeZer14
 
Posts: 3761
Joined: Sun Apr 11, 2010 3:27 pm
Location: Knoxville, TN, USA
Has thanked: 46 times
Been thanked: 317 times

Re: Missing drives since iOS app 3.5 upgrade

Postby zexpe » Tue Nov 06, 2012 4:26 pm

WeeeZer14 wrote:Data compression is turned on by default now.

Now that's interesting; so there is no way to turn off data compression now?
zexpe
 
Posts: 195
Joined: Mon Sep 24, 2012 2:40 pm
Has thanked: 15 times
Been thanked: 11 times

Re: Missing drives since iOS app 3.5 upgrade

Postby AlanOfTheBerg » Tue Nov 06, 2012 4:27 pm

zexpe wrote:
WeeeZer14 wrote:Data compression is turned on by default now.

Now that's interesting; so there is no way to turn off data compression now?

No.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23614
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1128 times
Been thanked: 4823 times

Re: Missing drives since iOS app 3.5 upgrade

Postby AlanOfTheBerg » Tue Nov 06, 2012 4:30 pm

- My morning commute drive showed up within 5 min.
- My morning commute yesterday is available.
- My afternoon commute hasn't appeared yet.

All are nearly exactly the same distance traveled. Drive processing is clearly not happy with something happening during some drives.
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23614
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1128 times
Been thanked: 4823 times

PreviousNext

Return to Waze App

Who is online

Users browsing this forum: Google Feedfetcher