have to turn GPS off and on to get location

These forums are specific to the Waze mobile app. Post here if you experienced a problem while using the app, have a question about the app functionality or a feature such as navigation or search.

Moderator: Unholy

have to turn GPS off and on to get location

Postby Bricarpent » Wed Apr 09, 2014 11:14 pm

Having an issue with my waze app, every time I open the app I get no GPS, I have found if I pull the drop down menu and turn the GPS off then back on fixes the problem till the next time I start waze. Anyone else having this issue? Using Samsung GALAXY 4
Bricarpent
 
Posts: 1
Joined: Mon Feb 27, 2012 11:11 pm
Has thanked: 0 time
Been thanked: 0 time

Re: have to turn GPS off and on to get location

Postby dno188 » Sun Sep 14, 2014 12:39 pm

Same problem on S4 - has made Waze totally unusable recently, unless you drive with the drop down turn by turn directions on and listen to the voice cues. The fact that this problem only effects Waze (my wife has no probs in the same areas on her Iphone) and that three others i know locally have the same problems with various Samsung Galaxy phones suggests the problem is specific to the OS and app and not GPS.
I've seen this reported on so many forums but no solutions. Have reinstalled, installed GPS kits - in short, I've used Waze for 5 years but have to use other apps at the moment. WAZE - some answers pls!
dno188
 
Posts: 1
Joined: Sun Sep 14, 2014 12:29 pm
Has thanked: 0 time
Been thanked: 0 time

Re: have to turn GPS off and on to get location

Postby dootcze » Mon Sep 15, 2014 2:55 pm

same issue with Sony Xperia Z - I send it to service, but same behavior when I got it back.
My last trick is to start GPS Status app and wait till It fix position (<20s) and start waze. Most of time waze works fine. If it loose signal I select GPS status and let waze run on background and just use voice navigation.
It looks like waze has problem to communicate with gps module/keep it live .
dootcze
 
Posts: 4
Joined: Fri Nov 15, 2013 2:01 pm
Has thanked: 0 time
Been thanked: 0 time

Re: have to turn GPS off and on to get location

Postby gsmithhart » Wed Jul 23, 2014 6:17 pm

I am having this exact same problem. I also have to start/stop my GPS every time I open Waze. It all started when the latest version of Waze rolled out last week. It has nothing to do with the GPS signal. My location service works fine on the Google maps side. And of course when I start/stop the GPS, Waze is just fine. Just a pain to have to do this every time.

BTW, I am on the Galaxy 3.

Greg.
gsmithhart
 
Posts: 1
Joined: Sat Jan 11, 2014 3:17 am
Has thanked: 0 time
Been thanked: 0 time

Re: have to turn GPS off and on to get location

Postby homebrew01 » Mon Aug 04, 2014 6:52 pm

Same here on my htc android. Seems like it started a month or 2 ago. Random "No GPS" signal, while my regular map app knows exactly where I am. I have not tried turning gps off & on, but would rather not have to do much while driving.

Getting a bit frustrated with Waze lately. I have not seen any useful improvements since I joined last year. Is there just 1 guy in a basement somewhere working on this app ?
homebrew01
 
Posts: 26
Joined: Mon Apr 29, 2013 12:48 pm
Has thanked: 0 time
Been thanked: 0 time

Re: have to turn GPS off and on to get location

Postby JimFromIL » Thu Jul 31, 2014 2:24 am

gsmithhart wrote:I am having this exact same problem. I also have to start/stop my GPS every time I open Waze. It all started when the latest version of Waze rolled out last week. It has nothing to do with the GPS signal. My location service works fine on the Google maps side. And of course when I start/stop the GPS, Waze is just fine. Just a pain to have to do this every time.

BTW, I am on the Galaxy 3.

Greg.


I too, have noticed the exact same issue: no GPS signal on a Samsung G-S4, on Kit-Kat - not rooted. It seems random, but mainly when I launch the app, (either leaving for work, and/or leaving from work). Just started happening week of July 28, (since 3.8.1 also). Too early to tell if this is a bug or not. At least other G-S4 users are having the same issue. :|
JimFromIL
 
Posts: 18
Joined: Thu Feb 27, 2014 1:44 pm
Has thanked: 5 times
Been thanked: 3 times

Re: have to turn GPS off and on to get location

Postby jricardogarcia » Mon Aug 04, 2014 4:54 pm

Hi, I have the same problem. My phone is Milestone3 with android 2.3.
After last update, my GPS sometimes finds no sign. I installed GPS Status App and when use with Waze on finds no signal. When I open before Waze, sometimes works.
AGPS and Navfree work perfectly.
Some information if this is a bug of the last update?

Thanks.
jricardogarcia
 
Posts: 5
Joined: Thu Oct 10, 2013 12:01 am
Has thanked: 0 time
Been thanked: 1 time

Re: have to turn GPS off and on to get location

Postby MGODLEW » Wed Aug 13, 2014 4:26 pm

homebrew01 wrote:Getting a bit frustrated with Waze lately. I have not seen any useful improvements since I joined last year. Is there just 1 guy in a basement somewhere working on this app ?

A lot of improvements have come to the Routing Engine (behind the scenes) per say. Waze is currently working on plenty of new features and does hear the requests for additional ideas. However, it does take time to develop new features on top of existing development plans/features they already have in planned to implement.
Image
Rank 6 US Champ, Waze Mentor & iOS Beta Tester | Waze Wishlist | Improper Edits | iPhone 6: JB iOS 8.1.2 |
Area Managing: State of Pennsylvania
MGODLEW
US Waze Champs
US Waze Champs
 
Posts: 1662
Joined: Tue Dec 20, 2011 6:39 pm
Location: Pennsylvania
Has thanked: 595 times
Been thanked: 492 times

Re: have to turn GPS off and on to get location

Postby Rokcet » Thu Apr 10, 2014 3:04 am

Superfraggle wrote:Yes I have had this issue. But it's not every time. Same phone as well. But as I also run another app at the same time which also uses GPS and has the same problem. I think it's a problem on the phone/OS


OR a problem with GPS signal reception at that particular location.
The other day I followed a (seasoned) visitor to Manhattan there with Glympse, an excellent tracker app. The signal was bouncing and jerking all over the place. Erratic jumps all over Broadway of 100 to 200 feet. While the phone in question was sitting, unmoving, on a table top in a coffee corner there. That was the GPS signals (multiple moving overhead satellites, remember) bouncing off of the concrete canyon walls, of course. Making a real fix impossible. Showing 'shadow' fixes instead.
Just to illustrate that individual situations vary, and matter.
I.o.w. I'm not so convinced this problem of yours is phone or OS related.
Rokcet
 
Posts: 136
Joined: Fri Sep 09, 2011 5:49 am
Has thanked: 0 time
Been thanked: 6 times

Re: have to turn GPS off and on to get location

Postby Rokcet » Thu Apr 10, 2014 2:01 pm

Superfraggle wrote:I don't think its signal, the GPS module doesn't appear to even start. The GPS Icon does not show in the notification bar, turning off GPS and turning it back on again, causes the GPS to show, and start flashing whilst it locks on and then stays solid once locked, as per usual.

If it was shadowed I would expect a lock, but incorrect location, and if it was poor/no signal I would expect to see just the flashing GPS icon, but there is NO GPS Icon, suggesting the GPS module is not loading.


You have a point.

But your S4 is probably not under warranty anymore, is it?

If not, rooting might be an alternative to reconfigure the GPS module's behavior.
Rokcet
 
Posts: 136
Joined: Fri Sep 09, 2011 5:49 am
Has thanked: 0 time
Been thanked: 6 times

Next

Return to Waze App

Who is online

Users browsing this forum: Yahoo [Bot]