iOS beta 3.5.1.993 feedback thread

Moderators: Unholy, hilaroth

iOS beta 3.5.1.993 feedback thread

Postby kieranrawley » Fri Dec 28, 2012 3:53 pm

Forgot to add iPhone 4


It's a bit better/worse (delete as required) again today
(I'll go for a run when I've got this little bit sorted..........)

ImageImageImage
kieranrawley
Waze Global Champs
Waze Global Champs
 
Posts: 175
Joined: Sat Feb 06, 2010 7:25 pm
Has thanked: 0 time
Been thanked: 5 times

Re: iOS beta 3.5.1.993 feedback thread

Postby npv1459 » Fri Dec 28, 2012 9:12 pm

bone0369 wrote:When iPhone is in horizontal position, keyboard will not appear when cursor is active in the search window. Rotating back to vertical the keyboard appears. Was attempting to search for a business when this occurred on iPhone 5, iOS 6.0.2.


I just confirm that!
When try to search an address in landscape mode with iphone keyboard will not appear.
I use an iphone 4 no JB with IOS 6.0.1
Image
See my area Here
npv1459
 
Posts: 198
Joined: Tue Sep 14, 2010 8:13 am
Location: Casoria (NA)
Has thanked: 10 times
Been thanked: 14 times

Re: iOS beta 3.5.1.993 feedback thread

Postby jasonh300 » Sat Dec 29, 2012 12:22 am

Today at 5:15 pm (23:15 GMT), Waze simply turned off. When I turned it back on, it came up in night mode. Sunset was at 5:08 pm. It didn't automatically switch.

I sent logs shortly afterwards, but it took about 10-15 minutes because there was like 250 to send.
Image
New Orleans, Louisiana, USA
Regional Coordinator, South-Central Region
U.S. Champ, Global Champ
Waze FAQ ... Best Map Editing Practice
Ask me about Louisiana or Mississippi Editors Chat in Google Hangouts!
jasonh300
Waze Global Champs
Waze Global Champs
 
Posts: 7528
Joined: Fri Oct 28, 2011 4:26 pm
Location: New Orleans, LA, USA
Has thanked: 393 times
Been thanked: 961 times

Re: iOS beta 3.5.1.993 feedback thread

Postby Shorty-CM » Sat Dec 29, 2012 12:24 am

How long had it been running before it crashed? I've noticed it sometimes doesn't change to night mode, and usually it has been open for quite a while when it doesn't switch. It's been doing that for quite a few versions, now.
Shorty-CM
Waze Global Champs
Waze Global Champs
 
Posts: 646
Joined: Sun Sep 20, 2009 9:56 pm
Location: Parksville, BC, Canada
Has thanked: 0 time
Been thanked: 7 times

Re: iOS beta 3.5.1.993 feedback thread

Postby Shorty-CM » Sat Dec 29, 2012 12:33 am

This version also behaves very poorly in relation to music playback and car stereo connections. If I forget to exit Waze and disconnect from the car stereo before starting the vehicle back up it makes the whole device act strangely. Music playback doesn't begin. Forcing it to pause/play doesn't help. The device acts like something is caught in a horrible loop and gets incredibly unresponsive, requiring me to shut down and reboot the device, *if* I can even get it to respond well enough to get it to shut down.

It's incredibly frustrating when I start the work truck back up and notice that I forgot to exit Waze, and the "Kaaaaaaaahn!" -style NOOOOOOOO! begins echoing around inside the truck, haha.

I don't know how the connection/communication differs when starting the vehicle versus simply plugging the device into the stereo that's already up and running, but I don't think I've seen this unresponsive loop behaviour in that scenario. But I think 9/10 times when I do this if Waze is running the music won't start playing. The stereo goes through the normal 'reading' phase and then brings up the current track's name but is blinking as though playback is paused, which it shouldn't be. When this happens, sometimes simply exiting Waze will automatically start playback again. Sometimes it does not, and I have to disconnect the device from the stereo and plug it back in again. 1/10 times pressing pause/play will start playback again in that scenario, but it's usually faster just to unplug and replug rather than try hitting pause/play over and over and hope it works.

As a result, my usual routine when getting out of the truck is to grab my phone and exit Waze so that when we're getting back in and taking off again it is already out of Waze and obviously disconnected from the stereo. If I connect to the stereo first, and wait for music playback to start, and *then* fire up Waze everything will be just fine for the duration. But if Waze is running before connecting, whether or not the vehicle was already running, it is just going to be a disaster of some sort.

A version or two ago seemed to have all the volume and music playback problems sorted out, so I don't know what has changed, but it is once again broken, and is worse than ever in some respects. At least the volume problems haven't returned, so that part still works properly.
Shorty-CM
Waze Global Champs
Waze Global Champs
 
Posts: 646
Joined: Sun Sep 20, 2009 9:56 pm
Location: Parksville, BC, Canada
Has thanked: 0 time
Been thanked: 7 times

Re: iOS beta 3.5.1.993 feedback thread

Postby Scorp42 » Sat Dec 29, 2012 5:50 am

The current app store version of Waze works with the pioneer appradio. However the screen is displayed off-center and is therefore mostly unusable. I installed the beta via testflight, hoping appradio support had been fixed.

The result:
Appradio support seems to have been completely removed now. The app starts on the iphone, then rather than showing the usual "pioneer disconnect" screen, it now shows the Waze app on both screens as if it was just a mirrored video port. If I hold the phone horizontal, the Waze app rotates to horizontal view on the iphone. It also stretches the display on the pioneer unit (which frankly, looks horrible)

If I turn the phone to landscape view, both screens display it, and it looks great on the pioneer.

In either mode ( landscape or horizontal) the pioneer touch screen is unavailable. The Waze app appears to be using a display-only mode. No touch input us accepted from the pioneer. However, the iphone accepts touch input as it always has.

Waze app: 3.5.1.993
Iphone 4 64gb art gsm
Jo's 6.0.1. Not jailbroken
Pioneer avh-p8400bh radio in advanced app mode.
(Cable appears to be ok, other apps continue to work)


Sent from my Kindle Fire using Tapatalk 2
iPhone 4 (AT&T GSM)
iOS 6.0.1 - nonjailbroken
Waze - 3.5.1.998
Scorp42
 
Posts: 225
Joined: Wed Dec 07, 2011 9:21 pm
Location: Southwest Florida
Has thanked: 1 time
Been thanked: 5 times

Re: iOS beta 3.5.1.993 feedback thread

Postby jasonh300 » Sat Dec 29, 2012 6:03 am

Shorty-CM wrote:How long had it been running before it crashed? I've noticed it sometimes doesn't change to night mode, and usually it has been open for quite a while when it doesn't switch. It's been doing that for quite a few versions, now.


For the past couple of weeks, with Sunset falling just past 5:00, I've been in the car at sunset almost every day, and since I've been watching it, it hasn't made the change automatically. But if I shut it down and reopen, it will come back in night mode.

Today when it crashed, Waze had probably been running for about an hour. I was actually looking at the screen, stopped at a light, watching the traffic popups on the screen. It just shut off. The only reason why I was thinking it had something to do with the night mode was because I noticed the switch when I brought it back up. I was thinking that sunset was at 5:15, which would have said a lot, but I checked my almanac app and sunset was at 5:08 at my location.
Image
New Orleans, Louisiana, USA
Regional Coordinator, South-Central Region
U.S. Champ, Global Champ
Waze FAQ ... Best Map Editing Practice
Ask me about Louisiana or Mississippi Editors Chat in Google Hangouts!
jasonh300
Waze Global Champs
Waze Global Champs
 
Posts: 7528
Joined: Fri Oct 28, 2011 4:26 pm
Location: New Orleans, LA, USA
Has thanked: 393 times
Been thanked: 961 times

Re: iOS beta 3.5.1.993 feedback thread

Postby sketch » Sun Dec 30, 2012 2:31 am

BIG problem.

Remember that old bug that made Waze unable to connect to the Waze network over cellular connections after leaving the range of the WiFi that the app connected to when first opened? Looks like it's back, and with a vengeance.

Now, if I open the beta within range of my home WiFi, every time I drive away, the app freezes up completely, and the LTE connection on my phone stops working entirely.

Nothing short of switching the phone into and out of airplane mode fixes it. If I close and reopen Waze, it crashes on the first relaunch, and if I relaunch it a second time and try to plan a route with no connectivity, the app freezes again.

It's a bit of a surprising bug, and it may have something to do with iOS, because typically iOS apps aren't given the kind of control necessary to affect these kinds of low-level OS tasks... but it's happened a few times now. I'm using an iPhone 5 with iOS 6.0.2 over the AT&T network.
ALL US EDITORS READ: New USA road type guidance
new orleans based • detroit enthusiast • usa country manager
2013 ford focus titanium hatchback 5mt • performance blue
Image Image
sketch
Waze Global Champs
Waze Global Champs
 
Posts: 5651
Joined: Sat Aug 08, 2009 6:13 pm
Location: New Orleans, LA
Has thanked: 1225 times
Been thanked: 1673 times

iOS beta 3.5.1.993 feedback thread

Postby AlanOfTheBerg » Sun Dec 30, 2012 2:48 am

sketch wrote:BIG problem.

That is very surprising. I've not experienced this yet. Same phone/OS on Verizon.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 9.3.1 | Waze v4.4.9904
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23436
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1079 times
Been thanked: 4543 times

iOS beta 3.5.1.993 feedback thread

Postby AlanOfTheBerg » Sun Dec 30, 2012 2:49 am

The following ETA popped up today. Pretty nonsensical. It did not save me 11+ hours on a 35 min route.
ImageUploadedByTapatalk1356835730.224928.jpg
ImageUploadedByTapatalk1356835730.224928.jpg (63.48 KiB) Viewed 1815 times


Logs uploaded at 7:03PM GMT.
Wiki Resources: Map Editing Manual | alanoftheberg@gmail.com
Oregon-based US Country Manager | iPhone6 - VZ - iOS 9.3.1 | Waze v4.4.9904
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23436
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1079 times
Been thanked: 4543 times

PreviousNext

Return to App Beta Testing

Who is online

Users browsing this forum: No registered users