Routing Server Timeouts / Failed Routes for long routes

Moderators: Unholy, bextein

Routing Server Timeouts / Failed Routes for long routes

Postby PesachZ » Wed Dec 30, 2015 6:20 pm

Hi team, we need your help, especially European testers.

Re: 'Routing server timeout', and 'Cannot find a route' errors on long (>100mi/150km) routes

Over the past several months there has been an increase of users getting Routing server timeouts, and not able to generate long (>100 mi/150 km) routes. This has been especially troublesome during the day. We have already seen hundreds of complaints from Wazers using the production client in the forums, local Google Hangouts, and URs sent when their routes fail. Many of these routes which are now failing, used to work flawlessly before, making it more disconcerting to users. Every few days I hear from another editor about "can't get a route from X to Y"
Some routes as short as 150 mi fail, other routes as long as 6-800 mi work. Some routes work only in middle of the night, or when there is no construction/closures along the way.

Another variable making the issue worse is when the client is set to 'Avoid tolls'. This requires the server to calculate the route and them look for alternatives which do not include tolls. This requires additional route calculations, which increases the chances of the server timing out before a route can be completed.

This issue started being a nuisance almost a year ago. It has gotten markedly worse around November time, and then again during the recent holiday season.

So far we have only heard about this problem from users in the North American server environment (USA and Canada). We need to hear from the Europeans if this is also affecting users in their areas please.

Reporting the failures
CBenson (a US Champ) started gathering a list of routes which failed after a certain distance, and put them in a Google Sheet. If you know of, experienced, or saw reports about a long route which is failing, please add it to the list by filling out this Google Form. This form is only for tracking this specific issue (long routes >100mi/150km) failing, please don't use it for other routing issues or failures (such as network connectivity issues, etc).

You can thoroughly test a route, by attempting it in the beta and production client (though this is likely not different), and using both with tolls (regular), and 'Avoid tolls' routing options (this is important).

When filling out the form please choose no for the RBS question (it relates to an internal waze team that handles certain routing issues).

Resolutions
  • The routing team is now aware of this issue, and will begin investigating the routes reported in the form, and looking for the cause and a fix.
  • So far all the reports are from North America, if this issue is affecting other parts of the world, it is imperative you fill out the form so the devs can see and address the issue for you as well.

PS This form is for all editors, please do not use it as a reply to URs.
PesachZ
Wiki Master
Wiki Master
 
Posts: 4507
Joined: Mon Jul 01, 2013 12:51 am
Location: NY, USA (also NJ sometimes) {GC}
Has thanked: 1997 times
Been thanked: 2352 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby PesachZ » Mon Jan 04, 2016 9:54 am

An update from the devs working on this issue:
The Devs wrote:Re routing failures:
Hey guys,

I'm here with news for you!

Our devs managed to partly fix this issue. it's not the end of their efforts, but at least from livemmap, some of the routes that failed - succeed. 

We still need your kind help:

1- To continue bearing with us.
2- Confirm that you see an improvement.
3- Report about routes that still fail.
4- Report how we're doing from the app.

Thanks,
-The Devs


Please continue to use the form above to report failures. If a route you previously reported as a failure starts working now, please report it here.
Sent from Android using Tapatalk
PesachZ
Wiki Master
Wiki Master
 
Posts: 4507
Joined: Mon Jul 01, 2013 12:51 am
Location: NY, USA (also NJ sometimes) {GC}
Has thanked: 1997 times
Been thanked: 2352 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby qwaletee » Mon Jan 04, 2016 3:00 pm

Can we get some info on what was happening?
US Champ / Country Manager | State Manager NY, NJ, PA, CT, MA, RI, VT, ME, NH | Northeast ARC | Mentor | Responding to Map Issues
qwaletee
US Waze Champs
US Waze Champs
 
Posts: 2936
Joined: Wed Feb 13, 2013 1:42 am
Location: NYC Metro - Active throughout NE^2 (Northeast & New England)
Has thanked: 235 times
Been thanked: 1134 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby SanzClew » Mon Jan 04, 2016 3:12 pm

I had received about a dozen UR's in Massachusetts about that error but I was able to get routing from the Boston area to north of Montreal over the last week without issue. Not sure if that was because it is very rural or if the problem has been fixed to some extent.
[ img ] [ img ]
USA CM | NER MSM | MA SM | RI SM
Waze, because you don't have enough to do in real life.....
Mass Wiki / CT Wiki / RI Wiki / NH Wiki / VT Wiki / ME Wiki
SanzClew
Country Manager
Country Manager
 
Posts: 770
Joined: Fri Jun 20, 2014 9:08 pm
Location: South Shore of Boston Metro area
Has thanked: 248 times
Been thanked: 170 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby tonytx05 » Mon Jan 04, 2016 3:15 pm

PesachZ wrote:
The Devs wrote:but at least from livemmap, some of the routes that failed - succeed. 


Does this mean users may have a route fail in the app, but will work ok in the livemap now? If so, how do we know what to submit through the form? Every user report of a failed route in the app, regardless of if we can reproduce in livemap?
Area Manager: Andrews | Brazos County | Houston

[ img ][ img ]

If you edit in Texas, please make sure you read the following:
USA South Central Region Info | Best Practices | Edits to Avoid
tonytx05
Beta tester
Beta tester
 
Posts: 389
Joined: Tue Nov 01, 2011 12:52 pm
Location: Kingwood, TX, USA
Has thanked: 111 times
Been thanked: 102 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby PesachZ » Mon Jan 04, 2016 3:17 pm

It means we have not tested the client because we are obviously not in those location but they do now work in live map so we hope that they will also work in the client. If they don't we must investigate further

Sent from Android using Tapatalk
PesachZ
Wiki Master
Wiki Master
 
Posts: 4507
Joined: Mon Jul 01, 2013 12:51 am
Location: NY, USA (also NJ sometimes) {GC}
Has thanked: 1997 times
Been thanked: 2352 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby tonytx05 » Mon Jan 04, 2016 3:20 pm

10-4, thanks.
Area Manager: Andrews | Brazos County | Houston

[ img ][ img ]

If you edit in Texas, please make sure you read the following:
USA South Central Region Info | Best Practices | Edits to Avoid
tonytx05
Beta tester
Beta tester
 
Posts: 389
Joined: Tue Nov 01, 2011 12:52 pm
Location: Kingwood, TX, USA
Has thanked: 111 times
Been thanked: 102 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby jdelosa » Tue Jan 05, 2016 6:59 am

Got This UR from Jan 3rd 2016 describing "1 First Stamford Place, Stamford, Connecticut, 06902 we were looking for the HIlton for one hour!" reported from 47th Street Brooklyn NY

https://www.waze.com/editor/?env=usa&lo ... st=4973837

I have left the UR open for your Review

Thanks John (JD)
JD, Brooklyn, NYC Area Manager, New York SM, NOR MSM,
Member of the NYC Closure Team

WazeNewYork@GMail.com Subject Attn: JDeLosa
[ img ][ img ][ img ]
[ img ][ img ][ img ]
jdelosa
PartnerCoordinator
PartnerCoordinator
 
Posts: 459
Joined: Mon Mar 09, 2015 10:05 pm
Location: Brooklyn, NY, USA
Has thanked: 381 times
Been thanked: 168 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby gunnargsd » Tue Jan 05, 2016 1:50 pm

The following route was reported as failed, but seems to be working in LiveMap now: https://www.waze.com/livemap?lon=-77.54 ... t_text=Now

Thank you,

Dave
gunnargsd
Area Manager
Area Manager
 
Posts: 56
Joined: Fri Dec 24, 2010 1:41 pm
Has thanked: 113 times
Been thanked: 17 times

Re: Routing Server Timeouts / Failed Routes for long routes

Postby gunnargsd » Tue Jan 05, 2016 7:00 pm

Positive reply #2. The following failed route is now working in LiveMap: https://www.waze.com/livemap?lon=-80.85 ... t_text=Now

Thanks,

Dave
gunnargsd
Area Manager
Area Manager
 
Posts: 56
Joined: Fri Dec 24, 2010 1:41 pm
Has thanked: 113 times
Been thanked: 17 times

Next

Return to Navigation & Routing

Who is online

Users browsing this forum: No registered users