Switch to full style
Post a reply

Re: Experiencing "Searching for Networks" Problem

Wed Aug 05, 2015 1:39 pm

I'm experiencing the same on my LG G2, my Waze is always in the "Searching for Network" everytime I'm on mobile connection. My browser and other apps are online just fine, somehow only Waze isn't online when it's supposed to.

I tried installing and reinstalling a few times and even tried restoring my phone to factory settings but the problem persists.

Please help..

Re: Experiencing "Searching for Networks" Problem

Fri Aug 07, 2015 7:28 pm

I'm having the same problem on Blackberry Bold in the Toronto area.

Re: Experiencing "Searching for Networks" Problem

Mon Sep 14, 2015 10:19 pm

I have that problem when I first had a network connection... then I lost ist for a cupple of minutes and get back the connection... It "Searching for Network" the hole time... and doesn't work anymore until I restart the app.
There was an Version I get from the support team, it worked this way.
Is there a new Version with a solution for this bug?

Experiencing "Searching for Networks" Problem

Sun Sep 20, 2015 10:01 pm

Being getting it a lot in the UK as well.

Had t today whilst having 4g connection and 3 or 4 bars of signal. So what is happening here? How can it be rectified?

Sent from my iPad using Tapatalk

Re: Experiencing "Searching for Networks" Problem

Tue Jun 20, 2017 11:19 am

IPhone cause: app not enabled to use cellular data (i.e. some how along the way this app got configured to only use wifi, which for an app that is used for traveling purposes is not possible).

Solution: go to iPhone Settings > Cellular > scroll down to Waze app and enable.

Re: Experiencing "Searching for Networks" Problem

Tue Apr 17, 2018 6:26 am

Creating a Waze User worked for me.

Solved! :)


Had to reninstall (Didn't work).
Tried to jump straight into navigating by hitting "Skip" for the registration process (Didn't work).
Created a user to make Waze happy (Worked!) - Maps downloaded, voice etc., no more "Searching Network..."

All the best!
Post a reply