Switch to full style
[ img ]
Post a reply

Problem z klientem - 80% CPU

Wed Mar 23, 2011 2:11 pm

Witam,
Ostatnio zauważyłem dziwne zachowywanie się klienta Waze:
- ~80% użycia CPU,
- brak możliwości przewijania mapy (chodzi tak wolno, że zanim przewinę to zdążę przejechać ok 500m),
- gubienie sygnału GPS, jak zgubi to już go nie odzyska
- skórka nie zmienia się na nocną, konieczność restartu Waze
Czy ktoś z Was zaobserwował takie działanie? Dodam, że nawet włączenie walca, menu czy czegokolwiek tak działa, mapa podczas jazdy skacze jakby chodziła na 0,5 FPS...
W cfg nic nie zmieniałem, podejrzewam, że takie działanie zaczęło się po odświeżeniu mapy obszaru ok 2 tyg temu.
Ahh, i jeszcze telefon: HTC HD2

Re: Problem z klientem - 80% CPU

Wed Mar 23, 2011 10:46 pm

U mnie na HTC Wildfire nie zaobserwowałem problemu z nadmiernym obciążeniem procesora więc tym bardziej na twoim nie powinno to występować.

Re: Problem z klientem - 80% CPU

Thu Mar 24, 2011 7:42 am

Przeinstalowałem Waze i wszystko jest ok - so far...
Zobaczymy po paru aktualizacjach mapy co się będzie działo.

Re: Problem z klientem - 80% CPU

Thu Mar 24, 2011 1:51 pm

Jaki masz system operacyjny? Jeśli Androida, to od wczoraj jest nowa wersja w markecie. Podobno poprawiona - jeszcze nie sprawdzałem. Z innymi systemami nie mam doświadczeń.

Zużycia CPU nie sprawdzałem, ale zużycie baterii przez waze jest wyjątkowo wysokie nawet z wyłączonym GPS-em, stąd wnioskuję, że to z powodu obciążenia CPU, ale tak miałem zawsze. Podobnego typu problemy widywałem na forum angielskojęzycznym, ale to było spowodowane testami nowej wersji beta, nie miało nic wspólnego z nowszą mapą.

Jeszcze mam taką hipotezę, że miałeś po prostu za dużo danych (map) w swoim kliencie, w pewnym momencie brakło pamięci RAM i zaczął działać swap, stąd znaczne spowolnienie, a przy okazji reinstalacji wyczyściłeś stare dane i dlatego pomogło.

Re: Problem z klientem - 80% CPU

Thu Mar 24, 2011 5:34 pm

Mam Winde 6 na HD2.
Co do ilości map i użycia swap to nie do końca się zgodzę. Mapy najprawdopodobniej zostają jeśli usuwam aplikację - w innym przypadku ściągałbym od nowa obszary a spokojnie mogłem przeglądać na offline. Opcje też zostały zachowane, ta sama skórka, hasła logowań, sposób wyświetlania itp...
Nie wiem co to mogło być ale reinstalacja klienta pomogła ;)
Pozdrawiam.
Post a reply