Map Editor major ver (Nov 5, 2012) Official Feedback

The place to get information and ask questions about everything to do with properly and successfully editing the Waze Map.

Use this forum for all general editing questions, and the sub-forums for specific types of Waze Map Editor features.

Moderators: Unholy, bextein

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby Olestas » Tue Nov 20, 2012 11:57 am

Shortly speaking - in current state and form House numbering is hard and unusable. Besides you have to check which way the road goes (A-B) all the time. Automatic numbering breaks everything too. Even and odd numbers are put on both sides all the time and mixed.
Olestas
Coordinators
Coordinators
 
Posts: 5815
Joined: Wed Mar 09, 2011 7:08 pm
Location: Latvia
Has thanked: 2837 times
Been thanked: 2074 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby mssusa » Tue Nov 20, 2012 4:17 am

I get the pointer stuck when my machine is overloaded. Especially when there are many segments in the view or there is a very long segment (10s or 100s of km long). This was also the case with the old version

Sent from my GT-I9100 using Tapatalk 2
mssusa
Area Manager
Area Manager
 
Posts: 308
Joined: Wed Jul 27, 2011 7:27 am
Location: Riyadh, Saudi Arabia
Has thanked: 10 times
Been thanked: 2 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Tue Nov 20, 2012 12:44 am

jasonh300 wrote:The thing with the geometry node sticking to the mouse pointer has been around for a while, but now, you can click multiple times and it still won't let go. It also seems to do it a lot more frequently under certain circumstances, and it does seem to have something to do with rapidly trying to select multiple segments. I found that hitting Escape will get rid of it sometimes, and sometimes it will do it on its own. This is an extremely frustrating bug.


Indeed, that's why I gave my example of the fupped road that I only noticed because there was a user report about that nice highway 90º based detour through the forest :D
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 2790
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 287 times
Been thanked: 604 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby jasonh300 » Tue Nov 20, 2012 12:38 am

The thing with the geometry node sticking to the mouse pointer has been around for a while, but now, you can click multiple times and it still won't let go. It also seems to do it a lot more frequently under certain circumstances, and it does seem to have something to do with rapidly trying to select multiple segments. I found that hitting Escape will get rid of it sometimes, and sometimes it will do it on its own. This is an extremely frustrating bug.
jasonh300
 
Posts: 7568
Joined: Fri Oct 28, 2011 4:26 pm
Location: New Orleans, LA, USA
Has thanked: 408 times
Been thanked: 986 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby davipt » Tue Nov 20, 2012 12:30 am

CrackedLCD wrote:First, when selecting small segments with geometry nodes in between the A-B points, I'm noticing a big tendency for the cursor to not change from the crosshairs back to a pointer. When this happens, if I click anywhere on the screen, it places the geometry node at that spot.


I've seen this happening with my Firefox and Safari and I even have a road live right now that, edited (screwed) with the old editor, a road that does a 90º angle to the side and then a 90º back, with that broken node almost a km away from the real road position. I always thought it was a question of sensitivity from the mouse. Maybe it's really a timing issue.

CrackedLCD wrote:Second, I'm having occasional trouble inputting data like street names onto segments. I'll start typing and then it's like someone hit the escape key, cancelling the operation


This used to happen when the backend is slow and the roads are still loading. Check if the "loading road" is still showing on the right side when you try to edit and if the editing fields goes away at the same time as the "loading road". I haven't seen yet this one on the new editor mainly because I'm more careful now but it did happen a lot before I knew about this, and hence it did happen to me before on the old editor.
davipt
Waze Global Champs
Waze Global Champs
 
Posts: 2790
Joined: Tue Nov 02, 2010 8:51 am
Location: Oeiras, Portugal
Has thanked: 287 times
Been thanked: 604 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby iainhouse » Tue Nov 20, 2012 12:14 am

CrackedLCD wrote:...when selecting small segments with geometry nodes in between the A-B points, I'm noticing a big tendency for the cursor to not change from the crosshairs back to a pointer. When this happens, if I click anywhere on the screen, it places the geometry node at that spot. It's very annoying during mass edits and deletes, where I'm trying to delete a lot of unneeded driveways or nodes in a reasonable amount of time. The only workarounds are to either hit escape and cancel the action, or wiggle the cursor over the selected segment back and forth until it "releases" and goes back to a cursor.


I'm getting this happen all the time. Really annoying! :x I think it's a timing issue: I get the impression that it happens when you click on the link and immediately move the pointer away. Although it seems to have grabbed the node and you can't "drop" it, it hasn't actually done so. I normally save and then permalink and the node is back where it started. I shall have to try wiggling. :lol:
iainhouse
Country Manager
Country Manager
 
Posts: 8233
Joined: Mon Jul 23, 2012 5:16 pm
Location: on the road from London to insanity
Has thanked: 1652 times
Been thanked: 5614 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby CrackedLCD » Tue Nov 20, 2012 12:04 am

After using the new version for a while, I think I've come across two instances of odd behaviour and I'm wondering if anyone else is having these issues.

First, when selecting small segments with geometry nodes in between the A-B points, I'm noticing a big tendency for the cursor to not change from the crosshairs back to a pointer. When this happens, if I click anywhere on the screen, it places the geometry node at that spot. It's very annoying during mass edits and deletes, where I'm trying to delete a lot of unneeded driveways or nodes in a reasonable amount of time. The only workarounds are to either hit escape and cancel the action, or wiggle the cursor over the selected segment back and forth until it "releases" and goes back to a cursor.

Second, I'm having occasional trouble inputting data like street names onto segments. I'll start typing and then it's like someone hit the escape key, cancelling the operation. I'm not hitting any stray keys or mouse buttons, so I have no idea where that escape command is coming from. It seems to do it if I'm typing quickly and the dropdown list of possible road populates with a bunch of different choices. But it doesn't do it with any reproduce-able regularity, so I'm stumped.

These problems didn't seem to happen on the old version. Has anyone else encountered these minor but annoying issues?

This is on Win XP sp2, Chrome version 24.0.1312.14 beta-m.
CrackedLCD
Area Manager
Area Manager
 
Posts: 426
Joined: Thu Aug 02, 2012 12:37 am
Location: LA (Lower Alabama)
Has thanked: 97 times
Been thanked: 63 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby Olestas » Mon Nov 19, 2012 5:29 pm

I tried not to continue numbering of usual street... entered number on both sides from 1 to 100.. and saved. All numbers got messed up completely. Thats just horrible. I do not understand how numbering works... is it automatic or what?? After chaning numbers in any place on street, somewhere else numbers are messed up.
I am not using this :(

This is the street I tried on..

https://world.waze.com/editor/?zoom=4&l ... 3,90265748
Olestas
Coordinators
Coordinators
 
Posts: 5815
Joined: Wed Mar 09, 2011 7:08 pm
Location: Latvia
Has thanked: 2837 times
Been thanked: 2074 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby Olestas » Mon Nov 19, 2012 5:04 pm

I did... but after saving they are replaced with numbers from nearest street segment...

P.S. Hmm, I have tried again now, and it seems to work. I will try further, and inform if something changes.
Olestas
Coordinators
Coordinators
 
Posts: 5815
Joined: Wed Mar 09, 2011 7:08 pm
Location: Latvia
Has thanked: 2837 times
Been thanked: 2074 times

Re: Map Editor major ver (Nov 5, 2012) Official Feedback

Postby AlanOfTheBerg » Mon Nov 19, 2012 4:54 pm

olestas wrote:Editor messes up numbers by itself, when there is unusual numbering.
If one side is e.g. 2-12, but other side has no numbers.. empty space should be accepted. If I do not enter any numbers, number from other part of the road is taken automatically, which brakes all numbering further.

Similar problem is with big streets, which are drawn as two one way roads and are separated in real life. Numbering must go on one side of street only... not taken from the other side..

Did you try entering zeroes (0)?
AlanOfTheBerg
Waze Global Champs
Waze Global Champs
 
Posts: 23614
Joined: Sat Aug 28, 2010 8:48 pm
Location: US Country Manager - Oregon, USA
Has thanked: 1128 times
Been thanked: 4822 times

PreviousNext

Return to Waze Map Editor

Who is online

Users browsing this forum: ArTsLeOpS, Yahoo [Bot]