Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by SuperDave1426
jm6087 wrote:That is a regional decision to stress on revcons.
Personally I have no issues with it being visible to all and of course that will be up to Bruce in the long run but it is my understanding that as a national guidance, revcons do not have to be fixed.
That said, I do clean them up as I come across them but I never tell any editor that they have created any.
I clean them as I encounter them, and don't bother the editor who created them, either, since I know they probably aren't even aware of them. So we're on the same page there.

The Raid, on the other hand, has the potential to create a sea of revcons across the map. Sure, we can press a button to get rid of screensfull of them, but why not simply clean them as you go and then it's not a big project (which I'm guessing is the rationale for why it's being encouraged in my region (sure, as you say, they're not technically a problem currently, but they also really shouldn't be there if for no other reason than it's cleaner without them)). Since I see it happening in the Discord channel for my region, I figured there was no harm in asking for the feature.

I'm assuming that SkiDoGuy is the "Bruce" that you mention above (I don't know his name). I'll look forward to seeing his thoughts on the matter. :-)
SuperDave1426
Country Manager
Country Manager
Posts: 972
Has thanked: 82 times
Been thanked: 275 times


Post by turbomkt
Horizon911 wrote:Hi, Just wonder about the "Redo RA" behavior. I am trying to update this RA but when I use Redo RA, it cuts also those FreeWay segments. (disregarding their different elevation)
Is that intentional? (Or is that something that wants to be fixed or can be configured?)
Can such behavior be avoided without me touching those FW segments? (They are above my editor level + It's extra opportunity to screw up something I did not want to change. :) )
I would ask a senior editor to drag them out of the way before trying to redo the RA - add geohandles and just pull it away. When done, remove any geohandles added to have the FWY snap back to where it was. No need to disconnect anything.
turbomkt
US Waze Champs
US Waze Champs
Posts: 1508
Has thanked: 385 times
Been thanked: 352 times
--Mike
ARC for Southwest Region

Post by Trexer0
Within the last month the ability to force the Fancy Permalinks to use beta or production links has disappeared.
Trexer0
Area Manager
Area Manager
Posts: 2928
Has thanked: 1598 times
Been thanked: 251 times


Post by yjanayas
Good afternoon friends,
can someone explain to me also clearly what the following error means?
Will it affect the routing by the ways that present this error?
Thank you.
https://lh3.googleusercontent.com/-Jn0Q ... -01-19.png
:D
yjanayas
Waze Mentor
Waze Mentor
Posts: 325
Has thanked: 644 times
Been thanked: 257 times

Post by turbomkt
Make sure to do at least a soft refresh before removing reverse connections. If the WME thinks they are disconnected, even if it's a bug, the tool will change one way segments to two way.
turbomkt
US Waze Champs
US Waze Champs
Posts: 1508
Has thanked: 385 times
Been thanked: 352 times
--Mike
ARC for Southwest Region

Post by turbomkt
Enable all new turns on new junction doesn't seem to work. That's with 1.9.7 and no scripts running.

JNF/RevCon doesn't seem to work reliably. Thought it was script related as it worked with scripts off, but 50/50 on scripts didn't affect the function. Error provided in TB Beta channel.
turbomkt
US Waze Champs
US Waze Champs
Posts: 1508
Has thanked: 385 times
Been thanked: 352 times
--Mike
ARC for Southwest Region

Post by YanisKyr
Bumped on a peculiar issue - when fixing reverse connections on segments connected to roundabouts, the roundabout Road Type is altered too..!

In the beginning I thought the road type drops one step (MH to mH/PS to St etc), but while trying to reproduce one mH roundabout changed to Ramp. I can't reproduce it consistently, but here are some examples. I think it breaks when a roundabout has 7 segments or more connected.

Reproduced:
Permalink 1
Permalink 2
Permalink 3

Not able to reproduce:
Permalink 4
Permalink 5
YanisKyr
Posts: 519
Has thanked: 281 times
Been thanked: 73 times

Post by YanisKyr
YanisKyr wrote:Bumped on a peculiar issue - when fixing reverse connections on segments connected to roundabouts, the roundabout Road Type is altered too..!

In the beginning I thought the road type drops one step (MH to mH/PS to St etc), but while trying to reproduce one mH roundabout changed to Ramp. I can't reproduce it consistently, but here are some examples. I think it breaks when a roundabout has 7 segments or more connected.

Reproduced:
Permalink 1
Permalink 2
Permalink 3

Not able to reproduce:
Permalink 4
Permalink 5
Still happens btw.
YanisKyr
Posts: 519
Has thanked: 281 times
Been thanked: 73 times