Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by rickzabel
also this is with maximizer and make sure not identified doesnt scroll of the window

monitor 1 - Chrome
1366*768 max height is 48px
1600*1200 max height is n/a
1920*1080 max height 167px

monitor 1 - firefox
1366*768 max height is 140px
1600*1200 max height is n/a
1920*1080 max height 250px

monitor 2 - Chrome
1366*768 max height is 80px
1600*1200 max height is 520px
1920*1080 max height 200px

monitor 2 - firefox
1366*768 max height is 110px
1600*1200 max height is 620px
1920*1080 max height 490px
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
PesachZ wrote:
KuniaKid wrote:Bug - Changing comments file in settings enables the Me! script.
Funny because I noticed recently and didn't yet try to debug, that the editor profile in top left shows my hard hats avatar, but I don't have the Me! Script installed.

Sent from Android using Tapatalk
hard hats does replace your me image with your hard hat icon.

i was annoyed turning wme me back on everytime i went to wme, so i made urc click on wme me's check box when the tab is drawn. totally forgot i added that in...
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
taco909 wrote:
KuniaKid wrote:
KuniaKid wrote:Bug - Changing comments file in settings enables the Me! script.
Upon further use I've discovered that changing files actually toggles "WME Me!".
I can't get "me" to remain disabled when I try to toggle it using the WME pulldown.
I have to disable it in the Greasemonkey pulldown or it comes back enabled on a browser refresh.
that is my fault since wme me does not remember it's setting and defaults to off. i force it back on every page load or comment list change.
if this is really bugging people i can remove that line of code?
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
FYI the Spanish List is now being maintained by cotero2002
https://greasyfork.org/en/scripts/14100 ... anish-list
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
whatnt wrote:I have been frequently getting the message: "URComments: Loading data has timed out. Retrying".

Also the script seems to be maxing out my CPU cycles at 90%+ without letting up. I have to disable almost all of its settings and filters.

v1.5.0
are you on a slower connection? what is your computer's age (older, newer)?
your problem seems to be slightly different from the others that posted after you.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
crayzee wrote:Ditto.
It seems like auto reload stopped working. Changing filters will reload once.

Sent from my SM-N900 using Tapatalk
Auto reload was removed from the script. toggling either filtering or the pills will not trigger a reload. if URs are present it will update what is shown and the pills.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
Cardyin wrote:I'm getting the same behavior as well. It almost seems like it's stuck in a loop. My guess in this situation is that the UR pill data are trying to load, but is waiting for the filtering which is waiting for the UR pill data.
What i am seeing happening is that sometimes time on page load WME is not loading all the information used by a few scripts. when this happens i noticed that WME does not have any UR data loaded and for hardhats the user rank is not loaded. causing script errors or unexpected behavior.

i disabled all waze scripts and extensions and every few reloads i still have the issue where UR pins are not showing up until i either reload the page, use the reload button, or move the map.
Cardyin wrote:Turning of the setting: "Enable URComments UR filtering", instantly allows the screen to load all URs and pill boxes, re-checking this box after the screen refreshes seems to enable the filter correctly and instantaneously
I could not recreate this at all, i tried both filters and pills. i even went so far as to leave my computer sit for an hour to see if the data was loading slowly.

for people who are not seeing UR pins on the map on page load i wrote a script to try to detect this situation and that will move the map an unnoticable amount. on my computer this forces all the WME data to load. this also might help with some of the other script problems other people are having. i don't have any details as to which other scripts other then there is script issues...
when the script detects this situation you will get a toolbox type message that says "WME-Force-Data: Waze's data is missing attempting a map move to force data into loading.'"
This has not had any testing so let me know if it helps or causes other issues.

the script can be found at,
https://greasyfork.org/en/scripts/14746-wme-force-data

hopefully waze will fix the issue and we wont need the script.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
jdelosa wrote:The - followed by the d gives the smiley -d

Sent from my XT1080 using Tapatalk
i am not seeing that here?
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
FYi to all to those having issues with the timeout message and other scripts.

the filters, pills, and the auto reminders are all in one function which pulls data from Descartes if you can not get to the following link or get a 403. the scripts that rely on data from Descartes will not work properly including URC and TB.

https://www.waze.com/Descartes-live/app ... ds=4857124

on that same thought if you have filters, pills, or auto reminders on, the function will be ran once until something is added changed or moved. there should not be much difference if one or all of those options are enabled.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
cafri wrote:I really like URComments.

Today I started using the beta WME instead of the public one, and it doesn't show the UR pill counts in there.
Just checked this morning filters/ pills are working for me on production and beta.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel