Switch to full style
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Forum rules

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post a reply

Re: [Script] WME Toolbox (1.8.16)

Wed Jul 24, 2019 6:30 am

Since yesterday WME Toolbox throws an exception after selecting place, which stops "selectionchanged" event for subsequent handlers:

Code:
Uncaught TypeError: Cannot read property 'mainObjectID' of undefined
    at e.WMETB_FPnewSelectionAvailable (FancyPermalink.min.js:227)
    at initialize.triggerEvent (vendor-86dc9f4c83949efd6718.js:1)
    at e.value (app-1d3e5c24957b318a3943.js:1)
    at e.value (app-1d3e5c24957b318a3943.js:1)
    at e.value (app-1d3e5c24957b318a3943.js:1)
    at f (vendor-86dc9f4c83949efd6718.js:1)
    at T (vendor-86dc9f4c83949efd6718.js:1)
    at h (vendor-86dc9f4c83949efd6718.js:1)
    at t.u.trigger (vendor-86dc9f4c83949efd6718.js:1)
    at t.y [as triggerMethod] (vendor-86dc9f4c83949efd6718.js:1)


The apparent reason for this seems to be that object "W.model.countries" doesn't have property called "additinalInfo".

Re: [Script] WME Toolbox (1.8.16)

Thu Jul 25, 2019 3:31 am

WME Toolbox causing WME Join Junction feature not working preoperly.
Browser : FireFox
Note :
The test show on the video are running with Tamper Monkey Off :-
1) 1st test is with TB enable
2) 2nd test is with TB disable

Re: [Script] WME Toolbox (1.8.16)

Sat Jul 27, 2019 8:34 am

Hi Rising_Sun,
I think it's due to the bug said by Iaccz.
Now it's fix, but not released yet.

Re: [Script] WME Toolbox (1.8.16)

Mon Jul 29, 2019 12:03 am

Join Junction feature not working for me as well

Re: [Script] WME Toolbox (1.8.16)

Mon Jul 29, 2019 2:26 am

I'm also noticing the "Show point places at zoom 3+ instead of 5+" functionality is not working in the last couple of days. Turned off Tampermonkey and made sure no other scripts or extensions were running, and this is occurring on two separate PCs.

Re: [Script] WME Toolbox (1.8.16)

Mon Jul 29, 2019 1:32 pm

AnorestesX wrote:I'm also noticing the "Show point places at zoom 3+ instead of 5+" functionality is not working in the last couple of days. Turned off Tampermonkey and made sure no other scripts or extensions were running, and this is occurring on two separate PCs.

I believe Bellhouse posted that this might no longer be possible due to some of the properties being removed in the WME data.

Re: [Script] WME Toolbox (1.8.17)

Tue Jul 30, 2019 12:34 pm

Toolbox 1.8.17 is released for Chrome and Firefox:

Code:
1.8.17  (20190730)
Fix: Fixed crashes after WME update
Fix: Simplify geometry nodes function attempted to modify segments with closures (#484)
Fix: Speed limit of off-road road type was not highlighted (#485)
Update: Matched Toolbox' top bar entry with WME's enties' behaviour when WME window has low horizontal resolution ("Toolbox" caption is hidden then) (#482)

Known issue:
  • Popups blocking live map overview

Re: [Script] WME Toolbox (1.8.17)

Tue Jul 30, 2019 2:45 pm

BellHouse wrote:Toolbox 1.8.17 is released for Chrome and Firefox:

Code:
1.8.17  (20190730)
Fix: Fixed crashes after WME update
Fix: Simplify geometry nodes function attempted to modify segments with closures (#484)
Fix: Speed limit of off-road road type was not highlighted (#485)
Update: Matched Toolbox' top bar entry with WME's enties' behaviour when WME window has low horizontal resolution ("Toolbox" caption is hidden then) (#482)

Known issue:
  • Popups blocking live map overview


Thank you BellHouse for this update! I am finding that TB is conflicting with PIE since last weeks update. It causes adding RPPs to not work properly. In PIE, you can have a setting enabled to open the edit pane right after adding an RPP. With TB enabled, it does not do this.

Re: [Script] WME Toolbox (1.8.17)

Thu Aug 01, 2019 8:08 am

G_W1Z wrote:I am finding that TB is conflicting with PIE since last weeks update. It causes adding RPPs to not work properly. In PIE, you can have a setting enabled to open the edit pane right after adding an RPP. With TB enabled, it does not do this.

I do not use or know PIE. Can you please list the steps on how to reproduce the issue?

Re: [Script] WME Toolbox (1.8.17)

Thu Aug 01, 2019 10:07 am

Pie is Android 9.

Verstuurd vanaf mijn HTC_2Q4D100 met Tapatalk
Post a reply