[Script] WME Speedhelper

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Speedhelper

Postby gertbroos » Fri Jun 17, 2016 6:34 am

Olestas wrote:So, gertbroos, could you add option to set speedlimits on Private road and Parking lots? They contain speed fields, they are just hidden... Thanks.


Not tried yet. In my country, I added those (hundreds of them) by temporarily changing the roadtype to street, setting the speed and changing them back to private/plr

I currently have no idea if it's possible in any way because the speed input fields don't appear when editing a private / plr

I will add this to my todo list, so no ETA ( "soon")
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Thu Jun 23, 2016 11:33 am

Update 0.7.4

Small bugfix, India was set to MPH instead of KPH, which resulted in wrong speeds.

My apologies for any inconvenience...
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Thu Jun 23, 2016 8:03 pm

The problem here is, that I cannot reproduce the problem, so it will be very difficult to debug :?

This is Chrome & Windows 10
[ img ]

This is Firefox & Windows 10
[ img ]

So everyone with this problem: post your setup (browser / OS) so I can try to find a solution
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Sun Jun 26, 2016 9:02 pm

laurenthembprd wrote:Windows 10.0 NT
Chrome Version 51.0.2704.106 m


So I have exactly the same browser & OS, and I don't have the issue you're having... Will not be easy to find what's going wrong there :?

Maybe 2 scripts that don't work nice together? Could you disable all scripts (tampermonkey) and only enable the Speedhelper, just as a test...

If it works, start enabling scripts one by one and look when it starts failing...
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Sun Jul 17, 2016 4:44 pm

I've been away for a week, so I will try to update the script as soon as possible.
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Tue Aug 23, 2016 9:44 pm

Update 0.7.6

Multiple changes :D (all done normally)
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Fri Aug 26, 2016 2:43 pm

kpouer wrote:Hi gertbroos, I noticed a strange problem in Algeria:
the speed are good, but when I click on one speed button, like 120, the value that is filled is 193. Like if the buttons were setting speeds in miles. Il Algeria it's all km/h ;)
thanks


I'm on Holiday untill monday, then i will fix it
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Thu Sep 01, 2016 9:44 pm

kpouer wrote:No Iainhouse, I'm in metric, I edit in France without any problem, it it's only in Algeria that the SpeedHelper fails. And Algeria normal unit is kph not mph.


I allready know what the problem is :) I just have to find the time to fix it. I'm hoping to get all requests done by this weekend :oops:
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Thu Sep 08, 2016 8:59 pm

PesachZ wrote:I think I found a bug, when using the speed helper to set the speed for a speed camera.

If I have my wme set to metric and use the buttons to enter a SL on a segment it converts the value to the metric equivalent to be entered in the segment. For example if I click on 25 MPH while WME is set to metric, it inputs 40 kph. This is how it should work and is fine.

But if I do the same thing on a speed camera (click on the 25 MPH sign button while WME is set to metric), it puts 25 in the input field, which then will set the camera to trigger at 16 MPH.

Please let me know if you need samples, or if you need me to explain better. It seems the conversion code which adjusts the input values is not active for the speed cam settings.


I think I know what you mean :)

A couple of updates ago, a few editors gave me a code snippet, that added this functionality, It works with segments, not with cameras...

I will add this to my todo list, can't give an ETA, but It will be fixed :)
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

Re: [Script] WME Speedhelper

Postby gertbroos » Wed Sep 21, 2016 9:41 pm

Update 0.7.7

Updated PHillipines
Added Bosnia-Herzegovina
Added India
Updated poland
Updated Quatar
Added Ukraine
Updated Canada
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 365
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 249 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: bedo2991