[Script] WME Speedhelper

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Speedhelper

Postby Robert04101 » Tue Jan 19, 2016 4:08 am

vince1612 wrote:
gertbroos wrote:
Robert04101 wrote:In the current version of WME Beta, WME Speedhelper adds the SLs to the first segment selected (when multiple segments are selected).

Haven't got access to WME Beta yet, so can't check/fix this at this time :(

I don't think this is a WME Speedhelper script problem only. Others have reported having a problem editing multiple segments also for road categories and other parameters since the update, it sounds like a general issue.

Source: https://www.waze.com/forum/viewtopic.ph ... 4&t=174554 (WME beta forum)

Yep, this is a WME Beta issue, not a Speedhelper issue. Sorry for the false alarm!
Robert04101
State Manager
State Manager
 
Posts: 258
Joined: Fri Mar 30, 2012 12:02 pm
Location: Portland, ME
Has thanked: 115 times
Been thanked: 127 times

Re: [Script] WME Speedhelper

Postby Robert04101 » Thu Apr 14, 2016 6:09 pm

Here's a reproducible bug:

Select two (or more) one-way segments that Waze's algo has assigned unverified speeds. Set a (common) speed. Any segments that in the opposite direction will still have an unverified SL.
Robert04101
State Manager
State Manager
 
Posts: 258
Joined: Fri Mar 30, 2012 12:02 pm
Location: Portland, ME
Has thanked: 115 times
Been thanked: 127 times

Re: [Script] WME Speedhelper

Postby Robert04101 » Tue May 10, 2016 12:44 am

South Africa could benefit from the addition of a 90 kph button. Not entirely common, but not rare either.
Robert04101
State Manager
State Manager
 
Posts: 258
Joined: Fri Mar 30, 2012 12:02 pm
Location: Portland, ME
Has thanked: 115 times
Been thanked: 127 times

Re: [Script] WME Speedhelper

Postby Rotobert06 » Fri Dec 04, 2015 7:04 pm

Bulgaria - BU
20-30-40-50-60-70-80-90-120-140
km/h
The sign is standard.
Rotobert06
 
Posts: 32
Joined: Sun Aug 16, 2015 8:04 pm
Has thanked: 6 times
Been thanked: 22 times

Re: [Script] WME Speedhelper

Postby russblau » Wed Mar 06, 2019 8:03 pm

Just noticed an odd little bug in this script. If I select a single two-way segment and then click on one of the speed limit signs to set the speed, the "save" counter increments to 2, as expected. However, if I select multiple two-way segments and then set a speed, the counter increments to 3. Hovering over the Save button, it appears that the script is changing the A->B speed twice, but the B->A speed only once, for each selected segment.
[ img ] [ img ] [ img ]
MAR MSM; State Manager: District of Columbia
russblau
State Manager
State Manager
 
Posts: 1506
Joined: Fri Oct 19, 2012 11:36 pm
Has thanked: 310 times
Been thanked: 651 times

Re: [Script] WME Speedhelper

Postby russblau » Thu Mar 07, 2019 9:54 pm

I agree, it doesn't seem to hurt anything, just seemed odd.
[ img ] [ img ] [ img ]
MAR MSM; State Manager: District of Columbia
russblau
State Manager
State Manager
 
Posts: 1506
Joined: Fri Oct 19, 2012 11:36 pm
Has thanked: 310 times
Been thanked: 651 times

Re: [Script] WME Speedhelper

Postby RussPA » Fri Jan 04, 2019 11:15 pm

I actually would like it kept setting both directions. Many times I can't delete a JN and it often turns out to be because the hidden direction SLs don't match, so with one click I can set the hidden SL and fix the problem. Otherwise it would take several steps to fix mismatched SL. Just my opinion.
[ img ] [ img ] [ img ] [ img ] [ img ][ img ] [ img ]
Assistant Regional Coordinator - NOR
Global Champ - US
WME Beta Community Coordinator
RussPA
Waze Global Champs
Waze Global Champs
 
Posts: 2772
Joined: Fri Nov 06, 2015 9:05 pm
Location: Bucks County, Pennsylvania
Has thanked: 399 times
Been thanked: 1134 times

Re: [Script] WME Speedhelper

Postby RussPA » Tue Apr 30, 2019 12:47 pm

Script seems to be working fine, but I keep seeing this console error:
SpeedHelper.PNG
(11.07 KiB) Downloaded 378 times
[ img ] [ img ] [ img ] [ img ] [ img ][ img ] [ img ]
Assistant Regional Coordinator - NOR
Global Champ - US
WME Beta Community Coordinator
RussPA
Waze Global Champs
Waze Global Champs
 
Posts: 2772
Joined: Fri Nov 06, 2015 9:05 pm
Location: Bucks County, Pennsylvania
Has thanked: 399 times
Been thanked: 1134 times

Re: [Script] WME Speedhelper

Postby sa9itario » Thu Jul 05, 2018 8:47 pm

Angola - AO
20-30-40-50-60-70-80-90-100-120
km/h
The sign is the European standard sign.

Thank you in advance!
sa9itario
Area Manager
Area Manager
 
Posts: 4
Joined: Mon Sep 29, 2014 8:04 pm
Has thanked: 0 time
Been thanked: 2 times

Re: [Script] WME Speedhelper

Postby santyg2001 » Fri Feb 08, 2019 12:50 am

Hi,

Would be great to have also the 10km/h vel in the Colombian list, as it is used much.

Thanks.
santyg2001
State Manager
State Manager
 
Posts: 288
Joined: Tue Dec 18, 2012 8:17 pm
Has thanked: 124 times
Been thanked: 144 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: Doctorblah, ldriveskier