Switch to full style
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Forum rules

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post a reply

Re: [Script] WME Color Speeds

Sun Feb 07, 2016 5:52 pm

Another problem/request: line type. dashed lines make it difficult to see small gaps in speed limits, because small segments can just be part of a gap in the dashed line.

Re: [Script] WME Color Speeds

Sun Feb 07, 2016 6:06 pm

seb-d59 wrote:
AlanOfTheBerg wrote:The update posted today broke 55mph again. Please include the truncation code I provided previously. 55mph comes up as "unknown" speed because the math is wrong.

Rectified, sorry :oops:

Thanks!


Sent from my iPhone using Tapatalk

Re: [Script] WME Color Speeds

Sat Feb 27, 2016 7:24 am

TheLastTaterTot wrote:Nope. I have not modified the script at all. Sketch is also having the same problem and he is also using Chrome on Mac OS. I have a suspicion it might be related to Mac OS, but I'm not sure.

I noted earlier in this thread that on the Mac, the browsers cannot override system behavior and the OPTION items in a SELECT control are not allowed to have background color changed, as well as other style items. This is documented in Mozilla dev threads.

It can be done, but it must be a custom control.


Sent from my iPhone using Tapatalk

Re: [Script] WME Color Speeds

Tue Apr 12, 2016 6:55 pm

This script is still "crashing" WME on save. WIth this script enabled, sometimes it will throw lots of "CityID" errors. This was mentioned previously I think. Need to find out what's happening because it really makes using WME Color Speeds very difficult, having to reload the browser regularly.

Re: [Script] WME Color Speeds

Thu Apr 14, 2016 7:35 pm

seb-d59 wrote:I'm on it, but I can not seem to reproduce the bug....

Win7 and Win10 Chrome

Re: [Script] WME Color Speeds v1.2.6

Wed Nov 21, 2018 12:53 pm

WME Color Speeds 1.2.6 keeps intermittently disappearing. I go around disabling other extensions and think I have found the breaker but then during further testing either Color Speeds vanishes when the suspect is still disabled, or Color Speeds works even when the suspect is enabled.
Very frustrating as I like this extension and I hate when it disappears.

Re: [Script] WME Color Speeds v1.2.6

Wed Nov 21, 2018 5:56 pm

Not sure if this helps, filtering error messages on 'speed'

[by the way, Smurfies Law strikes again (whatever happens will make you feel little and blue!); after I captured the info below, Color Speeds stopped failing. I have now turned on a bunch of extensions I had turned off while troubleshooting it, and it starts just fine, ever time. :) ]

WMEFU: initialising...
userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:252 Uncaught TypeError: Cannot read property 'abbr' of undefined
at Object.WMESpeedhelper_init.WMESpeedhelper.makeSigns (userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:252)
at WMESpeedhelper_init (userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:467)
at WMESpeedhelper_bootstrap (userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:179)
WMESpeedhelper_init.WMESpeedhelper.makeSigns @ userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:252
WMESpeedhelper_init @ userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:467
WMESpeedhelper_bootstrap @ userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:179
setTimeout (async)
(anonymous) @ userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:471
(anonymous) @ VM6228:2
(anonymous) @ userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:2
(anonymous) @ userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:3
(anonymous) @ userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:472
(anonymous) @ userscript.html?id=0157a4bf-5dc3-481f-9d5e-ec88f38ea5ba:474
(anonymous) @ VM6228:2
b @ VM6228:1
E_u @ VM6228:3
t @ VM6253:63
ka @ VM6253:61
create @ VM6253:72
e @ VM6253:16
setTimeout (async)
(anonymous) @ VM6228:2
y.(anonymous function) @ VM6228:8
(anonymous) @ VM6253:16
runListeners @ VM6253:16
(anonymous) @ VM6253:73
R @ VM6228:10
e @ content.js:6
send @ content.js:8
(anonymous) @ content.js:27
processQueue @ content.js:3
a @ content.js:10
userscript.html?id=35bbb113-0551-483f-be07-412c1f75d8d2:571 WMEFU: applying all settings
userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:427 Uncaught TypeError: Cannot read property 'name' of null
at Window.CSpeeds_init (userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:427)
at <anonymous>:2:491
at e.string.g.function.c.(/en-US/anonymous function) (eval at exec_fn (:1:107), <anonymous>:52:483)
CSpeeds_init @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:427
(anonymous) @ VM6228:2
e.string.g.function.c.(anonymous function) @ VM6253:52
setTimeout (async)
(anonymous) @ VM6228:2
y.(anonymous function) @ VM6228:8
(anonymous) @ VM6228:2
ja @ VM6253:53
enhance @ VM6253:56
CSpeeds_init @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:424
(anonymous) @ VM6228:2
e.string.g.function.c.(anonymous function) @ VM6253:52
setTimeout (async)
(anonymous) @ VM6228:2
y.(anonymous function) @ VM6228:8
(anonymous) @ VM6228:2
ja @ VM6253:53
enhance @ VM6253:56
CSpeeds_init @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:424
(anonymous) @ VM6228:2
e.string.g.function.c.(anonymous function) @ VM6253:52
setTimeout (async)
(anonymous) @ VM6228:2
y.(anonymous function) @ VM6228:8
(anonymous) @ VM6228:2
ja @ VM6253:53
enhance @ VM6253:56
CSpeeds_init @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:424
CSpeeds_bootstrap @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:392
tms_2423d064_467a_44eb_8d1b_e75cde8f2d86 @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:1642
(anonymous) @ VM6228:2
(anonymous) @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:4
(anonymous) @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:5
(anonymous) @ userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:1646
(anonymous) @ VM6228:2
E_c @ VM6228:3
ka @ VM6253:61
create @ VM6253:72
e @ VM6253:16
setTimeout (async)
(anonymous) @ VM6228:2
y.(anonymous function) @ VM6228:8
(anonymous) @ VM6253:16
runListeners @ VM6253:16
(anonymous) @ VM6253:73
R @ VM6228:10
e @ content.js:6
send @ content.js:8
(anonymous) @ content.js:27
processQueue @ content.js:3
a @ content.js:10

Re: [Script] WME Color Speeds v1.2.6

Thu Nov 22, 2018 3:14 pm

seb-d59 wrote:Ok, i see this:
userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:427 Uncaught TypeError: Cannot read property 'name' of null
at Window.CSpeeds_init (userscript.html?id=2423d064-467a-44eb-8d1b-e75cde8f2d86:427)


Is from the "W.model.countries.top.name" is not ok in the right time... and "countrie.top == null".

If you can, go to the tampermonkey script éditor and replace the line 416:
Code:
if(typeof(CSpeedsCountries.top) == 'undefined'){


by:
Code:
if(typeof(CSpeedsCountries.top) == 'undefined' || CSpeedsCountries.top === null){


If your test (at the same permalink and zoom) is ok, i push an update.

Trying. All I can say at this time is that it didn't make things worse because the problem has been intermittent and gone for a while.
Thank YOU for all the WAZE you help! Have a happy Thanksgiving Day.

Re: [Script] WME Color Speeds v1.2.6

Tue Mar 12, 2019 11:17 am

Is it intended that roads with no name gets no colour overlay?

Re: [Script] WME Color Speeds v1.2.6

Sat May 04, 2019 7:32 pm

And now roads with no speed gets no overlay either. Its been happening since WME was updated.
Post a reply