[Script] WME Place Interface Enhancements

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Place Interface Enhancements

Postby iainhouse » Mon Dec 03, 2018 8:41 pm

And just as you post an update, I have an improvement suggestion. ;)

On my first run through my local area, I deleted a lot of photos, but there are still hundreds left. If I come back to check again in a week or two, I'll be searching through a lot of good photos to find a few bad ones.

Is it possible to implement some sort of date filter? So that I could show, say, all photos since 1st December.

I'm also mulling the possibility that I might want to compare the new ones to the existing ones. So maybe the filter could put a different border colour around the "filtered" photos?
[ img ][ img ][ img ]
UK AdminsUK WikiWaze FAQWMEFU Script :ugeek:
I want to go to a commune in Vermont and deal with no unit of time shorter than a season
iainhouse
Country Manager
Country Manager
 
Posts: 10482
Joined: Mon Jul 23, 2012 5:16 pm
Location: on the road from London to insanity, with Waze HQ in the driving seat
Has thanked: 2838 times
Been thanked: 8674 times

Re: [Script] WME Place Interface Enhancements

Postby iainhouse » Wed Feb 12, 2020 8:58 pm

I suspect the problem is that the default font size for the main body of WME wa changed a couple of releases ago. Although most elements of WME define their font-size explicitly, there are a few things that depend on the body font-size. This is currently 14px and I suspect it must once have been smaller than that. Reducing that size seems to fix several problems I've seen, including the scroll bars on PIE.

I've already incorporated a specific font-size setting for the side-panel to override this change - it will be part of the next release of WME FixUI. But I haven't changed the font-size right up at the body level, because it could have multiple effects in other places.

Setting a font size of 13px on the photoViewerMainDiv div seems to fix the problem.
[ img ][ img ][ img ]
UK AdminsUK WikiWaze FAQWMEFU Script :ugeek:
I want to go to a commune in Vermont and deal with no unit of time shorter than a season
iainhouse
Country Manager
Country Manager
 
Posts: 10482
Joined: Mon Jul 23, 2012 5:16 pm
Location: on the road from London to insanity, with Waze HQ in the driving seat
Has thanked: 2838 times
Been thanked: 8674 times

Re: [Script] WME Place Interface Enhancements

Postby iainhouse » Tue Apr 14, 2020 1:19 am

(Very minor) Bug Report. :)

The X icon to close the "edit geometry" window is AWOL. The parent div ID is pieViewEditGeom and the icon you're using is the Font Awesome fa-window-close. Replacing that with fa-close seems to work.

You could use class waze-icon-close, but you'll probably have to fiddle with the font size/weight.
[ img ][ img ][ img ]
UK AdminsUK WikiWaze FAQWMEFU Script :ugeek:
I want to go to a commune in Vermont and deal with no unit of time shorter than a season
iainhouse
Country Manager
Country Manager
 
Posts: 10482
Joined: Mon Jul 23, 2012 5:16 pm
Location: on the road from London to insanity, with Waze HQ in the driving seat
Has thanked: 2838 times
Been thanked: 8674 times

Re: [Script] WME Place Interface Enhancements

Postby iainhouse » Fri Apr 24, 2020 6:56 pm

JustinS83 wrote:
iainhouse wrote:(Very minor) Bug Report. :)

The X icon to close the "edit geometry" window is AWOL. The parent div ID is pieViewEditGeom and the icon you're using is the Font Awesome fa-window-close. Replacing that with fa-close seems to work.

You could use class waze-icon-close, but you'll probably have to fiddle with the font size/weight.

Works for me in production and beta :?

Strange, indeed! Still missing for me in Beta and Production - but not in anonymous mode (i.e. no scripts).

Digging even deeper, it looks like some other script I'm using may be loading a version of FontAwsome for itself. Apart from some FA CSS I can see in the native WME, my sources tab tells me I also have FA loaded from use.fontawesome.com. Within that source is some CSS that is killing the icon. If I disable that line, the icon appears.

So I guess it's not a problem with PIE. I guess some other script is loading a different version of FontAwesome. I've no idea how to find out which one, other than by spending time disabling scripts - but at least it's a minor problem! :lol:
[ img ][ img ][ img ]
UK AdminsUK WikiWaze FAQWMEFU Script :ugeek:
I want to go to a commune in Vermont and deal with no unit of time shorter than a season
iainhouse
Country Manager
Country Manager
 
Posts: 10482
Joined: Mon Jul 23, 2012 5:16 pm
Location: on the road from London to insanity, with Waze HQ in the driving seat
Has thanked: 2838 times
Been thanked: 8674 times

Re: [Script] WME Place Interface Enhancements

Postby iainhouse » Fri Apr 24, 2020 11:09 pm

JustinS83 wrote:Do you have this installed? If so, try disabling.

I do. I did. It worked. :lol:

Having disabled it, WME Pie is as nice as - well - pie. :) I checked the console and the use.fontawesome.com source has gone. I can also see, in the WMEBED script where it is loading the extra fonts.

So you may close my "report" as you see fit: WAD, WontFix, however you like. ;)
[ img ][ img ][ img ]
UK AdminsUK WikiWaze FAQWMEFU Script :ugeek:
I want to go to a commune in Vermont and deal with no unit of time shorter than a season
iainhouse
Country Manager
Country Manager
 
Posts: 10482
Joined: Mon Jul 23, 2012 5:16 pm
Location: on the road from London to insanity, with Waze HQ in the driving seat
Has thanked: 2838 times
Been thanked: 8674 times

Re: [Script] WME Place Interface Enhancements

Postby ingdaniel94 » Sun Feb 03, 2019 3:50 am

The new notification window is very good. Excellent script. Congratulations
Daniel Toro - Ingdaniel94
State Manager

[ img ][ img ] [ img ]
ingdaniel94
 
Posts: 51
Joined: Mon Jan 29, 2018 5:04 am
Location: Santa Rosa de Cabal - Risaralda
Has thanked: 55 times
Been thanked: 60 times

Re: [Script] WME Place Interface Enhancements

Postby itzwolf » Mon Jun 12, 2017 12:39 pm

Delete button on pictures, thank you Justin!
Southeast Regional Coordinator
US Local Champ / US Country Manager
Partnerships Coordinator

SER Wiki | SER Discord Chat

[ img ][ img ][ img ][ img ][ img ][ img ]
itzwolf
Coordinators
Coordinators
 
Posts: 1107
Joined: Tue May 19, 2015 2:05 am
Location: Florida
Has thanked: 1257 times
Been thanked: 238 times

Re: [Script] WME Place Interface Enhancements

Postby itzwolf » Mon Mar 12, 2018 7:39 pm

So I have been running MoM's separate script for some time and it was working earlier today. I updated to the new PIE release, disabled the standalone script, and refreshed getting an error on the console. This is on Firefox and TamperMonkey.

PIE error:

Code: Select all
SyntaxError: JSON.parse: expected ':' after property name in object at line 1 column 78 of the JSON data
[Learn More]
vendor-667ad18bc0086df37c16.js:24:56631
de.parseJSON
https://editor-assets.waze.com/production/js/vendor-667ad18bc0086df37c16.js:24:56631
GoogleLinkEnhancer
moz-extension://92e3fba6-b3ce-4ff2-b8f8-51a527939080/userscript.html:3532:41
init
moz-extension://92e3fba6-b3ce-4ff2-b8f8-51a527939080/userscript.html:4485:15
bootstrap
moz-extension://92e3fba6-b3ce-4ff2-b8f8-51a527939080/userscript.html:4475:13
bootstrap/<
moz-extension://92e3fba6-b3ce-4ff2-b8f8-51a527939080/userscript.html:4477:37


I then switched back to the Google Link Enhancer script to troubleshoot and it also won't load now:

Code: Select all
SyntaxError: JSON.parse: expected ':' after property name in object at line 1 column 78 of the JSON data
[Learn More]
vendor-667ad18bc0086df37c16.js:24:56631
de.parseJSON
https://editor-assets.waze.com/production/js/vendor-667ad18bc0086df37c16.js:24:56631
GoogleLinkEnhancer
moz-extension://92e3fba6-b3ce-4ff2-b8f8-51a527939080/userscript.html:40:41
init
moz-extension://92e3fba6-b3ce-4ff2-b8f8-51a527939080/userscript.html:930:19
bootstrap
moz-extension://92e3fba6-b3ce-4ff2-b8f8-51a527939080/userscript.html:941:9
bootstrap/<
moz-extension://92e3fba6-b3ce-4ff2-b8f8-51a527939080/userscript.html:943:26
f</<
https://www.waze.com/en-US/editor/:2:477
ga/c[d]
https://www.waze.com/en-US/editor/:54:125
Southeast Regional Coordinator
US Local Champ / US Country Manager
Partnerships Coordinator

SER Wiki | SER Discord Chat

[ img ][ img ][ img ][ img ][ img ][ img ]
itzwolf
Coordinators
Coordinators
 
Posts: 1107
Joined: Tue May 19, 2015 2:05 am
Location: Florida
Has thanked: 1257 times
Been thanked: 238 times

Re: [Script] WME Place Interface Enhancements

Postby jalondon628 » Wed Mar 25, 2020 1:11 pm

With the latest build, the keyboard shortcut Alt+R to quickly create an RPP causes the Places layer to disable. The RPP can still be created but the layer is turned off.

Apologies if this has been reported elsewhere.
Joel London (jalondon628)
North & East TX Area Manager
SE FL Area Manager
Ward County, ND Area Manager

[ img ] [ img ][ img ][ img ][ img ][ img ] [ img ]
jalondon628
Area Manager
Area Manager
 
Posts: 63
Joined: Tue Mar 07, 2017 4:35 pm
Location: Dallas-Fort Worth, TX, United States
Has thanked: 20 times
Been thanked: 20 times

Re: [Script] WME Place Interface Enhancements

Postby jcnina » Thu Mar 15, 2018 3:14 pm

[Edited] Sorry duplicated post, please read next
Last edited by jcnina on Thu Mar 15, 2018 3:17 pm, edited 1 time in total.
jcnina
José Carlos Nina
URUGUAY
jcnina
Waze Global Champs
Waze Global Champs
 
Posts: 353
Joined: Thu Feb 10, 2011 7:10 pm
Location: Uruguay
Has thanked: 717 times
Been thanked: 158 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: Google Feedfetcher