Switch to full style
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Forum rules

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post a reply

Re: [Script] WME Image Overlays (1.3.1)

Tue May 28, 2019 4:03 pm

turbomkt wrote:Or a floating panel?

That would work nicely as well, indeed. I'm not 100% certain yet how I'd implement that, but it should be possible to do that.

Re: [Script] WME Image Overlays (1.3.1)

Thu May 30, 2019 5:27 pm

Justin uses one for RA Utility, right?

Re: [Script] WME Image Overlays (1.3.1)

Fri May 31, 2019 12:36 am

iainhouse wrote:Since this brought the script to mind, I thought of another suggestion.

I know some people have commented about the fairly large bar the script places across the top of the screen; particularly once you've added the editing controls. Is it worth placing those control buttons in the LH panel?

You already have some controls there. I don't have the biggest of screens, but it looks like there's room there for the array of buttons, leaving more space on the map to see where you're placing your image.


I made some cheap mockups of this exact request back on this post. Hopefully it is the pipeline! A floating panel would also be cool.

Re: [Script] WME Image Overlays (1.3.1)

Fri May 31, 2019 11:18 am

turbomkt wrote:Justin uses one for RA Utility, right?

That's "just" a static window that can't be dragged around. But I guess that would be sufficient as well if I can condense the controls a bit. I'll play around with some of the ideas I've got for this.

Re: [Script] WME Image Overlays (1.3.1)

Fri May 31, 2019 2:23 pm

Glodenox wrote:
turbomkt wrote:Justin uses one for RA Utility, right?

That's "just" a static window that can't be dragged around. But I guess that would be sufficient as well if I can condense the controls a bit. I'll play around with some of the ideas I've got for this.

Actually, it is draggable ;)

Re: [Script] WME Image Overlays (1.3.1)

Fri May 31, 2019 2:26 pm

JustinS83 wrote:Actually, it is draggable ;)

Weird. When I tried it before, I couldn't drag it around. It's working fine now.
My bad!

Re: [Script] WME Image Overlays (1.4.0)

Mon Jun 10, 2019 4:39 pm

I've been playing around with the location of the controls, but eventually it felt best to me to just place the controls in the sidebar. That way most of the space remains on the map and then the opacity and parent layer fields aren't positioned weirdly compared to the other image overlay attributes.

I've just released version 1.4.0 of the script which has the adjusted controls, as well as the possibility to adjust an image overlay you've saved in the past. The button that adjusted only the name in the past will now open up the "Align image" step for that image overlay.

I've also been working a bit on making it possible to lock an image to a corner instead of the centre, but that isn't ready to release yet.

[ img ]
Last edited by Glodenox on Mon Jun 10, 2019 6:22 pm, edited 1 time in total.
Reason: Added a screenshot of the new layout for the controls

Re: [Script] WME Image Overlays (1.4.0)

Thu Jun 13, 2019 6:43 pm

Glodenox wrote:I've just released version 1.4.0 of the script which has the adjusted controls, as well as the possibility to adjust an image overlay you've saved in the past.


Absolutely outstanding, thank you so much!! 8-)

Re: [Script] WME Image Overlays (1.4.0)

Sat Jul 13, 2019 8:26 pm

Hi, I am pressing this button but nothing happens. Am I missing something? Thanks.
screenshot_77.png
(13.09 KiB) Downloaded 76 times

Re: [Script] WME Image Overlays (1.4.0)

Sat Jul 13, 2019 9:04 pm

WazingArch wrote:Hi, I am pressing this button but nothing happens. Am I missing something? Thanks.
screenshot_77.png


Have you already added the image to the map?
Post a reply