Switch to full style
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Forum rules

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post a reply

Re: [Script] WMEMagic

Sat Apr 18, 2020 1:40 pm

Was there a change to highlight only empty street/city names? (white seciton)
Wasn't it segments without...name before? It was quite usefull to see faulty areas.

White section segments with empty...name is now the same as the blue one unnamed segments.
In WME it is impossible to safe a segment with only one name missing.
Screenshot_3.png
safe empty
(57.63 KiB) Downloaded 176 times

(Text says "fill in this form")

Either the city is named and the street needs the checkbox or the other way around.
If even one is missing when saving, the error message above appears.

Screenshot_2.jpg
empty segments
(143.38 KiB) Downloaded 174 times

Permalink

In my opinion highlight segments without name is doubble. I would recomment a change back to highlight empty streets or cities even if the checkbox is marked.

Regards & stay healty
Andy

Re: [Script] WMEMagic

Sun Apr 19, 2020 11:10 am

dbcm wrote:
Thanks, it's now fixed.

Version 217 changelog
- fix double interchange
- several fixes to work on WME Beta


There is a bug when double interchange is activated. I use Chrome (latest V80), maybe Firefox too. All other scripts were deactivated

  • Zoom out to zoom level 0-3
  • Activate "interchange over each other"
  • Chrome stopps working (sometimes I had to kill chrome in the taskmanager)

Best regards
Andy

Re: [Script] WMEMagic

Sun Jun 21, 2020 1:42 pm

Hello dbcm and Magic developers

a while ago I posted it once, maybe you have missed it. (happens :D )

If a segment has no streetname and no cityname magic will highlight it as unnamed segment, segments with empty street name and also segements with empty city name
Screenshot_2.jpg
Magic selected segments
(31.3 KiB) Downloaded 150 times


If you enter a street or city name, all 3 todo's will not appear any more.
--> these 3 highlighters work the same

In my opinion, highlight segment with empty street/city name should work as highlight segment without street/city name
The difference? It should highlight even if the checkbox none is marked --> very often this is a fault, but we are not able to highlight it.

A view month ago, it worked like this.

unnamed segment should highlight if eather street name or city name is empty --> maybe there are some segments from old wme-versions (nowadays it is not possible to leave one input field empty without marking "none")

At least is there is bug? segment count does not work for me:
Screenshot_3.jpg
Magic no segment count
(197.78 KiB) Downloaded 148 times

Re: [Script] WMEMagic

Sun Apr 05, 2020 9:27 am

to author: is there any plan to indicate which junction that has problem for magic indication geometry node too close and no connection in the coming future?

Re: [Script] WMEMagic

Tue Apr 21, 2020 1:35 pm

do you have any idea why this thing (the script unable to load) happen?

to make it work, need to do the following:
1. disable the script from tampermonkey
2. reload the WME
3. enable the script from tampermonkey
4. reload the WME

Re: [Script] WMEMagic

Sat Jan 13, 2018 2:25 pm

iainhouse wrote:This has prompted me to try some experiments. Note that I installed the new version earlier today without problems. So I removed Magic, then re-installed it - and got an error myself! The error about "cannot install from this site". That was followed by the download bar appearing at the bottom of Chrome as the file simply downloaded as a normal download.

After a bit of experimentation, I think I found a factor that I haven't seen mentioned before by any of the other people who have experienced problems. The script would not install if I had a WME window open. I tried several times and it seems that, if you have a WME window open, it somehow interferes with the installation of the script. I've now been round several times and been able to consistently install/re-install without WME windows open.

So my suggestion is to try this:
  1. Make sure Magic is uninstalled from Tampermonkey (and not installed in any other way)
  2. Copy the installation link https://waze.xpto.org/magic/magic.bundle.user.js to your clipboard
  3. Close Chrome completely
  4. Reopen Chrome with a fresh tab. If you have tabs set to open with Chrome, close them. If one of those was WME, I'm not sure what will happen. ;)
  5. Paste the link into the address bar
  6. Wait for the page to fully load and show the code. Because it's minified and all on one line, this will take TamperMonkey a while to handle - maybe 20-30 seconds
  7. Click the Install button
  8. Check the Tampermonkey dashboard to see if it's there
I hope that will work for you. Beyond that, we're definitely into territory where I can't really help much more without setting up a remote desktop sharing session.

I tried this, and it worked on my work PC, but not on my laptop at home. Same Chrome version, same Tampermonkey version, same Windows version (I think?).

At home, it won't even complete loading the code before it closes the browser tab and downloads the file, I don't even have time to click Install.

I'll try again in a few weeks time.

Re: [Script] WMEMagic

Sat Jan 06, 2018 11:58 pm

Ditto with the others - as you can see I'm running chrome ;)

http://prntscr.com/hx187y

http://prntscr.com/hx18h2

http://prntscr.com/hx18n1

http://prntscr.com/hx1906

Re: [Script] WMEMagic

Tue Aug 21, 2018 11:22 pm

Thank you!!!!

Re: [Script] WMEMagic

Mon Aug 28, 2017 3:52 pm

Done, thanks Justin

Re: [Script] WMEMagic

Fri Sep 01, 2017 12:12 pm

I'm getting WMEMagic highlighting a roundabout breaking routing when it is mapped correctly.

2 MH & 2mH, roundabout mapped as MH
Post a reply