Switch to full style
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Forum rules

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post a reply

Re: [Script] WME HN NavPoints

Fri Feb 15, 2019 9:11 pm

Thanks, I have added your condition!

Re: [Script] WME HN NavPoints

Sat Feb 23, 2019 5:05 pm

When I use JAI and need to remember which color means what, I can look in the panel. Is there any chance we could get a cheat sheet added to the panel so I don't have to go back to the forums each time? I'm sure it will eventually become second nature, but until then, if possible, I would appreciate the add. Thank you.

Sean

Re: [Script] WME HN NavPoints

Sat Feb 23, 2019 8:57 pm

First, I want to say this is a great script. It helps my troubleshooting immensely.

Next, I want to second Sean's request for a cheatsheet This would be a welcome addition to the script.
Thanks.

Re: [Script] WME HN NavPoints

Mon May 27, 2019 7:44 am

I still see both "before" and "after" lines if I move a number in such way that it gets anchored to another segment.

Re: [Script] WME HN NavPoints

Mon May 27, 2019 10:43 am

Could you please post detailed steps to try to reproduce the issue?

Re: [Script] WME HN NavPoints

Mon May 27, 2019 10:51 am

1. Locate a street that has house numbers and includes several segments.
2. Enter into the HN mode.
3. Select a number on an edge of a segment and move it to another segment.
4. Click "Save", then "Exit".
I see both the "before" and the "after" lines from the moment I have moved a number to another segment. The "before" line is still shown after I exit the HN mode and even after clicking Reload.

Working on Chrome, IL server.

Re: [Script] WME HN NavPoints

Mon May 27, 2019 3:47 pm

The "before" lines disappear when you refresh your tab - reload the whole tab, don't just hit the "reload" circle button on the upper right.

Re: [Script] WME HN NavPoints

Mon May 27, 2019 3:55 pm

Correct, but is it possible to remove the "before" line as soon as a number is moved, as it's done when a number is moved but remains anchored to the same segment?

Re: [Script] WME HN NavPoints

Mon May 27, 2019 6:07 pm

This is very problematic use case. I have tried to solve this again today, but one fix created another bugs... :/ I cannot promise, that I will be able to get this OK soon.

Re: [Script] WME HN NavPoints

Thu Jul 25, 2019 1:05 pm

Since the last WME update, HN NavPoints appears to be interfering with selection of HNs in the editor (click on an HN and it doesn't highlight, or show stop point).

Console message on clicking on the HN:
Code:
Uncaught TypeError: Cannot read property 'attributes' of undefined
    at t.eval (userscript.html?id=6aa9e507-ed79-41c2-972b-d08fd2056218:294)
    at initialize.triggerEvent (vendor-86dc9f4c83949efd6718.js:1)
    at HTMLDivElement.<anonymous> (app-1d3e5c24957b318a3943.js:1)
    at HTMLDivElement.dispatch (vendor-86dc9f4c83949efd6718.js:1)
    at HTMLDivElement.f.handle (vendor-86dc9f4c83949efd6718.js:1)


Anyone else having this issue?
Post a reply