[Script] UROverview Plus v3.102 (20170316)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] UROverview v1.21 (20130315)

Postby Twister-UK » Fri Mar 15, 2013 11:58 pm

Twister-UK
Beta tester
Beta tester
 
Posts: 2571
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 380 times
Been thanked: 2223 times

Re: [Script] UROverview v1.20 (20130302)

Postby Twister-UK » Fri Mar 15, 2013 12:48 pm

charleskelso wrote:A Possible Enhancement:

When you hover over the UR and the options dialog opens you have to carefully move down and then to the right to click on the desired option. If you're moving too quickly your cursor goes of the box and it disappears. I happen to be using a touch-pad on a laptop so sometimes it happens two or three times in a row. Anyway, is it possible to stack them in a column rather than the current row format? Then you can just keep going down.

So this:

[Open in new WME tab]
[Open in new livemap tab]
[Hide for this session]

Instead of this:

[Open in new WME tab] [Open in new livemap tab] [Hide for this session]


I like it, thanks for the suggestion! Haven't tried it on a touchpad yet, but even with a mouse it seems more natural to pick from a vertical list - it also means that for URs/problems that don't have lengthy titles or descriptive text, the width of the popup is kept to a minimum which looks neater.

This, along with a revised popup handler which now allows popups to appear immediately a new marker is highlighted (instead of having to move the mouse pointer off the current marker, wait for the popup to close, and then highlight the new marker), and a reinstatement of the UR/problem details pane auto-open functionality on Chrome (haven't changed anything in my code relating to this, so either the previously observed problems were a temporary glitch on the Waze servers, or the public version of WME has been quietly fiddled with once again...), form the basis of v1.21 which I'll be releasing just as soon as userscripts starts working properly again.
Twister-UK
Beta tester
Beta tester
 
Posts: 2571
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 380 times
Been thanked: 2223 times

Re: [Script] UROverview v1.20 (20130302)

Postby DisplayName » Thu Mar 14, 2013 1:43 pm

A Possible Enhancement:

When you hover over the UR and the options dialog opens you have to carefully move down and then to the right to click on the desired option. If you're moving too quickly your cursor goes of the box and it disappears. I happen to be using a touch-pad on a laptop so sometimes it happens two or three times in a row. Anyway, is it possible to stack them in a column rather than the current row format? Then you can just keep going down.

So this:

[Open in new WME tab]
[Open in new livemap tab]
[Hide for this session]

Instead of this:

[Open in new WME tab] [Open in new livemap tab] [Hide for this session]
DisplayName
 
Posts: 18
Joined: Thu Feb 16, 2012 3:35 am
Has thanked: 1 time
Been thanked: 2 times

Re: [Script] UROverview v1.20 (20130302)

Postby foxitrot » Wed Mar 06, 2013 1:16 pm

Twister_UK wrote:The bug in all of these versions will only show itself if you're using the filter settings to hide speed cameras by their speed value, and I suspect many users don't go anywhere near those settings...

I've also seen this "multiple URO links" bug manifesting in my browser, but never touched the filtering checkboxes for months.
Once I've thought I've solved it by an update (to 1.19?). Another time (some two weeks ago) I've noticed my USB disk (where a portable browser was installed) run out of space, cleaning up a few tens of MB solved it again.
I've also seen the rapid map panning problem, but never identified the script combination.
foxitrot
Waze Global Champs
Waze Global Champs
 
Posts: 7100
Joined: Thu Jul 14, 2011 10:22 pm
Location: Slovakia
Has thanked: 2406 times
Been thanked: 1100 times

Re: [Script] UROverview v1.20 (20130302)

Postby paulkok_my » Sun Mar 03, 2013 2:19 pm

Twister_UK wrote:The bug in all of these versions will only show itself if you're using the filter settings to hide speed cameras by their speed value, and I suspect many users don't go anywhere near those settings...


Thanks Twister_UK for pointing it out. I've downloaded version 1.20 and tested that it's working fine. :D
paulkok_my
Waze Global Champs
Waze Global Champs
 
Posts: 1042
Joined: Thu Jul 19, 2012 4:34 am
Location: Selangor, Malaysia
Has thanked: 270 times
Been thanked: 222 times

Re: [Script] UROverview v1.20 (20130302)

Postby Twister-UK » Sun Mar 03, 2013 10:21 am

The bug in all of these versions will only show itself if you're using the filter settings to hide speed cameras by their speed value, and I suspect many users don't go anywhere near those settings...
Twister-UK
Beta tester
Beta tester
 
Posts: 2571
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 380 times
Been thanked: 2223 times

Re: [Script] UROverview v1.20 (20130302)

Postby paulkok_my » Sat Mar 02, 2013 11:32 pm

Will download and test it out. I do not face any problems with version 1.19 here in Malaysia.
paulkok_my
Waze Global Champs
Waze Global Champs
 
Posts: 1042
Joined: Thu Jul 19, 2012 4:34 am
Location: Selangor, Malaysia
Has thanked: 270 times
Been thanked: 222 times

Re: [Script] UROverview v1.20 (20130302)

Postby magfro » Sat Mar 02, 2013 9:03 pm

Version 1.20 works just perfect!

Thanks for your dedication and fast resolving of this issue :!:
magfro
Area Manager
Area Manager
 
Posts: 175
Joined: Sun Jul 25, 2010 7:29 am
Has thanked: 9 times
Been thanked: 7 times

Re: [Script] UROverview v1.20 (20130302)

Postby Twister-UK » Sat Mar 02, 2013 8:34 pm

Thanks to the debug data provided by magfro, a long-standing bug (4 months old :shock: ) has now been nuked into oblivion, and hopefully the 1.20 release will solve the issue they noted above...

http://userscripts.org/scripts/show/145186
Twister-UK
Beta tester
Beta tester
 
Posts: 2571
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 380 times
Been thanked: 2223 times

Re: [Script] UROverview v1.19 (20130221)

Postby Twister-UK » Sat Mar 02, 2013 5:21 pm

Very weird. I've tried various combinations of scripts, zooming in/out, panning etc. and nothing goes wrong. Next time it happens, can you please grab a copy of the javascript console contents and send it to me in a PM. I've got a feeling it might be a timing-related error within URO itself causing it to glitch, rather than any sort of interaction with another script, in which case trying to trace it here could be impossible.
Twister-UK
Beta tester
Beta tester
 
Posts: 2571
Joined: Sat Jan 07, 2012 12:00 am
Location: NW London
Has thanked: 380 times
Been thanked: 2223 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: itzwolf, NalaKarokaro