[Script] WME Junction Node Fixer v0.1.6 2016-12-25

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby kentsmith9 » Tue Jul 08, 2014 12:05 am

Might have been from the editor update on Sunday? I think I saw a similar message this morning, but I thought it was the one we get periodically that does not seem to affect anything.
kentsmith9
Waze Global Champs
Waze Global Champs
 
Posts: 5192
Joined: Mon Apr 23, 2012 3:33 pm
Location: SF/SJ Bay Area of Northern California
Has thanked: 1326 times
Been thanked: 1568 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby bz2012 » Mon Jul 07, 2014 7:03 pm

new error message:

The page at https://www.waze.com says:
WME Junction Node Fixer has failed to load due to API
check: Waze.model
OK


Reloaded the page and no error message the second time. Some weird glitch?
bz2012
Map Raider
Map Raider
 
Posts: 1470
Joined: Wed Nov 23, 2011 4:32 pm
Location: Baton Rouge, La
Has thanked: 1152 times
Been thanked: 273 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby ottonomy » Thu Jul 03, 2014 12:53 am

sketch wrote:I get the error sometimes when already logged in, actually. I'm not sure what the problem is, but I believe it started happening only after I installed the Chrome Web Store version.


I've had the problem before the Chrome Web Store version was released, but it has presented itself more frequently since then.

Login status does not make a difference in my case. I never really log out, and when WME loads, following this API check message, I get the user greeting, and current points status, et cetera, confirming that I'm indeed logged in.
ottonomy
Global Champ Mentor
Global Champ Mentor
 
Posts: 725
Joined: Thu Oct 11, 2012 6:31 am
Location: Los Angeles CA
Has thanked: 1287 times
Been thanked: 567 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby sketch » Wed Jul 02, 2014 5:26 pm

Mike-1323 wrote:
olestas wrote:Why do I often get "WME Junction Node Fixer has failed to load due to API check: waze.map" message? It happens like in 40% time. And almost always when opening Editor for first time.

I think that has something to do with being logged in to the editor. If you're not logged in the splash screen appears and no map data is loaded. The info that JNF is looking for isn't there so it throws an error. If you log in and reload the page it doesn't throw the error. If you reload the page without logging in the error pops up.

At least that's my conjecture based on experience.

I get the error sometimes when already logged in, actually. I'm not sure what the problem is, but I believe it started happening only after I installed the Chrome Web Store version.
sketch
Waze Global Champs
Waze Global Champs
 
Posts: 5846
Joined: Sat Aug 08, 2009 6:13 pm
Location: New Orleans, LA
Has thanked: 1385 times
Been thanked: 1880 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby Olestas » Wed Jul 02, 2014 5:12 pm

Well.. ok.. fix anyone? :D
Olestas
Coordinators
Coordinators
 
Posts: 5502
Joined: Wed Mar 09, 2011 7:08 pm
Location: Latvia
Has thanked: 2525 times
Been thanked: 1867 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby Mike-1323 » Wed Jul 02, 2014 4:37 pm

olestas wrote:Why do I often get "WME Junction Node Fixer has failed to load due to API check: waze.map" message? It happens like in 40% time. And almost always when opening Editor for first time.

I think that has something to do with being logged in to the editor. If you're not logged in the splash screen appears and no map data is loaded. The info that JNF is looking for isn't there so it throws an error. If you log in and reload the page it doesn't throw the error. If you reload the page without logging in the error pops up.

At least that's my conjecture based on experience.
Mike-1323
Area Manager
Area Manager
 
Posts: 1026
Joined: Fri Jul 15, 2011 11:06 pm
Location: Lorton, Va
Has thanked: 3 times
Been thanked: 186 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby kentsmith9 » Wed Jul 02, 2014 3:15 pm

LOL. I had the SAME question and came here to see what was happening. :mrgreen:
kentsmith9
Waze Global Champs
Waze Global Champs
 
Posts: 5192
Joined: Mon Apr 23, 2012 3:33 pm
Location: SF/SJ Bay Area of Northern California
Has thanked: 1326 times
Been thanked: 1568 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby Olestas » Wed Jul 02, 2014 7:32 am

Why do I often get "WME Junction Node Fixer has failed to load due to API check: waze.map" message? It happens like in 40% time. And almost always when opening Editor for first time.
Olestas
Coordinators
Coordinators
 
Posts: 5502
Joined: Wed Mar 09, 2011 7:08 pm
Location: Latvia
Has thanked: 2525 times
Been thanked: 1867 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby qwaletee » Thu Jun 26, 2014 11:39 pm

I personally prefer Tampermonkey, easier to manage normally-installed scripts with it, userscripts.org troubles notwithstanding. Chrome extensions UI just takes too much clicking and scrolling.
qwaletee
US Waze Champs
US Waze Champs
 
Posts: 2866
Joined: Wed Feb 13, 2013 1:42 am
Location: NYC Metro - Active throughout NE^2 (Northeast & New England)
Has thanked: 227 times
Been thanked: 1109 times

Re: [Script] WME Junction Node Fixer v0.0.8.2 2014-01-29

Postby ModImmo » Sun Jun 15, 2014 7:07 pm

bigbear3764 wrote:So far, so good on NA server. Thanks


extension so far also good from UAE/AE , INTL/World server :D thanks.
ModImmo
 
Posts: 306
Joined: Fri Nov 15, 2013 7:01 am
Has thanked: 45 times
Been thanked: 8 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: Baidu [Spider], maalrivba, uscwaller