[Script] WME Color Highlights - 2.28 July 2019

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby voludu2 » Thu Aug 15, 2019 11:35 am

Thanks for giving the correct fix. Highlights works great with this one little change.
FIND:
function initCityList() {
var thisCity = W.model.segments.TopCityID();

REPLACE:
function initCityList() {
var thisCity = W.model.getTopCityId();

[ img ]
USA Northeast Region Discord Chat
State Manager - Pennsylvania
Country Manager - USA and Thailand
Wiki Master, Global Mentor
utilitas, simplicitas, retentionis
voludu2
Map Editor - Level 5
Map Editor - Level 5
 
Posts: 3041
Joined: Thu Jul 24, 2014 12:33 pm
Location: Chester County, Pennsylvania
Has thanked: 787 times
Been thanked: 1217 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby RussPA » Thu Aug 15, 2019 12:21 pm

I have 2.28 and I changed "W.model.topCityID" to "W.model.getTopCityId()" on line 820 and all is fine now, even though the script does show lots of red x, so there may be more that needs to be fixed.
[ img ] [ img ] [ img ] [ img ] [ img ][ img ] [ img ]
Assistant Regional Coordinator - NOR
Local Champ - US
WME Beta Community Coordinator
RussPA
US Waze Champs
US Waze Champs
 
Posts: 2597
Joined: Fri Nov 06, 2015 9:05 pm
Location: Bucks County, Pennsylvania
Has thanked: 348 times
Been thanked: 1039 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby age4670 » Sat Aug 17, 2019 9:51 am

Seems to be conflicting with WME Wide-Angle Lens. Not sure what I am looking for in the console to provide info.
[ img ][ img ][ img ][ img ]
AM Southern Queensland

Join us on the Waze Australia Discord Server.
age4670
Area Manager
Area Manager
 
Posts: 127
Joined: Tue Jan 15, 2019 10:58 am
Location: Queensland, Australia
Has thanked: 69 times
Been thanked: 13 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby ojlaw » Mon Aug 26, 2019 6:19 pm

hello, forgive me if this is not a Color Highlights issue. someone smarter than me suggested these errors may be caused by WME CH so i figured i would pass it along. thanks for an awesome script.
WME CH.jpg
(66.55 KiB) Downloaded 167 times
WI State Manager
IL Large Area Manager
CA, MN, ND, WA Area Manager
[ img ][ img ][ img ][ img ][ img ][ img ][ img ]
ojlaw
State Manager
State Manager
 
Posts: 122
Joined: Wed Jul 22, 2015 12:07 am
Has thanked: 61 times
Been thanked: 53 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby moosool » Wed Sep 25, 2019 12:48 pm

Would it be possible to change the color of the 'Filter by City' option which is currently in yellow? It is very difficult to see it on Primary Street segments. Thanks for considering.
moosool
Waze Local Champs
Waze Local Champs
 
Posts: 23
Joined: Sat Aug 08, 2015 4:04 pm
Has thanked: 7 times
Been thanked: 8 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby turbomkt » Wed Sep 25, 2019 3:11 pm

moosool wrote:Would it be possible to change the color of the 'Filter by City' option which is currently in yellow? It is very difficult to see it on Primary Street segments. Thanks for considering.


If they don't update the script, you can change the color using hex color codes at line 384. Search google for "hex color picker" and you should be able to find something that works better for you.
turbomkt
Country Manager
Country Manager
 
Posts: 1074
Joined: Thu Jan 22, 2015 1:05 am
Location: San Diego, Ca
Has thanked: 446 times
Been thanked: 294 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby SeveriorumPatrem » Fri Sep 27, 2019 7:05 pm

Just adding to the list... sorry.... but noticed today that if highlighting for a city name (City X) is enabled - and a particular segment has a different city name (City Y), but does not have City X as an alt and is therefore not highlighted - highlighting for no speed limit is not working.

* Highlights enabled for (1) City X and (2) No speed limit.
* A particular segment's primary city is City Y, and it has no alt cities. It also has no SL. No highlights appear.
* City X added as alt city.
* Segment is now highlighted for lack of speed limit.
* Speed limit added.
* Segment is now highlighted for City X.

This does not occur if the original segment has no primary city. In that case, the no-SL highlight works fine.

It's possible that city highlighting returning a negative result may block all other highlights, but I did not test that.

Maybe it's always been this way and I didn't notice?
[ img ][ img ][ img ][ img ]
The Grumpy Dad
The more I learn, the more I discover how much I don't know.
SeveriorumPatrem
Area Manager
Area Manager
 
Posts: 911
Joined: Thu Nov 19, 2015 11:05 pm
Location: SW Washington State
Has thanked: 505 times
Been thanked: 314 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby voludu2 » Fri Oct 11, 2019 12:31 pm

On segments where city and street have never been set (none not checked), there are no highlights.
So I cannot highlight by editor username.

Is this WAD?

[ img ]
USA Northeast Region Discord Chat
State Manager - Pennsylvania
Country Manager - USA and Thailand
Wiki Master, Global Mentor
utilitas, simplicitas, retentionis
voludu2
Map Editor - Level 5
Map Editor - Level 5
 
Posts: 3041
Joined: Thu Jul 24, 2014 12:33 pm
Location: Chester County, Pennsylvania
Has thanked: 787 times
Been thanked: 1217 times

Previous

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: hawkeygoal