Switch to full style
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Forum rules

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post a reply

Re: [Script] Colour Highlights for Segments - v1.6.2 Apr 201

Sun Jun 02, 2013 12:52 pm

Looks like TamperMonkey allows both my scripts to run just fine, without having to go through the crx stuff.. And since it seems it's fixed in Chrome 28 or 29, I doubt it's worth too much bother: https://code.google.com/p/chromium/issu ... ?id=242890

Re: [Script] Colour Highlights for Segments - v1.6.7 Jul 201

Sun Sep 08, 2013 9:16 am

n8nagel wrote:
drive4fun2me wrote:
n8nagel wrote:Is anyone else having issues? I'm not sure if it is due to the script or something with the NA server FDGB today (it was not working this AM, it *appears* to be working now)

Anyway, I just downloaded this script for Chrome as I wanted to find roads with mislabeled cities. Suddenly I am saving my changes but if I scroll away and then back to the area I just worked on, the changes I've done have reverted to their previous state.


I am having the same exact issue. Not sure what's going on


Yes, I don't think it's the script, there's another thread going about WME issues... guess I'll just let it alone until I see it's back to normal, which I'm assuming won't be until after the weekend. Must have been completely coincidental that that started happening immediately after I installed the script.


+1

Re: [Script] WME Color Highlights - 2.5 Nov 2015

Sun Feb 07, 2016 10:12 pm

SleepyBaker wrote:This script seems to be broken now the WME has been updated to include the news feed tab


+1

Re: [Script] WME Color Highlights - 2.7 APR 2016

Fri Apr 15, 2016 9:42 am

I'm using Firefox 42.0. For some reason, this script sometimes doesn't load. It usually appears when I just log in, but once I refresh the editor or open another in a new tab, the highlights tab isn't there. Also, the script has a yellow background when I view it on the Add-ons menu in Firefox.

I'm wondering if anyone here had a similar issue and solved it.

Re: [Script] WME Color Highlights - 1.91 July 2014

Tue Oct 14, 2014 3:31 am

Tim, is there any way to separate locked roads from locked landmarks? The number of locked roads is overwhelming when you're trying to see just the locked landmarks.

Re: [Script] WME Color Highlights - 1.91 July 2014

Mon Oct 20, 2014 5:36 am

The "Recently Edited" doesn't seem to be working properly. I thought it wasn't working at all, but then I saw some segments highlighted. It does work on landmarks, but the issue is with segments.

Re: [Script] WME Color Highlights - 1.94 Oct 2014

Tue Dec 02, 2014 9:12 pm

Timbones wrote:While I accept that a few places might not have any category that fits them, I think we have very many more which could but currently have a parent category. So, I still feel it's important to flag places that use parent categories, but if they cannot be changed then we'll just have to live with that.

Perhaps I could show a dashed border for these, without the orange hightlight?


How about a second checkbox that would highlight places with parent categories. That way, it could be turned on if someone is bored and wants to look deeper into those, but turned off for a quick scan of the bad stuff.

Re: [Script] WME Color Highlights - 2.5 Nov 2015

Sun Apr 03, 2016 1:26 am

Any chance we can get a separate checkbox under the Speed Limits section to toggle highlighting of Ramps? In the US, in most cases, we're not setting speed limits on ramps, and sometimes, there's a big blob of highlight around freeways and major highways where there's a lot of ramps and it makes it hard to distinguish whether the freeway has been set or not.

Thanks!

Re: [Script] WME Color Highlights - 2.5 Nov 2015

Sun Apr 10, 2016 9:19 pm

Timbones wrote:I couldn't decide what to do about ramps, and I didn't want to force personal and local ideas on to everyone.

How about if ramps are only highlighted if Streets checkbox is selected?

Sent from my Wileyfox Swift using Tapatalk


I think that may result in an even worse conflict. How hard would it be to make a checkbox for each road type to highlight? I'm done with freeways and am working on Major Highways in my state. It would be handy to only show those so I could keep my eye on my goal rather than be distracted by everything else that's highlighted. This is a more linear project rather than something concentrated on by area...at least the way I'm doing it.

EDIT: In the U.S., we're not really putting speed limits on ramps except in the rare case where there's a regular black and white speed limit sign on the ramp. In most cases, we have a yellow sign with black lettering, which is an advisory speed and not an enforceable speed limit. I don't know how it's done in the rest of the world. That's why I was specifically asking about ramps. I'm just looking for a way to do it that won't conflict with differing rules and methods in other places.

Re: [Script] WME Color Highlights - 2.7 APR 2016

Mon Apr 11, 2016 10:37 pm

Timbones wrote:Rightio then. I've just uploaded Color Highlights v2.7 that adds a separate option for Ramps.

I've maybe fixed Alan's issue with localeCompare too. If not, send me a permalink of where it occurs.

:ugeek:


Thanks Tim. That will end my frustration!
Post a reply