[Script] WME Color Highlights - 2.33 Sept 2020

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Color Highlights - 1.91 July 2014

Postby AlexN-114 » Wed Oct 15, 2014 4:16 pm

dmcrandall wrote:I installed the script version, and didn't see any of the extended options (last edited, etc). I ended up re-enabling the Extension, while the script was running, just to check.

I had the same, when I run it together with my Highlighter (HiLiCi). When i deactivated my Highlighter, I got all options (after a reload of the page). In all cases the Toolbox and many other scripts were running.
best regards Alex ;)
AM Waldviertel (NÖ)/Forest quarter (Lower Austria) / CM Austria / GC
[ img ]
HiLiCi @ greasyfork.org or @ userscripts.org
AlexN-114
 
Posts: 590
Joined: Thu Jun 21, 2012 7:22 pm
Location: Wien, Österreich (Vienna, Austria)
Has thanked: 225 times
Been thanked: 367 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby alexs001 » Fri Jul 03, 2020 9:33 pm

I started getting uncommanded highlights of nameless roads today. Disabling and reenabling this script seems to have made the problem go away. The highlights were in a much more intense orange than you use for this category of highlight, so it's possible it wasn't even this script's doing. Just posting in case anyone else has encountered the same.
Area Manager: Okanagan Valley, BC / Newfoundland and Labrador
[ img ] [ img ]
alexs001
Waze Local Champs
Waze Local Champs
 
Posts: 860
Joined: Fri Oct 26, 2012 5:27 am
Location: Kelowna, BC, Canada
Has thanked: 183 times
Been thanked: 294 times

Re: [Script] WME Color Highlights - 2.28 July 2019

Postby alexs001 » Sun Jul 05, 2020 6:13 am

Timbones wrote:
alexs001 wrote:I started getting uncommanded highlights of nameless roads today.

Perhaps you accidentally enabled WME's built-in "Highlight segments with no name"? (Shift+D)
Well, you learn something new every day. Thanks!
Area Manager: Okanagan Valley, BC / Newfoundland and Labrador
[ img ] [ img ]
alexs001
Waze Local Champs
Waze Local Champs
 
Posts: 860
Joined: Fri Oct 26, 2012 5:27 am
Location: Kelowna, BC, Canada
Has thanked: 183 times
Been thanked: 294 times

Re: [Script] WME Color Highlights - 2.5 Nov 2015

Postby AliG2605 » Wed Feb 10, 2016 9:11 am

I'm also unable to run this script (or any other scripts!) since the WME update. I'm using firefox/greasymonkey on a mac using the latest OSX. The script was working fine before the WME update. I've tried disabling all other scripts, putting it first in execution order, refreshing page...

Brilliant script when its working though. Thanks for all the work put into it.
AliG2605
 
Posts: 292
Joined: Mon Apr 21, 2014 2:04 am
Location: ACT, Australia
Has thanked: 128 times
Been thanked: 70 times

Re: [Script] WME Color Highlights - 2.5 Nov 2015

Postby AliG2605 » Fri Feb 12, 2016 9:40 am

An update on my situation with scripts (including color highlights) not working (firefox/greasymonkey on a mac):
I uninstalled all other scripts except colour highlights and color highlights still wouldn't work, no matter what I tried.
Then, missing having validator (which also hadn't been working too), I thought I would try reinstalling the validator script. So I navigate from my WME page to my bookmark of the Validator script page, install the script and hit the back button and Color highlights is working again. (Tab is showing and some segments are in Orange (no speed limit)... Hooray.
Hang on Validator still has a tab. Refresh page and Color highlights stops working. Back to square one...
I tried repeating the process: removing Validator, reinstalling Validator and that got color highlights start working again...
So there's a problem here somewhere. I hope this info helps to solve it.
Cheers
AliG2605
 
Posts: 292
Joined: Mon Apr 21, 2014 2:04 am
Location: ACT, Australia
Has thanked: 128 times
Been thanked: 70 times

Re: [Script] WME Color Highlights - 2.25 May 2018

Postby AlObaili » Thu Apr 25, 2019 2:30 pm

Hello,

I'm not sure if this has been asked before, but is it possible to add a setting to hide road highlights if the roads layer is hidden?
Last edited by AlObaili on Sun Apr 28, 2019 9:35 am, edited 1 time in total.
[ img ]
[ img ][ img ][ img ][ img ]
مـنـســـق مــجـتـمـع ويـز الـسـعــوديـة والــبحـريـن ومـنـســق الـتعــريـب لـمـنـتجـات ويــز
CM for Saudi Arabia & Bahrain & Transifex Coordinator for Arabic
AlObaili
PartnerCoordinator
PartnerCoordinator
 
Posts: 350
Joined: Sun Apr 20, 2014 4:04 pm
Location: Saudi Arabia
Has thanked: 235 times
Been thanked: 155 times

Re: [Script] Colour Highlights for Segments - v1.6.7 Jul 201

Postby andrcondon » Thu Aug 01, 2013 3:40 pm

I've been working with "smudged" cities and non-existing cities, and this script is really useful for that.
I'd like to ask if it would be possible to add a "Highlight city (select city name)" to see only (or on top) the city polygon of the selected name.
Thank you
Andrés Condón
andrcondon
[ img ] [ img ] [ img ] [ img ]
andrcondon
Map Editor - Level 6
Map Editor - Level 6
 
Posts: 243
Joined: Mon Jun 10, 2013 11:19 am
Has thanked: 96 times
Been thanked: 86 times

Re: [Script] Colour Highlights for Segments - v1.6.2 Apr 201

Postby AndyPoms » Sun May 26, 2013 9:13 pm

1.6.4 BUG: Landmark with type Park no longer tinted green
[ img ]
Waze Champ & Forum Moderator
USA Country Manager
Senior Area Manager: State of Connecticut
Wiki: Editing | Best Practices | FAQ
AndyPoms
EmeritusChamps
EmeritusChamps
 
Posts: 7223
Joined: Tue Dec 27, 2011 1:34 pm
Location: Hartford, CT
Has thanked: 129 times
Been thanked: 1331 times

Re: [Script] Colour Highlights for Segments - v1.6.7 Jul 201

Postby AnotherHiggins » Wed Jul 17, 2013 4:42 am

First: Thanks a ton, Timbones. This is a great tool.

But I'm having the same problem where there are no options in the drop-downs for Filter By City or Filter By Road Type. Also, I'm missing all of the Advanced Options even though I'm a level 5 and a CM.

Waze_WMEColourHighlights_Broken001.JPG
(35.22 KiB) Downloaded 3611 times


I've uninstalled my previous version, re-downloaded 1.6.7 (multiple times) from UserScripts, and restarted Chrome. Then I repeated all of those steps.

Still no go.

The previous version works fine.

I'm on Chrome Version 28.0.1500.72, if that helps.
[ img ]
CM USA
AM Raleigh/Durham & Charlotte, NC
Android Nexus 4
AnotherHiggins
 
Posts: 171
Joined: Mon Nov 29, 2010 4:53 am
Location: NC
Has thanked: 3 times
Been thanked: 92 times

Re: [Script] Colour Highlights for Segments - v1.6.7 Jul 201

Postby AnotherHiggins » Wed Jul 17, 2013 8:06 pm

Timbones wrote:You need to install the .crx package for Chrome - there are instructions and a link posted to that page.

I've got the .crx version now and it's working fine. Man, that's embarrassing. :oops:

Thanks again for your work on this extension.
[ img ]
CM USA
AM Raleigh/Durham & Charlotte, NC
Android Nexus 4
AnotherHiggins
 
Posts: 171
Joined: Mon Nov 29, 2010 4:53 am
Location: NC
Has thanked: 3 times
Been thanked: 92 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: BenEnmen, Google Feedfetcher, Mapman44, Mythdraug