[Script] WME Validator v2021.3.5 (+ PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 1.0.1 / 25.06.2014

Postby GeekySmurf » Fri Jun 27, 2014 7:40 pm

I get the same thing ctpoole gets. You place a node because validator says you need a node, then you hit save and it throws an error for having the node. It's a vicious cycle.


I have been doing cleanup with Validator in low traffic areas. Per the Wiki I have been adding the node to these scenarios and have not received errors on save for the most part. There have been a couple of occasions where there was a loop that would cause some errors and I would need to build out a section at a time, but never an error when adding the extra node.
Last edited by GeekySmurf on Fri Jun 27, 2014 9:00 pm, edited 1 time in total.
GeekySmurf
Area Manager
Area Manager
 
Posts: 28
Joined: Wed Apr 23, 2014 3:05 am
Location: New Orleans, LA
Has thanked: 13 times
Been thanked: 9 times

Re: [Script] WME Validator 1.1.19 / 04.06.2016

Postby gertbroos » Wed Sep 14, 2016 10:00 pm

Is there another script out there that I can use untill this validator script is updated, that highlights newly drawn roads (the glow around them) ?

It's such a handy feature when drawing in lot's of new segments... Really miss that part :)
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 367
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 250 times

Re: [Script] WME Validator 1.1.19 / 04.06.2016

Postby gertbroos » Thu Sep 29, 2016 12:41 pm

It would help if the original autor shared his code :)
gertbroos
Waze Local Champs
Waze Local Champs
 
Posts: 367
Joined: Mon Jan 19, 2015 4:04 pm
Location: Belgium
Has thanked: 88 times
Been thanked: 250 times

Re: [Script] WME Validator 1.1.8 / 07.05.2015

Postby GFM_Danny » Thu Nov 05, 2015 12:59 pm

SpencerFG wrote:I have found that Validator has stopped working with Chrome after the WME update. Is there something I need to do to make it work or is an update required?


Yes, i have the same problem, ita not working with the new WME interdace, hope there will soon a new.update od validator. It helps much eduting segmen.
GFM_Danny
Waze Local Champs
Waze Local Champs
 
Posts: 3480
Joined: Wed Dec 24, 2014 7:04 am
Location: Bandung
Has thanked: 1476 times
Been thanked: 1141 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby GFM_Danny » Tue May 24, 2016 7:02 am

yes..not working at my side either..i'm also use chrome to edit
GFM_Danny
Waze Local Champs
Waze Local Champs
 
Posts: 3480
Joined: Wed Dec 24, 2014 7:04 am
Location: Bandung
Has thanked: 1476 times
Been thanked: 1141 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby GFM_Danny » Tue May 31, 2016 1:50 pm

Is the Validator functional again?
Somtime's is active and most not working.
If I got a permalink for an unlock request, suddenly work..and if I close the window/tab, opening a new window/tab..it disapear again.
I'm using Chrome as browser.
GFM_Danny
Waze Local Champs
Waze Local Champs
 
Posts: 3480
Joined: Wed Dec 24, 2014 7:04 am
Location: Bandung
Has thanked: 1476 times
Been thanked: 1141 times

Re: [Script] WME Validator 1.1.8 / 07.05.2015

Postby GiancarloG » Thu Nov 05, 2015 11:51 am

SpencerFG wrote:I have found that Validator has stopped working with Chrome after the WME update. Is there something I need to do to make it work or is an update required?


My guess is we'll have to wait until they release an update compatible with the new WME.
Giancarlo Giuliano
Editor Level 5
Guayaquil - ECUADOR
GiancarloG
Waze Local Champs
Waze Local Champs
 
Posts: 222
Joined: Sat Feb 23, 2013 10:10 pm
Location: Guayaquil - Ecuador
Has thanked: 37 times
Been thanked: 37 times

Re: [Script] WME Validator 0.5.1 (BETA) / 21.01.2014

Postby GinBook » Fri Jan 24, 2014 6:51 pm

porubcan wrote:berestovskyy, would it be possible to include SK (Slovakia) and CZ (Czech Republic) into those country specific checks?

12. BETA Lowercase street name (SK only, not for CZ)
50. BETA: Lowercase street name (with exceptions) (CZ only, exceptions: náměstí; nám.; nábřeží)
13. BETA: Two-way Freeway segment
53. City name on Railroad
63. Less than 3 letters long street name
64. More than 25 letters street name (ramps excl.)
68. No lock on Freeway
69. No lock on Major Highway
70. No lock on Minor Highway

thank you very much for great help and maybe just small suggestion - separate checks in the complete list into groups, e.g.:
- checks not adjacted to other scripts:
A. checks vallid for all countries
B. country specific checks
- checks using other scripts
C. checks vallid for all countries
D. country specific checks

this will allow better overview of all checks with separate numbering for each group so no need to renumber the list and if someone will reffer to check A13 it will be clear regardless of current version.

than you.



Hi berestovskyy

50. BETA: Lowercase ....... (CZ only, exceptions: náměstí; nám.; nábřeží) add třída; tř.; nábř.

than you.
GinBook
Waze Global Champs
Waze Global Champs
 
Posts: 6791
Joined: Tue Oct 12, 2010 8:35 am
Location: Czech Republic
Has thanked: 906 times
Been thanked: 1609 times

Re: [Script] WME Validator 1.0.3 / 04.08.2014

Postby giuffr0lo » Sun Aug 24, 2014 2:15 pm

Same in Italy. Broken update?
giuffr0lo
 
Posts: 3
Joined: Mon Jul 14, 2014 2:51 pm
Has thanked: 0 time
Been thanked: 0 time

Re: [Script] WME Validator 0.6.3 (BETA) / 12.02.2014

Postby GizmoGuy411 » Wed Feb 19, 2014 12:41 pm

While in the process of reviewing the example area for a potential new AM for the Great Lakes Region of the US, I had Validator crash my computer.

It crashed at the end of the scan with the final audio prompt sounding continuously. The crash was so bad that I had power down the computer. (PC with Windows 7.)

The scan for this PL took quite a while, so I wondered if the size of the report that was a factor.

I tried it again with a different PL and it worked ok.

If anyone wants to chance crashing their system the PL was:
https://www.waze.com/editor/?lon=-94.39 ... TT&env=usa

UPDATE: I tried the same PL that previously crashed at "zoom=1" and "zoom=1" and it did not crash. I was too reluctant to try it again at "zoom=0".

U.S. based Global Champ Emeritus
U.S. Local Champ
U.S. Country Manager
U.S. Great Lakes ARC: IL, IN, MI, OH, WI
(and past GLR RC)
AM: NW OH, NE IN, SE MI
Wiki Profile
Verizon: Google Pixel XL3 & iPad "3"
GizmoGuy411
EmeritusChamps
EmeritusChamps
 
Posts: 1470
Joined: Wed Oct 13, 2010 3:14 am
Location: NW Ohio, SE Michigan, NW Indiana tri-state area
Has thanked: 895 times
Been thanked: 563 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: dfortney, jm6087