Page 130 of 237

Re: [Script] WME Validator 1.1.20 / 03.11.2016

PostPosted: Mon Dec 05, 2016 4:55 pm
by ldriveskier
SuperDave1426 wrote:I'm probably missing something here.... :-) What exactly is the problem that the date fix script fixes, and is it really necessary for the proper/better functioning of other scripts?

Thanks for any info!


The "problem" is more of a preference. The default for the date display is very long, so this shortens it up and makes it easier to read. Here is a link to another thread that explains it: https://www.waze.com/forum/viewtopic.ph ... 6#p1540156

Re: [Script] WME Validator 1.1.20 / 03.11.2016

PostPosted: Mon Feb 13, 2017 12:37 pm
by ldriveskier
GeekDriverPeaceful wrote:I read the code, didn't try yet. Looks very promising! It basically grabs the latest rendering class from WME and apply it to Validator. This will (hopefully) show highlights. Neat!


I tried it and it is WORKING for me.

Thank you, dbcm!

Re: [Script] WME Validator 1.1.20 / 03.11.2016

PostPosted: Mon Feb 13, 2017 2:42 pm
by ldriveskier
Thanks to markr4468 for detailed instructions on installation of dbcm's fix:

1) Go To Tampermonkey Dashboard
2) Click Utilities Tab
3) Paste http://dbcm.github.io/waze/valfix/valfix.js in the URL Box
4) Click Import
5) Click Install
6) Click Installed Userscripts Tab
7) Click On Waze Map Editor - Validator Fix
8) Click On Settings
9) Set Position to #1
10) Hard Refresh in WME
11) Enable Any Localization Files you have.

(Note: If you disabled Validator, don't forget to re-enable it!)

Re: [Script] WME Validator 1.1.20 / 03.11.2016

PostPosted: Mon Feb 13, 2017 3:06 pm
by ldriveskier
Glodenox wrote:So the addition of the ExtendedSVG renderer fixes the script already? I've just installed the userscript at https://dbcm.github.io/waze/valfix/valfix.js as a userscript on Firefox, but the validator still doesn't seem to work yet here (I've made it so that the fix gets executed before validator).

I'll look into it later if other people say this does seem to fix validator for them.


dbcm said "In the case you are using WME Validator through Tampermonkey", so it sounds like you need to use Tampermonkey.

Re: [Script] WME Validator 1.1.20 / 03.11.2016

PostPosted: Wed Apr 19, 2017 2:55 pm
by ldriveskier
jangliss - is that a problem with Validator and its fix or with a validator Localization script? I know the Localization scripts that I use were modified after the language change, so yours might need that also.

Re: [Script] WME Validator 1.1.20 / 03.11.2016

PostPosted: Wed Apr 19, 2017 8:21 pm
by ldriveskier
Sorry, I don't understand the nuts and bolts of the required updates, but I know that XanderB updated the Validator Localization scripts for the states that I use it for when the new language was released to WME. I would suggest dropping him a PM if you'd like to compare notes (or to point him to your post here). Good luck!

Re: [Script] WME Validator 1.1.20 / 03.11.2016

PostPosted: Mon Jul 17, 2017 2:38 pm
by ldriveskier
I would recommend locking this thread and adding a "MOD NOTE" to the OP like was done for the Closest Segment script. This topic could be reopened if/when the original author returns.

Re: [Script] WME Validator 2019.09.24 (PLACES BETA)

PostPosted: Mon Mar 09, 2020 4:23 pm
by ldriveskier
RichardPyne wrote:Using version 2019.09.24 when trying to scan, it appears that the scan starts, then just stalls.


Try turning off other scripts, especially WME Color Highlights. IME, it seems to be a script conflict.

Re: [Script] WME Validator 0.7.3 (BETA) / 24.02.2014

PostPosted: Mon Feb 24, 2014 11:44 pm
by LeighGr
berestovskyy wrote:24.02.2014 v0.7.3:
- NEW for All 'BETA: Overlapping segments at node A/B'
- NEW for All 'BETA: Too sharp turn at node A/B'
- check IDs moved to the end of the check title


Something isn't quite right. The only instruction I'm getting is "Zoom out to start WME Validator". I'm at zoom level 0, and can't go out anymore :)

Re: [Script] WME Validator 0.7.3 (BETA) / 24.02.2014

PostPosted: Mon Feb 24, 2014 11:48 pm
by LeighGr
LeighGr wrote:
berestovskyy wrote:24.02.2014 v0.7.3:
- NEW for All 'BETA: Overlapping segments at node A/B'
- NEW for All 'BETA: Too sharp turn at node A/B'
- check IDs moved to the end of the check title


Something isn't quite right. The only instruction I'm getting is "Zoom out to start WME Validator". I'm at zoom level 0, and can't go out anymore :)


:oops: Sorry, Brain dead. Validator was disabled. :oops: Though not the right error message, should be more like "Click the button below to enable"!

Repeatable by disabling WMEV, then pressing the "Clear the report and segment cache" button, and you're left with a "Zoom out to start WME Validator" message.