[Script] WME Validator 2019.08.29 (BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, JustinS83, Glodenox

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby iainhouse » Tue Feb 26, 2019 11:23 pm

The update seems to have fixed multiple issues I was seeing:
  • Alt-click on second segment not selecting all between first & second
  • WME Toolbox failing during load 9 times out of 10 with missing highlights and an empty drop-down menu
  • Attempts to set speed limits using WME Speedhelper behaving very strangely!
Thanks for the quick fix. :mrgreen:
[ img ][ img ][ img ]
UK AdminsUK WikiWaze FAQWMEFU Script :ugeek:
I want to go to a commune in Vermont and deal with no unit of time shorter than a season
iainhouse
Country Manager
Country Manager
 
Posts: 9934
Joined: Mon Jul 23, 2012 5:16 pm
Location: on the road from London to insanity, with Waze HQ in the driving seat
Has thanked: 2565 times
Been thanked: 7953 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby mudge42 » Wed Feb 27, 2019 3:27 am

Yes, that fixes the two issues I was seeing. Thanks!
mudge42
State Manager
State Manager
 
Posts: 347
Joined: Wed Sep 10, 2014 4:06 pm
Location: Massachusetts
Has thanked: 125 times
Been thanked: 121 times

Re: [Script] WME Validator 2018.09.15 (BETA)

Postby berestovskyy » Wed Mar 06, 2019 9:24 pm

berestovskyy wrote:
Nazride wrote:error on : Noeud A: inutil (mode lent) (#36)
or here

https://www.waze.com/fr/editor/?zoom=7& ... =343409108

Same issues as with lg1992 report: WME sometimes does not report nodes as "partial". We will try to workaround it in the code.


Hey guys,
The issues with "ghost" (disappearing) Validator reports due to the missing attribute "partial" is fixed in the latest WME Beta. So it will be available for everyone soon ;)

Sorry, it took quite a time. But still I'm really impressed Waze guys managed to fix it!
berestovskyy
 
Posts: 894
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 323 times
Been thanked: 806 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby shmupi » Wed Mar 06, 2019 9:44 pm

With some help from the community :)

Sent from my SM-G960F using Tapatalk
Israel Coordinator & Community Leader & GC
Country Manager : Israel, Jordan, Thailand, Romania
Resolved Update Requests : 185K

[ img ]
shmupi
Waze Global Champs
Waze Global Champs
 
Posts: 20885
Joined: Tue Jan 06, 2009 7:16 am
Has thanked: 6697 times
Been thanked: 2150 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby LysdexiaEht » Thu Mar 21, 2019 1:25 am

Hi, I'm using Version 73.0.3683.86 (Official Build) (64-bit) of Chrome, and Validator more often than not fails to load. I've tried disabling all extensions except validator, close, reopen, and it seems to exhibit the same issue. What kind of steps could I take to troubleshoot this further?
[ img ]
AM: Regional Queensland
LysdexiaEht
Area Manager
Area Manager
 
Posts: 97
Joined: Fri Mar 08, 2019 4:04 am
Has thanked: 40 times
Been thanked: 11 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby berestovskyy » Thu Mar 21, 2019 5:48 am

LysdexiaEht wrote:What kind of steps could I take to troubleshoot this further?

Thanks for reporting.

Could you please check the JavaScript console (View->Developer->JavaScript Console) if there are any logs or errors from Validator or WME...
berestovskyy
 
Posts: 894
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 323 times
Been thanked: 806 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby LysdexiaEht » Fri Apr 05, 2019 2:16 am

Sorry for the long overdue reply, when Validator fails to load, in the console I see (filtered as Validator):

WME Validator v2019.02.26: waiting for login...


When it succeeds (after a few refreshes) I see:

WME Validator v2019.02.26: login LysdexiaEht
[ img ]
AM: Regional Queensland
LysdexiaEht
Area Manager
Area Manager
 
Posts: 97
Joined: Fri Mar 08, 2019 4:04 am
Has thanked: 40 times
Been thanked: 11 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby berestovskyy » Fri Apr 05, 2019 5:28 am

If there are no errors in between those logs, it’s normal...

Which Waze server do you use? Or which country you are from?
berestovskyy
 
Posts: 894
Joined: Fri Jul 15, 2011 1:50 pm
Has thanked: 323 times
Been thanked: 806 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby Nazride » Fri Apr 05, 2019 8:50 am

LysdexiaEht wrote:Validator more often than not fails to load.


Hello, same issue, i need to do multiple refresh for having validator available (editor normal version (no beta), chrome browser, editing in France)
Nazride
 
Posts: 155
Joined: Sat Sep 30, 2017 5:15 pm
Has thanked: 37 times
Been thanked: 29 times

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby timtamcan » Tue Apr 09, 2019 11:43 pm

Nazride wrote:
LysdexiaEht wrote:Validator more often than not fails to load.


Hello, same issue, i need to do multiple refresh for having validator available (editor normal version (no beta), chrome browser, editing in France)


Same issue here - editing in Australia on Chrome, normal WME. Only loads sometimes. Console is saying that its waiting for login - maybe it's a race condition?

EDIT - Interestingly when I breakpoint the log function and manually resume script execution it always works so definitely looks like a race condition.

EDIT #2 - I replaced the following line in F_INIT function (line 468 in other.js):
Code: Select all
async(F_ONLOGIN);

with this and it seems to have fixed it (hacky but better than nothing):
Code: Select all
var lc = setInterval(function() {
    if ((WLM.isLoggedIn && WLM.isLoggedIn()) || WLM.user) {
        if (!_WV.$loggedIn) F_ONLOGIN();
        clearInterval(lc);
    }
}, 1000);


If you want to use the version I modified (v2019.02.26) you can grab it here (requires Tampermonkey on Chrome/Firefox, remove the WME Validator Chrome extension if you have it):
https://gist.github.com/master131/d919d ... or.user.js
timtamcan
 
Posts: 6
Joined: Sat Mar 23, 2019 7:17 am
Has thanked: 1 time
Been thanked: 5 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: age4670, ramblinwreck_81