Switch to full style
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Forum rules

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post a reply

Re: [Script] WME Validator 0.6.0 (BETA) / 04.02.2014

Tue Feb 04, 2014 3:21 pm

Hi !

Validator is becoming more and more useful every day, nice and quick development.
Thanks for all the updates and improvements.

Still I have a situation with "Same endpoints drivable segments".

Here is the permalink.

The issue is that one segment goes one way ant the other is the return way.
There is no mistake on the roads, thus when one segment goes one way ant the other segment goes the other way, there is no error and should not be highlighted.

I hope you can fix this to prevent a false positive highlight.

Best regards, from Concepción, Chile,

Re: [Script] WME Validator 0.6.2 (BETA) / 07.02.2014

Mon Feb 10, 2014 6:19 pm

Dear Berestovskyy,

I have some small issue on the report of the area on the permalink.

At the end of the report says:
Summary
WME Validator has checked 635 segments and reported 2 errors (3‰) and 8 warnings (13‰).

3% of 635 errors is not 2 errors, and
13% of 635 errors is not 8 errors.

Percentage is being calculated with a big error (Reported percentage is 10 times bigger than real)

As you can see Validator has aloud me to reduce significantly the errors of the area (over 200 when started fixing it, I didn´t check percentage before starting).

I hope you can fix this small issue, it is not a bug, is just a small issue and has nothing to do with the proper functionality of the error detection.

Best regards form Concepción, Chile,

Re: [Script] WME Validator 0.6.2 (BETA) / 07.02.2014

Mon Feb 10, 2014 6:57 pm

bedo2991 wrote:
fernandoanguita wrote:Percentage is being calculated with a big error (Reported percentage is 10 times bigger than real)

Look more carefully to the "percentage" sign in your report: https://es.wikipedia.org/wiki/Por_mil
8:635 = x:1000
x = 8 * 1000 / 635 = 12.60


Oops... !!!!!
You are right, I was not careful enough to look it right. :oops:

Or may be I need glasses :D

Thanks for the quick reply !

Re: [Script] WME Validator 0.9.4 (BETA) / 30.03.2014

Mon Apr 07, 2014 8:24 pm

petervdveen wrote:Look at this page:
https://wiki.waze.com/wiki/Minimum_segment_length

The minimum segment length is 5 meters.
I would like to have a minimum of 6 meters (to be sure) in the benelux.


I agree also for Latin America and Spain, minimum lenght should be 5m it is a reasonable value.

(I think that is the actual value).

Re: [Script] WME Validator 1.0.4 / 24.08.2014

Wed Aug 27, 2014 11:40 pm

rulikoto wrote:Still have the trouble with the node fixer, anybody can explain?


There is a problem with the new editor API exchange of information with node fixer.

Solution in on the way, just be patient, I am sure all involved people is looking a this on their free time. Just be patient, it will be solved soon.

Best regards from Concepción, Chile,

Re: [Script] WME Validator 1.1.0 / 29.08.2014

Fri Aug 29, 2014 2:05 pm

Thanks again for your dedicated work !

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Tue Nov 08, 2016 5:52 pm

kahlcolimon wrote:I'm detecting some problems when saving. Do you think this is due to the script or general conditions of the WME?


WME Editor has some issues... they are not script related.

Best regards from Talca, Chile,

Re: [Script] WME Validator 1.1.16 / 24.05.2016

Tue May 24, 2016 6:02 am

Is is possible that the WME Validator is not longer loading in the new released WME.
I use Chrome to edit and have tried reinstalling the extension several times.

Re: [Script] WME Validator 1.1.16 / update WME 24.05.2016

Tue May 24, 2016 8:13 pm

Today we received to WME Toolbox update ! :-)

What about the WME Validator update ?

Re: [Script] WME Validator 1.1.19 / 04.06.2016

Mon Oct 03, 2016 11:43 pm

May I kindly ask that whoever comes up with a replacement please put a clause in the TOS which allows it to be fixed if this happens again? Because I'm sure we all love to see a perfectly good script go to waste.
Post a reply