[Script] WME Validator 2020.04.12 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 0.7.4 (BETA) / 28.02.2014

Postby Laurentwb » Sat Mar 01, 2014 8:33 am

Hello,

First of all, many thanks to the authors for this very useful script !

I am wondering if would be possible to get a version that would highlight primary streets that are not locked at level 2.

Thank you.

Laurent
Laurentwb
Area Manager
Area Manager
 
Posts: 497
Joined: Mon Nov 14, 2011 10:18 pm
Has thanked: 44 times
Been thanked: 38 times

Re: [Script] WME Validator 0.7.4 (BETA) / 28.02.2014

Postby Laurentwb » Sat Mar 01, 2014 1:10 pm

berestovskyy wrote:Sure, will be implemented in the next release for Benelux.


That's great.
Thanks a lot !
Laurentwb
Area Manager
Area Manager
 
Posts: 497
Joined: Mon Nov 14, 2011 10:18 pm
Has thanked: 44 times
Been thanked: 38 times

Re: [Script] WME Validator 0.8.0 (BETA) / 08.03.2014

Postby Laurentwb » Sat Mar 08, 2014 5:21 am

Thanks for the update !
Laurentwb
Area Manager
Area Manager
 
Posts: 497
Joined: Mon Nov 14, 2011 10:18 pm
Has thanked: 44 times
Been thanked: 38 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby ldriveskier » Sun Nov 20, 2016 10:19 pm

Actually, whatever WME update happened last night has caused validator to start working (or at least act like it is working) for me.
[ img ][ img ][ img ][ img ][ img ][ img ]
USA LC/CM, MAR ARC, GLR LC (resident of Ohio), App Beta Leader
ldriveskier
Coordinators
Coordinators
 
Posts: 904
Joined: Fri Feb 19, 2016 9:05 pm
Location: Northeast Ohio, United States
Has thanked: 1793 times
Been thanked: 1051 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby ldriveskier » Thu Dec 01, 2016 2:41 pm

I am VERY happy that Validator is working again. Thank you!!! However, I get a pop-up every time I open a page in WME or hard refresh WME. I don't know if it is something that changed in Validator or an incorrect setting on my end, but it is annoying. Can someone help to get rid of this please?

Validator_popup.JPG
(36.66 KiB) Downloaded 2387 times


Thank you!
[ img ][ img ][ img ][ img ][ img ][ img ]
USA LC/CM, MAR ARC, GLR LC (resident of Ohio), App Beta Leader
ldriveskier
Coordinators
Coordinators
 
Posts: 904
Joined: Fri Feb 19, 2016 9:05 pm
Location: Northeast Ohio, United States
Has thanked: 1793 times
Been thanked: 1051 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby ldriveskier » Mon Dec 05, 2016 4:55 pm

SuperDave1426 wrote:I'm probably missing something here.... :-) What exactly is the problem that the date fix script fixes, and is it really necessary for the proper/better functioning of other scripts?

Thanks for any info!


The "problem" is more of a preference. The default for the date display is very long, so this shortens it up and makes it easier to read. Here is a link to another thread that explains it: https://www.waze.com/forum/viewtopic.ph ... 6#p1540156
[ img ][ img ][ img ][ img ][ img ][ img ]
USA LC/CM, MAR ARC, GLR LC (resident of Ohio), App Beta Leader
ldriveskier
Coordinators
Coordinators
 
Posts: 904
Joined: Fri Feb 19, 2016 9:05 pm
Location: Northeast Ohio, United States
Has thanked: 1793 times
Been thanked: 1051 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby ldriveskier » Mon Feb 13, 2017 12:37 pm

GeekDriverPeaceful wrote:I read the code, didn't try yet. Looks very promising! It basically grabs the latest rendering class from WME and apply it to Validator. This will (hopefully) show highlights. Neat!


I tried it and it is WORKING for me.

Thank you, dbcm!
[ img ][ img ][ img ][ img ][ img ][ img ]
USA LC/CM, MAR ARC, GLR LC (resident of Ohio), App Beta Leader
ldriveskier
Coordinators
Coordinators
 
Posts: 904
Joined: Fri Feb 19, 2016 9:05 pm
Location: Northeast Ohio, United States
Has thanked: 1793 times
Been thanked: 1051 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby ldriveskier » Mon Feb 13, 2017 2:42 pm

Thanks to markr4468 for detailed instructions on installation of dbcm's fix:

1) Go To Tampermonkey Dashboard
2) Click Utilities Tab
3) Paste http://dbcm.github.io/waze/valfix/valfix.js in the URL Box
4) Click Import
5) Click Install
6) Click Installed Userscripts Tab
7) Click On Waze Map Editor - Validator Fix
8) Click On Settings
9) Set Position to #1
10) Hard Refresh in WME
11) Enable Any Localization Files you have.

(Note: If you disabled Validator, don't forget to re-enable it!)
Last edited by ldriveskier on Mon Feb 13, 2017 2:49 pm, edited 1 time in total.
[ img ][ img ][ img ][ img ][ img ][ img ]
USA LC/CM, MAR ARC, GLR LC (resident of Ohio), App Beta Leader
ldriveskier
Coordinators
Coordinators
 
Posts: 904
Joined: Fri Feb 19, 2016 9:05 pm
Location: Northeast Ohio, United States
Has thanked: 1793 times
Been thanked: 1051 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby ldriveskier » Mon Feb 13, 2017 3:06 pm

Glodenox wrote:So the addition of the ExtendedSVG renderer fixes the script already? I've just installed the userscript at https://dbcm.github.io/waze/valfix/valfix.js as a userscript on Firefox, but the validator still doesn't seem to work yet here (I've made it so that the fix gets executed before validator).

I'll look into it later if other people say this does seem to fix validator for them.


dbcm said "In the case you are using WME Validator through Tampermonkey", so it sounds like you need to use Tampermonkey.
[ img ][ img ][ img ][ img ][ img ][ img ]
USA LC/CM, MAR ARC, GLR LC (resident of Ohio), App Beta Leader
ldriveskier
Coordinators
Coordinators
 
Posts: 904
Joined: Fri Feb 19, 2016 9:05 pm
Location: Northeast Ohio, United States
Has thanked: 1793 times
Been thanked: 1051 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby ldriveskier » Wed Apr 19, 2017 2:55 pm

jangliss - is that a problem with Validator and its fix or with a validator Localization script? I know the Localization scripts that I use were modified after the language change, so yours might need that also.
[ img ][ img ][ img ][ img ][ img ][ img ]
USA LC/CM, MAR ARC, GLR LC (resident of Ohio), App Beta Leader
ldriveskier
Coordinators
Coordinators
 
Posts: 904
Joined: Fri Feb 19, 2016 9:05 pm
Location: Northeast Ohio, United States
Has thanked: 1793 times
Been thanked: 1051 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: Google [Bot], jangliss, jm6087, Mapman44