Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by Cardyin
russblau wrote:Using Chrome, I get double scroll-bars in the UR dialog box when using URComments, at least in some cases where there are several comments on a report. Here's screenshots of the same UR, with UR Comments active and with it disabled. Notice that the first one has two nested scrollbars, the second has only one. What's really annoying is that sometimes the UR dialog will open up scrolled down so far that it is entirely whitespace, and I have to scroll up to see anything.
If you don't want to wait for the update, you can fix this by going to line 628 in the script:

Code: Select all

g = g + '.problem-edit .body { position: absolute !important; top: 30px !important; bottom: 5px !important; overflow: auto !important; width: 280px !important;}';
and remove the "overflow: auto !important;"

Code: Select all

g = g + '.problem-edit .body { position: absolute !important; top: 30px !important; bottom: 5px !important; width: 280px !important;}';
That will prevent the outer scroll bar from appearing due to the comments "overflowing" it's container.
Cardyin
Map Editor - Level 4
Map Editor - Level 4
Posts: 59
Has thanked: 16 times
Been thanked: 71 times

Post by Cardyin
Rick,

I echo the sentiment of those above...it's really hard to live without your WONDERFUL script.

So being the impatient one that I am, I did some debugging for you.

It seems that the WME restructured the way it renders the tabs on the left side, which invalidated your jQuery selectors where you are appending your tab code to the page.

I think all you have to do is update your jQuery selectors to handle the difference:

Line 652

Code: Select all

				$("#user-tabs > ul.nav-tabs").first().append(b);
Line 659

Code: Select all

				$("#user-tabs + .tab-content").append(c);
I'm testing the change currently myself, but hopefully, you can validate this faster and release to the masses. :)
Cardyin
Map Editor - Level 4
Map Editor - Level 4
Posts: 59
Has thanked: 16 times
Been thanked: 71 times

Post by Cardyin
Same issue with refresh button. They changed the html so your jQuery doesn't find it.

Line 2204:

Code: Select all

            $(".controls-container .reload-button").trigger('click');
Cardyin
Map Editor - Level 4
Map Editor - Level 4
Posts: 59
Has thanked: 16 times
Been thanked: 71 times

Post by Cardyin
Wow Rick,

Great job. Just wanted to give a thumbs up on this. I love the new update! Please keep up the excellent work!
Cardyin
Map Editor - Level 4
Map Editor - Level 4
Posts: 59
Has thanked: 16 times
Been thanked: 71 times

Post by Cardyin
I'm getting the same behavior as well. It almost seems like it's stuck in a loop. My guess in this situation is that the UR pill data are trying to load, but is waiting for the filtering which is waiting for the UR pill data.

Turning of the setting: "Enable URComments UR filtering", instantly allows the screen to load all URs and pill boxes, re-checking this box after the screen refreshes seems to enable the filter correctly and instantaneously
Cardyin
Map Editor - Level 4
Map Editor - Level 4
Posts: 59
Has thanked: 16 times
Been thanked: 71 times

Post by cafri
I really like URComments.

Today I started using the beta WME instead of the public one, and it doesn't show the UR pill counts in there.
cafri
Posts: 1117
Has thanked: 249 times
Been thanked: 149 times
----------------------
iPhone X, iOS 13.1, latest Waze beta
----------------------
https://s.waze.tools/c5.png

Post by cafri
rickzabel wrote:
cafri wrote:I really like URComments.

Today I started using the beta WME instead of the public one, and it doesn't show the UR pill counts in there.
Just checked this morning filters/ pills are working for me on production and beta.
Any idea what I am doing wrong?

http://i65.tinypic.com/t83k79.png
cafri
Posts: 1117
Has thanked: 249 times
Been thanked: 149 times
----------------------
iPhone X, iOS 13.1, latest Waze beta
----------------------
https://s.waze.tools/c5.png

Post by cafri
Maybe it is related to the following error message, which I get only when using the beta?

http://i65.tinypic.com/20ijfig.png
cafri
Posts: 1117
Has thanked: 249 times
Been thanked: 149 times
----------------------
iPhone X, iOS 13.1, latest Waze beta
----------------------
https://s.waze.tools/c5.png

Post by cafri
You are correct - I am using the IL server.
1.5.3 solved the issue - thanks!

However, I noticed that 1.5.3 doesn't let me use the IsraeliHebrew comments file, nor my own Custom comment files.

What should we change in the comments file for them to work?
cafri
Posts: 1117
Has thanked: 249 times
Been thanked: 149 times
----------------------
iPhone X, iOS 13.1, latest Waze beta
----------------------
https://s.waze.tools/c5.png

Post by bz2012
Not sure if this script is causing it or it is something WME has done, but ctrl-c no longer is copying text from the reporters text in the UR comment window. I must right click and select 'copy' to copy something I have selected.
A bit annoying. :)
bz2012
Map Raider
Map Raider
Posts: 1600
Has thanked: 1919 times
Been thanked: 304 times
State Manager, Louisiana[ img ]