[Script] WME Validator v2020.11.1 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 0.9.4 (BETA) / 30.03.2014

Postby lg1992 » Fri Apr 04, 2014 12:16 pm

Are there plans to enable checking for invalid elevation? If not, can I enable this checking just for me? If not, what's the correct rule to define custom condition for that?
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 0.9.4 (BETA) / 30.03.2014

Postby lg1992 » Sat Apr 05, 2014 3:48 am

BellHouse wrote:Yes, I am just trying to find out if lg1992 means the same thing as we did earlier.

Anyway, the template would be ${elevation} and the regexp would be !\-[1-5]|^[0-9]$ , if you want to test if the elevation is outside of -5 and 9. And I trust you would manage to tune that to a range you are looking for.

I mean cases when elevation of a selected segment is shown empty. I see a lot of such segments in my region in Israel. I've applied a custom check as berestovskyy advised.
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 0.9.9 (BETA) / 27.04.2014

Postby lg1992 » Sat May 10, 2014 3:06 am

I use the following custom condition to mark dead-ends without U-turn:
template ${deadEnd}:${Uturn}:${direction}
RegExp 1:0:3
It usually works properly, but fails to mark segments which have U-turn on the second end. Here's an example of such segment https://www.waze.com/editor/?zoom=7&lat ... nts=240202

Can anybody suggest a condition that will also cover such segments?
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 0.9.9 (BETA) / 27.04.2014

Postby lg1992 » Sat May 17, 2014 3:38 am

Now, as landmarks have been changed with places that have categories and sub-categories, I occasionally meet a place with a general category only. It would be nice to have the Validator to mark such places.
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 1.0.0 / 26.05.2014

Postby lg1992 » Sun Jun 22, 2014 6:34 am

Lately I cannot use the Validator on the beta editor (Israeli server). If I work with a small area, the Validator properly paints problematic segments and the button "Show Report", but clicking the button doesn't open a Report page. If I work with a bigger area and click "Start Scanning", the scanning starts but never finishes, and clicking the buttons "Pause" or "Stop" doesn't bring the map back. There are no such problems with the regular editor.

Do any users experience these problems with the beta editor or NA or ROW servers?
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 1.1.3 / 07.10.2014

Postby lg1992 » Sat Oct 18, 2014 3:25 am

After scanning an area with all layers turned off the Validator doesn't restore the layer of Place updates.
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 1.1.8 / 07.05.2015

Postby lg1992 » Tue Oct 27, 2015 3:39 am

:shock: The new beta version of WME doesn't have the "Me" tab, so the Validator isn't shown at all!
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby lg1992 » Wed Mar 23, 2016 4:53 am

I lose the Validator rather often, but I haven't notice a pattern so far. Usually it's enough to reload the Chrome page to get the Validator back.
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby lg1992 » Tue Mar 29, 2016 4:23 pm

The new beta version of the editor broke the Validator (at least on Chrome). The error is:

Uncaught TypeError: Cannot read property 'length' of null
WME_Validator.user.js:129
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

Re: [Script] WME Validator 1.1.18 / 02.06.2016

Postby lg1992 » Fri Jun 03, 2016 11:49 am

The buttons "Show report" and "Send" don't work in the WME beta.
Leonid, Country Manager, Israel
lg1992
Country Manager
Country Manager
 
Posts: 4284
Joined: Fri May 04, 2012 9:50 am
Has thanked: 274 times
Been thanked: 817 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: No registered users