[Script] WME Validator v2020.11.1 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 2019.02.26 (BETA)

Postby LysdexiaEht » Wed Apr 10, 2019 12:51 am

berestovskyy wrote:If there are no errors in between those logs, it’s normal...

Which Waze server do you use? Or which country you are from?


Australian (INTL) servers, and nothing in between ... but it's a repeatable phenomenon, if it's "waiting for login" Validator never loads.
[ img ]
AM: QLD/Northern NSW
LysdexiaEht
Area Manager
Area Manager
 
Posts: 149
Joined: Fri Mar 08, 2019 4:04 am
Has thanked: 55 times
Been thanked: 31 times

Re: [Script] WME Validator 2019.04.11 (BETA)

Postby LysdexiaEht » Tue Apr 16, 2019 12:12 am

Great stuff, I can confirm it's been working well since your changes.
[ img ]
AM: QLD/Northern NSW
LysdexiaEht
Area Manager
Area Manager
 
Posts: 149
Joined: Fri Mar 08, 2019 4:04 am
Has thanked: 55 times
Been thanked: 31 times

Re: [Script] WME Validator 0.7.3 (BETA) / 24.02.2014

Postby magfro » Fri Feb 28, 2014 7:17 am

My WME Validator suddenly reports in Spanish. I live in Sweden and as most parts of Europe we don't understand Spanish. Why does WME Validator default to Spanish and not English and how do I change that? Can't find any option under WME Validator settings.

I use Google Chrome and the languages used there is Swedish, English (USA) and English (UK).

Only thing I can think of is that Sweden has top domain ".se" and Spain has ".es". Could that have anything to do with it?

Thanks,
[ img ][ img ]
Area Manager of Småland and south of Stockholm, Sweden (INTL)
iPhone 6s, iOS 10
magfro
Area Manager
Area Manager
 
Posts: 175
Joined: Sun Jul 25, 2010 7:29 am
Has thanked: 9 times
Been thanked: 7 times

Re: [Script] WME Validator 0.7.3 (BETA) / 24.02.2014

Postby magfro » Fri Feb 28, 2014 7:31 am

berestovskyy wrote:Switch WME language to English for now, the bug will be fixed in the next release.


Ok great! Thanks for the quick reply.
[ img ][ img ]
Area Manager of Småland and south of Stockholm, Sweden (INTL)
iPhone 6s, iOS 10
magfro
Area Manager
Area Manager
 
Posts: 175
Joined: Sun Jul 25, 2010 7:29 am
Has thanked: 9 times
Been thanked: 7 times

Re: [Script] WME Validator 1.0.2 / 04.07.2014

Postby manoeuvre » Mon Aug 04, 2014 12:18 am

I also have this same error. No new version is available to download.
[ img ][ img ][ img ][ img ][ img ][ img ]
Canadian Country Coordinator | Greater Toronto Area Manager | @Waze_Canada
manoeuvre
Global Champ Mentor
Global Champ Mentor
 
Posts: 5520
Joined: Thu Mar 20, 2014 3:05 am
Location: Canada
Has thanked: 1150 times
Been thanked: 2436 times

Re: [Script] WME Validator 1.0.2 / 04.07.2014

Postby manoeuvre » Mon Aug 04, 2014 1:04 am

Thanks for the work-around!
[ img ][ img ][ img ][ img ][ img ][ img ]
Canadian Country Coordinator | Greater Toronto Area Manager | @Waze_Canada
manoeuvre
Global Champ Mentor
Global Champ Mentor
 
Posts: 5520
Joined: Thu Mar 20, 2014 3:05 am
Location: Canada
Has thanked: 1150 times
Been thanked: 2436 times

Re: [Script] WME Validator 1.0.2 / 04.07.2014

Postby manoeuvre » Mon Aug 04, 2014 2:34 am

[ img ][ img ][ img ][ img ][ img ][ img ]
Canadian Country Coordinator | Greater Toronto Area Manager | @Waze_Canada
manoeuvre
Global Champ Mentor
Global Champ Mentor
 
Posts: 5520
Joined: Thu Mar 20, 2014 3:05 am
Location: Canada
Has thanked: 1150 times
Been thanked: 2436 times

Re: [Script] WME Validator 1.1.1 / 30.08.2014

Postby manoeuvre » Wed Sep 03, 2014 4:12 am

Unable to get my custom localization script to work.

I'm trying to fix street name abbreviations with the first one. The second one is to fix roads with the name St, which should be St. (Saint).

Any ideas what i'm doing wrong? Not able to get anything to highlight.

Code: Select all
// ==UserScript==
// @name                WME Validator Localization for Canada
// @version             1.1.1
// @description         This script localizes WME Validator for Canada. You also need main package (WME Validator) installed.
// @match               https://editor-beta.waze.com/*editor/*
// @match               https://www.waze.com/*editor/*
// @grant               none
// @run-at              document-start
// ==/UserScript==
//
/*
  See Settings->About->Available checks for complete list of checks and their params.

  Examples:

  Enable #170 "Lowercase street name" but allow lowercase "exit" and "to":
    "170.enabled": true,
    "170.params": {
        "regexp": "/^((exit|to) )?[a-z]/",
    "},

  Enable #130 "Custom check" to find a dot in street names, but allow dots at Ramps:
    "130.enabled": true,
    "130.params": {
        "titleEN": "Street name with a dot",
        "problemEN": "There is a dot in the street name (excluding Ramps)",
        "solutionEN": "Expand the abbreviation or remove the dot",
        "template": "${type}:${street}",
        "regexp": "D/^[^4][0-9]?:.*\\./",
    },
    *Note: use D at the beginning of RegExp to enable debugging on JS console.
    *Note: do not forget to escape backslashes in strings, i.e. use "\\" instead of "\".
*/

window.WME_Validator_Canada = {
  ".country": "Canada",
  ".codeISO": "CA",
  ".author": "manoeuvre",
  ".updated": "2014-09-03",
  ".link": " : "

},
     
"171.enabled": true,
"171.severity": "warning",
"171.params": {
    "titleEN": "Wrong Abbreviation",
    "problemEN": "Street name has the wrong abbreviation",
    "solutionEN": "Use the correct abbreviation",
    "template": "${type}:${street}",
    "regexp": "/ (Aly|Avenue|Bnd|Boulevard|By-pass|Centre|Center|Circle|Cl|Court|Cr|Ct|Crescent|Cul-de-sac|Drive|Extension|Fld|Gardens|Gln|Grn|Grounds|Grv|Harbour|Harbr|Heights|Highway|Hl|Holw|Landing|Landng|Ln|Mnr|Mdw|Mountain|Orchard|Park|Parkway|Passage|Pass|Ptwy|Place|Pt|Prt|Pvt|Promenade|Rg|Rdge|Road|Square|Subdiv|Street|Terrace|Ter|Trl|Tr|Thick|Tline|Turnabt|Village|Villge|North|East|South|West)$/i",
},

"174.enabled": true,
"174.severity": "warning",
"174.params": {
    "titleEN": "St. not St",
    "problemEN": "St. not St",
    "solutionEN": "Use St. instead of St",
    "template": "${type}:${street}",
    "regexp": "^St.[A-Z].[a-z].*/",
},
[ img ][ img ][ img ][ img ][ img ][ img ]
Canadian Country Coordinator | Greater Toronto Area Manager | @Waze_Canada
manoeuvre
Global Champ Mentor
Global Champ Mentor
 
Posts: 5520
Joined: Thu Mar 20, 2014 3:05 am
Location: Canada
Has thanked: 1150 times
Been thanked: 2436 times

Re: [Script] WME Validator 1.1.2 / 01.10.2014

Postby manoeuvre » Wed Oct 01, 2014 2:37 am

[ img ]

edit: nvm, I just upgraded... working now :oops:
Last edited by manoeuvre on Wed Oct 01, 2014 2:40 am, edited 1 time in total.
[ img ][ img ][ img ][ img ][ img ][ img ]
Canadian Country Coordinator | Greater Toronto Area Manager | @Waze_Canada
manoeuvre
Global Champ Mentor
Global Champ Mentor
 
Posts: 5520
Joined: Thu Mar 20, 2014 3:05 am
Location: Canada
Has thanked: 1150 times
Been thanked: 2436 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby mapraider » Sat Apr 01, 2017 3:47 pm

I set the zoom at 500 ft, then Validator highlights any problem.
Country Manager, Norway.
mapraider
 
Posts: 44
Joined: Tue Jul 28, 2015 12:06 pm
Location: Sogn og Fjordane
Has thanked: 7 times
Been thanked: 8 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: airchair, jm6087, n4dog