Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by Kayos_On_The_Road
Ocaisonally I see URs for missing traffic lights. The last one I used this language in response:

"Volunteer responding, Waze does not currently contain information regarding traffic lights, only red light cameras. The routing engine will take into account the time it takes to cross an intersection and the average wait time for the traffic lights are included in this. Thanks!"

Could this be considered as an addition?
Kayos_On_The_Road
Waze Global Champs
Waze Global Champs
Posts: 5449
Has thanked: 386 times
Been thanked: 2070 times
Samsung Galaxy S7 (7.0 stock), waze version always latest beta.
GC, CM - Vancouver, BC
Waze Beta Leader (Android)
Canada Wazeopedia
https://s.waze.tools/c6.pnghttps://wiki.waze.com/wiki/images/c/c1/ ... Tester.png

Post by Kayos_On_The_Road
Hi Rick,

For the custom responses, I've not had time to play with it, but is the idea that the user edits the script directly to give the responses you want?

Kayos
Kayos_On_The_Road
Waze Global Champs
Waze Global Champs
Posts: 5449
Has thanked: 386 times
Been thanked: 2070 times
Samsung Galaxy S7 (7.0 stock), waze version always latest beta.
GC, CM - Vancouver, BC
Waze Beta Leader (Android)
Canada Wazeopedia
https://s.waze.tools/c6.pnghttps://wiki.waze.com/wiki/images/c/c1/ ... Tester.png

Post by kahlcolimon
Apparently this script broke with the new WME update (v1.37-42) ... or not?
kahlcolimon
Coordinators
Coordinators
Posts: 2759
Has thanked: 568 times
Been thanked: 1850 times
Kahl Colimon
Waze Colombia Coordinator/MTE Marshall
Waze Local Champ Mentor/Country Manager
App Beta Leader/WME Beta Tester
First Responder Member

https://i.ibb.co/h9vDrY6/Beta-Logo-100px.pnghttps://storage.googleapis.com/wazeoped ... _Champ.png

Post by kahlcolimon
tcalvert317 wrote:Hello All,

I have noticed that when using URC not all URs are showing up. Has anyone else experienced this?

Thanks,

Ted
After the difficulties presented with the WME update I haven't had any problems with this extension. Have you installed any other extensions lately?
kahlcolimon
Coordinators
Coordinators
Posts: 2759
Has thanked: 568 times
Been thanked: 1850 times
Kahl Colimon
Waze Colombia Coordinator/MTE Marshall
Waze Local Champ Mentor/Country Manager
App Beta Leader/WME Beta Tester
First Responder Member

https://i.ibb.co/h9vDrY6/Beta-Logo-100px.pnghttps://storage.googleapis.com/wazeoped ... _Champ.png

Post by juliansean
rickzabel wrote:
juliansean wrote:I believe this is the correct script...with the new change to WME Prod, when you use a standard comment and send, it no longer closes the UR. Not a big deal, just something that has changed.
they renamed the close button, i believe i have it working and will post an update in a bit
Thank you!


Sent from my iPhone using Tapatalk
juliansean
Country Manager
Country Manager
Posts: 1270
Has thanked: 346 times
Been thanked: 345 times
Sean Julian
CM
SM: TX, LA, MS, AR, OK
AM: SE FL, Boston, MA, Brooklyn, NY, Bronx, NY, Manhattan, NY, Queens, NY, E CA, SW KS


Post by JustinS83
If you change all instances of

Code: Select all

selectedItems
to

Code: Select all

getSelectedFeatures()
it might start working again.
JustinS83
Waze Global Champs
Waze Global Champs
Posts: 1418
Has thanked: 211 times
Been thanked: 2334 times

Post by JustinS83
madcatvt wrote:I tried searching for this issue but I didn't see anything that might be related to my issue. When I have UR Comments running, URs that I have no comments in view fine. The second I comment on a UR is disappears. When I first go to a location the UR will flash and show for a second, then it disappears. If I disable UR Comments I can see all URs no problem.
Anyone else have this issue? Conflicting script maybe? This has been happening to me through several versions of the script.
Thanks,
madcatvt
Check the filtering settings for the script
JustinS83
Waze Global Champs
Waze Global Champs
Posts: 1418
Has thanked: 211 times
Been thanked: 2334 times

Post by juliansean
I have this happen often. A reboot of wme solves the issue. I haven't tried to troubleshoot since it's easy to just close WME and open it again.

Sean
juliansean
Country Manager
Country Manager
Posts: 1270
Has thanked: 346 times
Been thanked: 345 times
Sean Julian
CM
SM: TX, LA, MS, AR, OK
AM: SE FL, Boston, MA, Brooklyn, NY, Bronx, NY, Manhattan, NY, Queens, NY, E CA, SW KS


Post by juliansean
URC is working fine for me. Version 1.9.0 on Chrome Version 69.0.3497.92

Sean
juliansean
Country Manager
Country Manager
Posts: 1270
Has thanked: 346 times
Been thanked: 345 times
Sean Julian
CM
SM: TX, LA, MS, AR, OK
AM: SE FL, Boston, MA, Brooklyn, NY, Bronx, NY, Manhattan, NY, Queens, NY, E CA, SW KS


Post by JustinS83
Rick no longer has the time to maintain URC.

Please install URComments-Enhanced as a replacement.
JustinS83
Waze Global Champs
Waze Global Champs
Posts: 1418
Has thanked: 211 times
Been thanked: 2334 times