Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by rickzabel
hmarian wrote:Apology for the confusion. I will move the discussion back to the Beta area and sorry for the intrusion to your Script discussion.
I will give it a spin.

Cheers,
HM.
Thinking about this more, since the UR window is the same on the production editor as the beta i don't know if the beta forum is the right place either.

The information you are looking for is still being saved. i noticed that i can use URO+ to hide URs that are either solved or not identified.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
HuckD wrote:When Chrome loads the editor it displays the following error message from URComments:

http://i665.photobucket.com/albums/vv11/HuckD/WAZE%20Images/ErrorURComments_zpsaeb74616.png

What should I do with this?

HuckD
update to the the latest version and this should not happen on startup. you were only getting that message when UrComments beat URO loading.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
bart99gt wrote:One other suggestion, at the end of the "Errors With No Text", let's include a small sentence reminding reporters to reply via the app. I'd hate to think how many replies we've had lost to the void because someone starts typing out a reply to us as an E-MAIL reply, hits send, gets the delivery failure notification, then just gives up on the UR process entirely.

I know something like this has to be going on because I see some of the same URs pop up over and over, they're trying to reach out for a solution, but just can't figure out how to get back to us.
we tried that with the 4 day reminder instructions, we immediately started getting complaints from drivers that they do not get the messages on their app. We also tried instructing them to click the link waze gives them in the email, last time i checked that link went to the map with the UR layer turned off and did not open the ur directly. refer to this for an example https://wiki.waze.com/wiki/User:Rickzab ... structions

last night i came up with a way to generate URLs that go directly to the UR with the window open. but have not had a chance to discuss with the team the idea of sending our own links with the initial comment much in the same way the 4 day reminder works. i also want to update the link i use for the reminder to open the UR and the text that goes along with it.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
russblau wrote:Is this thread the correct place to post suggestions about the wording of the default comments?
it could be, but we have a google hang out we have been using to discuss the script...

we have 2 files going in google docs,

one is a master list of comments where we have been adding and removing comments along with editing and voting on the wording.

the other is a file full of grammatical changes. "Volunteer responding, text" is probably going to become "Volunteer responding - text". other comments that are run on sentences are going to be fixed. some wording that is not 100% will be kept in favor of having shorter comments.

i have yet to have time to go over the grammar changes and copy them back into the master list and then onto the script.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
AlanOfTheBerg wrote:I'd really like the option to not disable the Done button in WME. I rather like it, and find the controlling of this a little too much.
that is a possibility; but during the LA raid i got reports one after another about people thinking they were sending 200+ messages but were instead clicking done. the script made it was to easy to mess up one after another and i had to make a snap decision. i figured doing it this was would get people used to the new procedure. i will add making it an option to the request list.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
AlanOfTheBerg wrote:I understand. However, I believe that tools should enhance the editing experience without restricting the ability of using the normal, expected Editor functions.
i also agree and making this an option is on the to do list.

the function of the "done" button is the same as clicking the x at the top of the ur, which was the same workflow before the new Ur window. so i didn't think i was restricting the use of the editor.

if you are so inclined you can delete or comment out lines 1209 trough 1213. if you do please make sure you once and a while check that you are on the current version as changing the script sometimes stops auto updates.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
AlanOfTheBerg wrote:I have the custom list installed and enabled in Tampermonkey, but Urcomments says it can't find a custom list. What do I need to do?
Thanks PesachZ exactly what i was going to recommend!

AlanOfTheBerg i had to make some changes to the custom file in order to support multi languages, at that time i moved some config into the comments files. if you are still having issues let me know what the error message says, as it should say what is missing. if the message doesn't say what is wrong and that it is missing altogether you most likely have a syntax error; missing or extra " or , is usually the cause.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
shawndoc wrote:Running 0.9.3, and have come across a strange behavior with whether the 4-Day Reminder includes a URL link or not.

Going into settings, only first 3 boxes are checked. Clicking (4 day Follow Up) does not include the URL. After setting the first 4 boxes to checked, clicking 4DFU now includes the URL.

I asked Jesse to see if he saw the same behavior on his computer, and 4DFU continued to include the URL with the first 3 boxes checked. It wasn't until he removed the 3rd button that it stopped including it.
i can not recreate this, i tried in firefox and chrome. is anyone else having this issue?
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
Raiden38 wrote:Ah yes, you are right. By changing General Error, it worked. Thanks!!! :)
Please do not edit the main script, install the custom comments script then edit the comments there. the comments with numbers after them are the ones used for auto insert, such as
"Incorrect turn", //6
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel

Post by rickzabel
bz2012 wrote:I can't get the 'double click' to work properly.
I always get an error message about needing to save first because the first click changes the save status and that cues up a save operation.
So I have to click on the message and then hit the send button. THAT accomplishes the desired action but takes moving the mouse before making the second click.

also, a minor point: many of those (Double Click) notes added on cause the line to wrap and means more frequent scrolling to find the desired message. How about just adding a '*' instead, at the end of each line, then a foot note at the bottom *(Double Click). :)

By the Waze, LOVE THIS EXTENSION! Thank YOU so much for it!
your welcome and i wish i still was on vacation so i could work on it some more.

as for your double click issue, the titles are still single click and based of your description it sounds like you are double clicking the title of the comment and not the words (double click).

as for the line wrap the only one that wraps on me is "No user transponder (avoid tolls) (Double Click)" i have tried to keep the titles very short so they do not wrap. but if you are using wme maximize they will wrap.
rickzabel
Map Editor - level 3
Map Editor - level 3
Posts: 222
Been thanked: 277 times
https://www.waze.com/wiki/images/5/5a/W ... M_only.png
Chicago Illinois Suburbs , Main areas Downers Grove, Naperville, and Auroa
https://wiki.waze.com/wiki/User:Rickzabel