[Script] WME Validator v2020.11.1 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 0.9.2 (BETA) / 22.03.2014

Postby rgatland » Sun Mar 23, 2014 11:37 pm

I have had this problem too. I make an edit, and after the save, the elevation is nulled out. I have noticed it enough that I have been checking the elevation before saves, and they are set properly, but then they null out.
rgatland
 
Posts: 83
Joined: Wed Jan 01, 2014 2:01 pm
Location: Piedmont Triad NC
Has thanked: 29 times
Been thanked: 10 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby RichardPyne » Sat Jan 07, 2017 12:12 am

mrbig2015 wrote:I like validator. it never works anymore and I'M a L-2 and without it makes it hard for I do not get this YE Noot go back to the last time it was working so we can have sumthing over nothing or take it off altogether most of you never think of this I mad web pages be for and this is how you do it if you can't fix it go back to the time it was good never leave trash save a good copy


The problem is not that changes were made to validator, so rolling back to an earlier version will not help. The problem is that WME has changed and the developer of validator is no longer active. Because of the way validator was built and licensed, it is impossible for someone else to fix it.
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby RichardPyne » Wed Mar 15, 2017 1:32 am

It looks like Waze broke the Validator again. It will no longer produce a report.
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby RichardPyne » Thu Mar 16, 2017 8:27 pm

The report feature is still not working correctly. While it does report some issues, it is far from reporting them all. The most I've been able to get it to report since the last fix was 19 items in an area that I know had over 100 segments with an unknown direction.

I just scanned another area, and just doing a rough count watching while is scanned, saw about 60 unconfirmed nodes as shown by toolbox. The report didn't show anything.

Thanks.
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby RichardPyne » Thu Mar 16, 2017 9:21 pm

JustinS83 wrote:Guys - we do not have the code for validator in order to truly fix it, we are trying to apply patches to get it working. We very well might not be able to get it working correctly. We are doing our best to keep putting on bandaids but at some point you need surgery...which we cannot do.


Understood. I greatly appreciate the work you are doing.
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby RichardPyne » Mon Apr 03, 2017 10:59 pm

JoshJMM wrote:that's no problem if you are looking at a small town, but I'm talking Denver, Atlanta, LA. If you want to pan around at 500ft you are going to be panning for a week.


The same applies when working large un or sparsely populated areas such as the farmlands, mountains, and deserts of Idaho and Utah.

While I do appreciate all the work that has been done to keep Validator working as much as it is, I would have unending gratitude if the scan report could work again.
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby RichardPyne » Fri Apr 07, 2017 1:26 pm

Mapman44 wrote:If you are using Google Chrome it may be a memory problem.


While I am using Chrome, it was working fine up until the last big WME breakage. Also, I recently update memory from 8GB to 24 GB.
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby RichardPyne » Sat Jun 02, 2018 4:21 pm

I will add my encouragement to revive WME Validator. For everything Magic is, it still doesn't provide the functionality I found most useful in Validator.
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

Re: [Script] WME Validator 2019.09.24 (PLACES BETA)

Postby RichardPyne » Wed Jan 29, 2020 7:15 pm

Any progress or hope for Validator working again?
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

Re: [Script] WME Validator 2019.09.24 (PLACES BETA)

Postby RichardPyne » Mon Mar 09, 2020 3:56 pm

Using version 2019.09.24 when trying to scan, it appears that the scan starts, then just stalls.
RichardPyne
Area Manager
Area Manager
 
Posts: 292
Joined: Sat Mar 12, 2016 6:05 pm
Location: Lynndyl, Utah, USA
Has thanked: 347 times
Been thanked: 126 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: Mapman44