[Script] WME MagicWand

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME MagicWand

Postby JustinS83 » Tue Mar 06, 2018 2:28 am

wasd42 wrote:Hey everyone!

I've posted a new update, containing an interesting feature: Right angles helper. Just hold SHIFT while editing a feature to display a helper circle that will help you to draw right angles.

Please, feel free to send me your feedback and feature requests :)


What is this supposed to look like? I just get a giant orange-yellow circle and the editor slows to a crawl

Image
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1350
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 341 times
Been thanked: 2397 times

Re: [Script] WME MagicWand

Postby JustinS83 » Mon May 07, 2018 6:45 pm

wasd - you have a pending pull request which should fix the parts necessary to get the script working since the WME updates.
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1350
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 341 times
Been thanked: 2397 times

Re: [Script] WME MagicWand

Postby karlcr9911 » Thu Jan 03, 2019 5:16 pm

Using MagicWand prevents the Save button from activating when I delete a place or map comment. Turning off this script and then performing that action works as expected.
karlcr9911
Global Champ Mentor
Global Champ Mentor
 
Posts: 2409
Joined: Fri Aug 23, 2013 2:05 am
Location: North East Texas, USA
Has thanked: 589 times
Been thanked: 1544 times

Re: [Script] WME MagicWand

Postby kentsmith9 » Tue Sep 27, 2016 6:01 pm

aureozb wrote:Hello,

i have a big problem here, the first thing that appears wen i open the wme: unable fo find appropriate control element, script is broken

what should i do ?

How funny. I just did a search for this error and didn't see anything. I then restarted my computer and still saw the error. I narrowed the error down to this script and then here is another report of the problem. :lol:

I just disabled it for now and the error goes away while it is being investigated.
kentsmith9
Waze Global Champs
Waze Global Champs
 
Posts: 5684
Joined: Mon Apr 23, 2012 3:33 pm
Location: Boise ID and SF/SJ Bay Area of Northern California
Has thanked: 1577 times
Been thanked: 1793 times

Re: [Script] WME MagicWand

Postby krizecek » Thu May 17, 2018 10:34 am

Someone will correct this script? we use it a lotThank you
krizecek
Area Manager
Area Manager
 
Posts: 95
Joined: Thu Nov 27, 2014 9:04 pm
Has thanked: 83 times
Been thanked: 38 times

Re: [Script] WME MagicWand

Postby leflysurfeur » Mon Apr 04, 2016 7:47 pm

Hello,

Comme RIFF_RAFF, impossible pour moi de créer des landmarks en cliquant sur les vues satellites Google. Une solution? Merci.
leflysurfeur
 
Posts: 650
Joined: Tue Jun 03, 2014 1:04 pm
Location: Pornichet
Has thanked: 177 times
Been thanked: 45 times

Re: [Script] WME MagicWand

Postby leflysurfeur » Mon Jun 13, 2016 1:59 pm

Iridium1 wrote:Thanks fo the Update!

I am having an issue: Whenever I try to create a landmark by clicking on the map I get an error:
Cannot create landmark, need at least 3 points to create polygon

What do I do wrong?
FYI: Chrome 51.0.2704.84 (latest) is used.

Appreciate your help.


I have the same problem... What is the solution please?
leflysurfeur
 
Posts: 650
Joined: Tue Jun 03, 2014 1:04 pm
Location: Pornichet
Has thanked: 177 times
Been thanked: 45 times

Re: [Script] WME MagicWand

Postby leflysurfeur » Mon Jun 20, 2016 8:19 am

????
leflysurfeur
 
Posts: 650
Joined: Tue Jun 03, 2014 1:04 pm
Location: Pornichet
Has thanked: 177 times
Been thanked: 45 times

Re: [Script] WME MagicWand

Postby lg1992 » Wed Jan 10, 2018 4:54 am

I've noticed a small problem caused with the MagicWand. If I enter HN mode, then exit it and select some place, Delete button on the upper toolbar is disabled. If then I select another place, the button is already enabled.

Checked in Chrome on Win 10. All other add-ons were disabled. The problem doesn't happen if the MagicWand is disabled.
lg1992
Country Manager
Country Manager
 
Posts: 3978
Joined: Fri May 04, 2012 9:50 am
Has thanked: 233 times
Been thanked: 758 times

Re: [Script] WME MagicWand

Postby lg1992 » Fri Jan 19, 2018 4:22 am

lg1992 wrote:I've noticed a small problem caused with the MagicWand. If I enter HN mode, then exit it and select some place, Delete button on the upper toolbar is disabled. If then I select another place, the button is already enabled.

Checked in Chrome on Win 10. All other add-ons were disabled. The problem doesn't happen if the MagicWand is disabled.

Was this report noticed? Am I the only one with the problem?
lg1992
Country Manager
Country Manager
 
Posts: 3978
Joined: Fri May 04, 2012 9:50 am
Has thanked: 233 times
Been thanked: 758 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: ehepner1977, jm6087, Mythdraug