Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by Twister-UK
3.10 includes the ability to filter URs based on whether or not they have any descriptive text included by the reporter, as requested by yaacobyy. It also now provides an appropriate update link based on the browser being used (i.e. Chrome users now get pointed to the Chrome Web Store, everyone else gets pointed to Greasyfork, and no-one gets pointed to userscripts.org...)

Firefox+Greasemonkey version: https://greasyfork.org/scripts/1952-uroverview-plus-uro
Chrome Web Store version: https://chrome.google.com/webstore/deta ... mjcdghdphi
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
yaacobyy wrote:It would be great if there was a filter that filters out URs with text, or those without text (inserted by the originator).
Also it would be nice to have a filter for those URs not posted by me (I would see only my URs).
For your first request, see V3.10 :D Unfortunately, since Waze doesn't provide any user identification data with URs, there's no way to provide an automatic way to fulfil your second request. The way I and some other editors get around this is to ensure that any URs we post ourselves include our usernames in the description text (via the use of keyboard shortcuts on our phones where available), allowing us to filter them by keyword. It's not an ideal solution, but it's the only one we've got...
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
3.11.1 now stores the server (row, usa or il) associated with each camera added to the CWL - this allows URO+ to ignore cameras which aren't on the current server, instead of erroneously marking them as deleted. This also significantly reduces the time taken to start an editing session on a server if the CWL contains lots of cameras associated with a different server.

Also for CWL afficionados, the generic alert message which appeared whenever a watched camera was tagged as having been changed or deleted has now been replaced with something ever so slightly more informative...

Finally, nestling just below the "Undo last hide/Undo all hides" buttons on the URO+ sidebar, you'll now find the names of the area managers (if any) looking after the location under the current mouse pointer position.


Firefox+Greasemonkey version: https://greasyfork.org/scripts/1952-uroverview-plus-uro
Chrome Web Store version: https://chrome.google.com/webstore/deta ... mjcdghdphi
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
Well that was odd... the package I uploaded to the CWS contained the 3.11.1 code in the main user.js file, yet the filename was still set to 3.11. Meanwhile both manifest.json and bootstrap.user.js were referencing the main file with the expected 3.11.1 filename, which is something I normally only change once I've changed the filename of the main file. So I'm really not sure how the main filename ended up being wrong in the uploaded package.

Anyway, I've uploaded another package which should now work as planned - note that to get around the "you can't upload a new package with the same version number, you muppet" problem (nice of the CWS to sanity check the version number for you, be even nicer if it'd also check that the files referenced in your manifest are present in the package...) it'll show up as 3.11.1.1 in CWS, but the script itself still calls itself 3.11.1 as that hasn't changed. The .crx packed version checks out OK in Canary, so it looks like all the filename references tie up correctly this time.

Fingers crossed :oops:
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
SuperDave1426 wrote:Ok, I'd like to modify my recommendation regarding the "disclaimer" to be that you should indicate that it only really works if you've got the AM layer turned on in the map editor display. :-)
It should work either way - if the AM layer is already turned on then it uses the AM area data already loaded by WME itself, otherwise it requests that data itself as you pan/zoom the map view. One niggly bit of behaviour I've noticed (and will try to address in a future release) is that this self-request mechanism doesn't work when you first open up a location via the search box, it's only once you then nudge the map view even by a single pixel that it's able to pull in the data itself.
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
jasonroseweir wrote:Guess I'll just need to find another challenge to tackle, perhaps the auto commenting / smart canned responses for UR conversations (unless of course you already have plans in this area too ;) )...
I may have been giving that some thought, yes...
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
ply8808 wrote:An issue with false turn restrictions on multiple nodes running either top/horizontal and east/verticle or bottom/horizontal and west/vertical, nodes show blue dot when highlighted.
Ran an isolation check through all scripts and it is the URO+ on chrome.
Any chance of posting a screengrab to illustrate this problem, because I'm struggling to picture it from your description here :?
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
ply8808 wrote:Forgive my attempt on a screen shot, but here it is.
I was unable to recreate the horizontal/vertical lines but they are the same as these only they come in the NE or SW corner of screen. I can keep trying to find that situation if it will help.
Thanks for these, but unfortunately I'm still not seeing what the problem is - everything looks normal in both those screengrabs. Please can you do a step by step description of what you're doing when you see the problem, and what you believe you should be seeing instead?
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
SuperDave1426 wrote:Maybe that's the way that it's supposed to work, but that hasn't been the case for me so far. I move, then move the mouse, and nothing. It wasn't until I turned on the AM layer that it started showing information. And when I turned the layer back off, it stopped updating the information. Whatever was there at the time remains there. When I move off and on areas where the information had been changing with the AM layer turned on, nothing was happening with it turned off.
Let me get this clear, are you saying that if you turn off the AM layer and leave the map view exactly as it was - no panning or zooming - the AM list then stops changing when you move the mouse pointer across the same part of the screen where, when the AM layer was still shown, the list was changing? Or does it still change the list OK until you then pan/zoom the map with the AM layer turned off, at which point it then stops updating until you turn the layer back on?

Which browser, WME version (public/beta), and language and server location settings (as shown in the top-right corner of WME) are you using?
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png

Post by Twister-UK
ply8808 wrote:Lots of useful stuff...
Ah, gotcha! Thanks, I'll see if I can recreate this at home. One final Q, is this on the production or beta version of WME?
Twister-UK
Waze Local Champs
Waze Local Champs
Posts: 3894
Has thanked: 546 times
Been thanked: 3237 times
Chris (not to be confused with Chris or Chris...)
AM SE England & Shetland Islands, UK Local Champ, WME Beta Tester & ScriptMangler
WME/Livemap enhancement scripts @ GreasyFork


https://chizzum.com/greasemonkey/images/beta.pnghttps://chizzum.com/greasemonkey/images/s0300.pnghttps://chizzum.com/greasemonkey/images/c5s.png