[Script] WME Validator 2020.04.12 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 1.1.8 / 07.05.2015

Postby SpencerFG » Thu Nov 05, 2015 2:05 pm

SpencerFG wrote:
voludu2 wrote:
taco909 wrote:Validator does seem to be functioning inasmuch as it is highlighting the segments.
I'm seeing thick, bright red roads, and I'm seeing yellow highlights on segment pairs that share the same endpoints.

Toolbox "same connection segments". And the red-road highlight is either toolbox or color highlighter. I can never remember which.

I'll look again. I couldn't find the control panel but I was looking at a clean part of the map so it wouldn't find anything to highlight. I'll check on it again . . .


No, it's not highlighting for me. I drew a stray road in the woods and Validator didn't point it out.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby SpencerFG » Wed Mar 30, 2016 8:48 pm

james890526 wrote:
shmupi wrote:Confirmed...it's broken :cry:

Ya it's not loading in Chrome. Weird much :( :(


It's working for me.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby SpencerFG » Fri Apr 22, 2016 6:49 pm

I haven't had a problem with this script, but in the past uninstalling the script and re-installing it solved the problem.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby SpencerFG » Sat May 28, 2016 6:10 pm

It not working for me on Chrome nor on Firefox.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.19 / 04.06.2016

Postby SpencerFG » Mon Sep 12, 2016 12:59 pm

I found the whole map "lit up." I first turned Validator off, then tried checking the box. That worked but I'm still getting the "too many errors" message.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby SpencerFG » Tue Nov 08, 2016 4:57 pm

kahlcolimon wrote:I'm detecting some problems when saving. Do you think this is due to the script or general conditions of the WME?


I've been experiencing this for some time, even when the script was disabled so I don't think Validator is the cause. Sometimes refreshing works. Sometimes I open the PL in another browser and that works. All in all it's pretty mysterious.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby SpencerFG » Wed Nov 09, 2016 1:12 pm

Everything looked wacky until I turned of _all_ the plugins. Maybe I can find one or two that still work.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby SpencerFG » Wed Nov 09, 2016 6:13 pm

Waze doesn't pay me enough for this aggravation.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby SpencerFG » Thu Mar 02, 2017 1:33 pm

sketch wrote:Plenty of scripts highlight without building a log that you can read. Validator is the only one that continues to hold the identities of those segments long after they're off screen, until cleared manually.

Understandable given its design to scan larger sections of the map, but many don't use it that way, so it's an unnecessary extra step.


Just for the record, I, and I assume others use the log. It's particularly useful in large areas of base map to highlight and quickly find problems. I didn't know it kept a log when just being run passively, though.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

Re: [Script] WME Validator 1.1.20 / 03.11.2016

Postby SpencerFG » Wed Mar 15, 2017 5:27 pm

So it now starts for me but after about fifteen minutes I gave up on it (it's been saying "Finishing in a minute most of that time). So I tried the stop button and it doesn't respond.
SpencerFG
 
Posts: 182
Joined: Thu Mar 12, 2015 10:05 pm
Location: Virginia, Southern California USA
Has thanked: 54 times
Been thanked: 28 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: jm6087, turnertr