[Script] WME Validator 2019.09.24 (PLACES BETA)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Validator 1.1.8 / 07.05.2015

Postby taco909 » Thu Nov 05, 2015 3:10 am

KB_Steveo wrote:
taco909 wrote:Validator does seem to be functioning inasmuch as it is highlighting the segments.
I'm seeing thick, bright red roads, and I'm seeing yellow highlights on segment pairs that share the same endpoints.

What browser are you using? There are no highlights happening in Chrome.

That was on Chrome.
I'm home and on FF now, I'll check again.

Yep... seeing the same thing here. Red and yellow, nothing for unconfirmed turns, nothing for short segments, overlaps, or disconnection.

validatortest.jpg
validatortest.jpg (56.62 KiB) Viewed 632 times



Edit... Never mind. The yellow highlight is from Toolbox.
The red is likely WME... they had it more toned down on the new roads layer on the last revision.
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.10 / 05.11.2015

Postby taco909 » Thu Nov 05, 2015 11:41 pm

Rfrsw101 wrote:I'm just wondering, is there any way for Validator to be incorporated into a tab? Instead of having it up all the time. Such as [Validator] [Drives] [Area] [Settings]... But thanks for getting it working so quickly after WME changed.

Ditto.
Validator goes away when you use the URO+ option to eliminate the editor sidebar info.
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.10 / 05.11.2015

Postby taco909 » Sat Nov 07, 2015 2:17 am

Fredo-p wrote:Just how often do you guys use the tabs? I rarely click on them. When I do need them, and the sidebar is causing it to expanding, making a scroll bar, I just scroll down. It doesn't seem like that big of a deal. Even on a small screen (which has been my primary screen for years).


[UPDATE]

As for the Me tab. Yes, I was wrong. You had to be on the me tab to be able to see it. However, that was how I liked it. I liked having validator "always on".

For Validator?

I run reports all the time, and the Validator menu needs to be visible for that.
As a tab, it's just a matter of clicking back and forth between "Me/Validator" and whatever tab is being used.
Now, it's "go to the TB/URO+ tab, enable the annoying cartoon box, work with Validator, go back to the TB/URO+ tab, disable the annoying cartoon.....

It's an extra step and a bunch of scrolling.

Maybe wouldn't be so bad on a 32" monitor with a 4k display.
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.10 / 05.11.2015

Postby taco909 » Sat Nov 07, 2015 7:27 am

Fredo-p wrote:I have a 20" AOC. That's probably why I'm not having that much of an issue. If my laptop was working, my 15" would have me saying otherwise.

I'm running a Flatron 23" @ 1920x1080

My notebook is horrible.
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.11 / 11.11.2015

Postby taco909 » Mon Nov 16, 2015 8:46 pm

KuniaKid wrote:Hawaiian city and street names use diacritical marks that are flagged in Validator, specifically the apostrophe. We get UR's that request that we match the signage. I haven't found any guidelines in this matter, so I add the mark. Is there a way to switch off the check for this in Validator?

Hawaii State Managers are in discussion as to using complete diacritical marks for all names. There is quite a movement here for making all things PC.

A localizer script can be written to augment Validator.
I'm not sure that it can disable the flags in the primary code, but it can add new flags based on local preferences including lock levels, street name conventions, etc...
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.14 / 17.11.2015

Postby taco909 » Wed Nov 18, 2015 8:37 pm

Robert04101 wrote:Feature request: please add "Dead-end one-way segment" in reports. Such roads clearly can't exist in practice, but between base map errors and newbie editors creating one-way roads, I see a lot of these problem segments.

There certainly are places where these could be valid, specifically one-way stubs intended to force "stay" instructions where BC logic produces unclear or confusing results, but these should be locked 4+ anyways, and it never hurts to give them another look.

This WAS a feature of Validator until the WME changes of late 2014.
It was actually a flag for "No inbound/outbound connectivity of driveable segment" so not only did it flag dead end one-way segments, it also flagged segments with turn restriction issues.
We lost that at the same time we lost notification on RevCons and other junction-related problems.

Toolbox and Highlighter still do a good job of flagging things like RevCons, but Validator no longer includes them in the report screen. I miss that function.
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.14 / 17.11.2015

Postby taco909 » Wed Nov 18, 2015 9:15 pm

SuperDave1426 wrote:If you simply have to do it that way, then I would agree with jdelosa about using the Settings or Drives tab.

I like the idea of using the settings tab.
Likewise for other scripts that have a minimal interface, such as Mass Camera Eraser (which currently appears above Validator)
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.15 / 13.12.2015

Postby taco909 » Tue Dec 29, 2015 8:16 pm

aBshield wrote:I thought I'd flag this here in case this is something WME Validator could potentially test for. As I write this though, didn't we have something like this way back? Was this impacted by the same change that lost some other functionality?

We did.
"No inbound/outbound connectivity of driveable road"

That function went away in August 2014 when turn restriction data was moved from the segment to the junction (likely in preparation for JB). This was the same time we lost Validator visibility/flagging of Revcons and unconfirmed turns.

Given that Validator can pull flags from WMECH and TB, I would really like to get RevCon and Unconfirmed Turn flags back in the Validator report...
Getting back the "no inbound/outbound" may be more daunting as it requires the analysis of both the segment data (determine directionality and if routable) and the junction node, then comparing the two.
It may be too much complexity for what is essentially a fairly simple script.

I agree, it was a good feature when we had it (so long as that specific feature is locked so as not to display "errors" on segments locked above the editor's level, as there are many times that we create these intentionally)
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby taco909 » Fri Jan 29, 2016 2:20 am

Just received an update, appears to be working.
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

Re: [Script] WME Validator 1.1.16 / 29.01.2016

Postby taco909 » Mon Feb 01, 2016 11:47 pm

SuperDave1426 wrote:@khaytsus, believe me, you're not the only one who wishes that we'd get an option to put Validator on its own tab since access to the interface itself is needed so infrequently.... :?

+1

Apparently some editors don't like having a second row of tabs... I have 3 :D
taco909
Map Editor - Level 4
Map Editor - Level 4
 
Posts: 2230
Joined: Sun Jun 01, 2014 4:05 am
Location: Los Angeles Area
Has thanked: 716 times
Been thanked: 646 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: Google Feedfetcher, KuniaKid, Mythdraug