[Script] WME Place Interface Enhancements

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Fri Oct 27, 2017 2:47 am

SeveriorumPatrem wrote:
JustinS83 wrote:Unable to reproduce. Disable other scripts and see if it still happens.


All scripts disabled except for PIE. Zoom in to an area (Zoom 7), place names not shown. Disable and re-enable "Show Place names", then names appear. Pan sideways, the new places now brought into view names do not appear. Repeat disable/enable process, names appear.

Close entire browser. Reopen browser and reload WME, it reopens at Zoom 7. Place names still not shown. Repeat disable/enable process. Names reappear on display but again not for subsequent places broght into view by panning.

Chrome 57.0.2987.133

Love this script, thanks for your help looking into this!


I still cannot reproduce. I'm going to try not to blame the fact that you are running Chrome 5 versions behind current...:)

I have some delay in the Place names loading at times which seems to correspond with WME loading the layer data super slowly, but I have not had any not load at all. Since it is only like 3 people reporting this as an issue, I'd say it isn't a problem with the script and more likely a data load issue.
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Sun Oct 29, 2017 1:25 pm

Update released - 2017.10.29.01

Bug fix: Rebuilding the custom new Place menu when exiting HN edit mode
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Wed Nov 01, 2017 2:18 pm

WazingArch wrote:Hello, this seems like a bug - Place category buttons are visible even when the relevant option is not selected. The icons hide when the option is poked but they return when places are being updated.

I am not able to reproduce this. Could you provide steps to reproduce, including a screenshot of all options you have enabled?
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Sat Nov 18, 2017 5:49 pm

juliansean wrote:I'm not sure if it's a bug or just me, but if I create an exit/entry point, then decide to move the PP, I get a save error. If I tap undo once, the entry/exit point reappears and I can save. With PIE turned off, this doesn't happen.
https://prnt.sc/hc0sl2
https://prnt.sc/hc0sqa
https://prnt.sc/hc0szf
https://prnt.sc/hc0t2r
https://prnt.sc/hc0t7k

Yes, you cannot move the entry/exit point immediately after creating a RPP - you either get a save error or it just snaps back to the original location. I haven't been able to figure out why it ignores the moves, yet.
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Mon Nov 27, 2017 5:27 am

Update released - 2017.11.27.01

Place filtering allows you to hide all Places that match the regex supported filter or only show Places whose name matches the filter.

Screenshot - 11_27_2017 , 12_26_14 AM.png
(4.18 KiB) Downloaded 564 times
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Fri Dec 01, 2017 5:52 pm

Update released - 2017.12.01.01

Fixing a bug in WME beta where new RPPs couldn't pull the closest segement's name or city & it couldn't automatically edit the RPP after creation due to a timing issue with some backend objects.
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Thu Dec 07, 2017 4:54 am

Update released - 2017.12.06.01

Enabling the Residential Place layer when creating a RPP from the PIE new Place menu
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Thu Dec 14, 2017 7:34 pm

m4rc072 wrote:When I use this script I have a BUG
All Place don't move when I move the Map or zoom in or out.
look video at 0.18 with WME PIE active https://drive.google.com/file/d/1QCHmMmIsfzQGHOm7iXA71OCWbwya8jxq/view

Please check your console and report any errors. I always have this script enabled and haven't seen this behavior
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Thu Dec 28, 2017 6:02 pm

m4rc072 wrote:I have this error in prod and beta editor

Code: Select all
Uncaught (in promise) TypeError: Cannot read property 'backgroundGraphic' of undefined
    at initialize.eraseGeometry (vendor-e7e8255ff94a0f574f65.js:73)
    at initialize.eraseFeatures (vendor-e7e8255ff94a0f574f65.js:73)
    at initialize.removeFeatures (vendor-e7e8255ff94a0f574f65.js:73)
    at t.unselectFeature (vendor-e7e8255ff94a0f574f65.js:73)
    at t.destroy (app-1163a8649b7109b29781.js:1)
    at app-1163a8649b7109b29781.js:1
    at <anonymous>


Code: Select all
Uncaught TypeError: Cannot read property 'graphicZIndex' of undefined
    at initialize.getZIndex (vendor-0ee1287518b8bfe18e82.js:73)
    at Object.Z_ORDER (vendor-0ee1287518b8bfe18e82.js:73)
    at initialize.Z_ORDER_DRAWING_ORDER [as compare] (vendor-0ee1287518b8bfe18e82.js:73)
    at initialize.insert (vendor-0ee1287518b8bfe18e82.js:73)
    at initialize.redrawNode (vendor-0ee1287518b8bfe18e82.js:73)
    at initialize.drawGeometry (vendor-0ee1287518b8bfe18e82.js:73)
    at initialize.drawFeature (vendor-0ee1287518b8bfe18e82.js:73)
    at initialize.drawFeature (vendor-0ee1287518b8bfe18e82.js:73)
    at initialize.moveTo (vendor-0ee1287518b8bfe18e82.js:73)
    at initialize.moveTo (vendor-0ee1287518b8bfe18e82.js:73)
getZIndex @ vendor-0ee1287518b8bfe18e82.js:73
Z_ORDER @ vendor-0ee1287518b8bfe18e82.js:73
Z_ORDER_DRAWING_ORDER @ vendor-0ee1287518b8bfe18e82.js:73
insert @ vendor-0ee1287518b8bfe18e82.js:73
redrawNode @ vendor-0ee1287518b8bfe18e82.js:73
drawGeometry @ vendor-0ee1287518b8bfe18e82.js:73
drawFeature @ vendor-0ee1287518b8bfe18e82.js:73
drawFeature @ vendor-0ee1287518b8bfe18e82.js:73
moveTo @ vendor-0ee1287518b8bfe18e82.js:73
moveTo @ vendor-0ee1287518b8bfe18e82.js:73
pan @ vendor-0ee1287518b8bfe18e82.js:73
panMapDone @ vendor-0ee1287518b8bfe18e82.js:73
callback @ vendor-0ee1287518b8bfe18e82.js:73
dragend @ vendor-0ee1287518b8bfe18e82.js:73
mouseup @ vendor-0ee1287518b8bfe18e82.js:73
triggerEvent @ vendor-0ee1287518b8bfe18e82.js:73
handleBrowserEvent @ vendor-0ee1287518b8bfe18e82.js:73
(anonymous) @ vendor-0ee1287518b8bfe18e82.js:73


Neither of these look to be from PIE. What were you doing when you received the errors?
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Sun Dec 31, 2017 5:08 pm

Forgot to post here...

Update released - 2017.12.30.01

Fixes the new area Place bug YourEvilTwin reported.
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1370
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 346 times
Been thanked: 2451 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: steveinark, timmyelgato