Post Reply

New WME version v2.13-57

Post by delilush
Hi Everyone,

A new WME version is out. Here is the change log:

* New Speed Camera and Speed Verification UI - ENABLED (Known Issue: Imperial units are saying mi/h instead of mph, this will be fixed in the upcoming release)
* Added a new road type : ALLEY - Please see separate release notes here
* Selection manager new API - Script writers can follow this thread if they experience issues with their scripts as a result of this change.

* Street name are not unique in street selection - FIXED
* Cannot edit multiple Alt names - FIXED
* Reveal username in "flagged" PURs
* Closure tab unselectable for locked segments + ASC checkboxes - FIXED
* "Follow conversation" Check box Map Comment v/s User report - FIXED
* Keyboard shortcut allow HN editing mode on unnamed street - FIXED
* H shortcut not working in House numbers mode - FIXED
* GSV element obscuring segments - Beta & Production - FIXED
* [MAIN] Settings hidden vs in read-only mode for locked elements - FIXED
* Closure tab unselectable for locked segments + ASC checkboxes - FIXED
* Time Based Segment Restrictions Missing - FIXED
* Unable to see HN button and access the mode if segment is locked to higher level - FIXED
* Can't drag nodes together (to delete a segment) - FIXED
* GSV icon does not reappear when GSV handle moves out of view - FIXED
* Selecting a path of segments no longer works - FIXED
* Copying segment restrictions doesn't work - FIXED
* Deleted Closure is still visible - FIXED
* Revealing version WME version number in production (exposed in window.W)
* Added new scrolling acceleration
* Update translations
* Revert "Expert Mode (tee hee)"

Happy Editing!
delilush
Waze Team
Waze Team
Posts: 1080
Been thanked: 1803 times

Post by Inactive user -1643274304-
Thank you, can you add a link to the Alley Post when more information is available
Inactive user -1643274304-
PartnerCoordinator
PartnerCoordinator
Posts: 1023
Has thanked: 406 times
Been thanked: 459 times
-John
-------
https://j.mp/1BqcgbWhttps://s.waze.tools/c5.png
VT - State Manager
New England - Multi State Manager

Post by delilush
johnsninja58 wrote:Thank you, can you add a link to the Alley Post when more information is available
Updated.
delilush
Waze Team
Waze Team
Posts: 1080
Been thanked: 1803 times

Post by atrophicshiner
delilush wrote:* Added new scrolling acceleration
Why :!: Now I must ensure I stop my finger on laptop trackpad fully before releasing the mouse button, otherwise the map flings itself a ridiculous distance away from the area I was panning to :cry:

Also why are all the categories now CAPITALISED :?: It is difficult to read words that are all caps, another example of bad usability design :(
atrophicshiner  
Waze Local Champs
Waze Local Champs
Posts: 4244
Answers: 3
Has thanked: 1418 times
Been thanked: 1548 times
- Chris - (Catching up with the Ia{i}ns one Chris at a time)

https://cottagepi.uk/proud-wazer.gifhttps://cottagepi.uk/pirate.pnghttps://cottagepi.uk/Beta_app.pnghttps://cottagepi.uk/tolls.pnghttps://cottagepi.uk/Iain.png
UK Local Champ would you believe
AM the Middle bit of England
Usability | Simplicity | Retention

Post by AlObaili
I noticed the panning acceleration effect becomes particularly annoying when the cursor leaves the map view area. The map keeps panning with the same acceleration right after when the cursor leaves the map view area.

e.g. try panning the map by holding your click and moving the cursor to the left very fast. As soon as the cursor leaves the map view area and enter the side panel the map will continue accelerating fast. I crossed the country boarders because of this :lol:

I think the panning should stop immediately if the cursor leaves the map view area.
AlObaili
PartnerCoordinator
PartnerCoordinator
Posts: 350
Has thanked: 139 times
Been thanked: 110 times

download/file.php?id=58773https://s.waze.tools/s0500.pnghttps://s.waze.tools/beta.pnghttps://s.waze.tools/c6s.png
مـنـســـق مــجـتـمـع ويـز الـسـعــوديـة والــبحـريـن ومـنـســق الـتعــريـب لـمـنـتجـات ويــز
CM for Saudi Arabia & Bahrain & Transifex Coordinator for Arabic

Post by AlObaili
Then maybe it would be better to research how editors interact with this feature and adjust the speed rate of panning so that it wont fly around the country, or lower the animation so we can quickly grab the map to stop it in the intended spot.
AlObaili
PartnerCoordinator
PartnerCoordinator
Posts: 350
Has thanked: 139 times
Been thanked: 110 times

download/file.php?id=58773https://s.waze.tools/s0500.pnghttps://s.waze.tools/beta.pnghttps://s.waze.tools/c6s.png
مـنـســـق مــجـتـمـع ويـز الـسـعــوديـة والــبحـريـن ومـنـســق الـتعــريـب لـمـنـتجـات ويــز
CM for Saudi Arabia & Bahrain & Transifex Coordinator for Arabic

Post by abc1357
The latest version does not appear to display restricted turns correctly. For example, the left turn from Mission St to 3rd St in San Francisco is time restricted. Yet the turn arrow displays as green, not as yellow.
Green Arrow.jpg
(15.56 KiB) Downloaded 451 times
When I pull up the restrictions tab, it does show a restriction has been applied to it.
Restrictions.jpg
(54.44 KiB) Downloaded 449 times

Note that the type of restriction is a "Allowed" type (i.e, the following list is allowed - all others are prohibited).


If the restriction is a "Prohibited" type (i.e. the following list is prohibited - all others are allowed),
Prohibited Restrictions.jpg
(53.44 KiB) Downloaded 448 times
then the map displays a yellow turn arrow.
Yellow Arrow.jpg
(17.29 KiB) Downloaded 446 times
This was done on a clean WME in Firefox with no extensions or scripts running.
abc1357
State Manager
State Manager
Posts: 600
Answers: 1
Has thanked: 244 times
Been thanked: 202 times
Last edited by abc1357 on Thu Apr 26, 2018 5:58 pm, edited 2 times in total.

Post by GeekDriverPeaceful
Last night this was happening in NA server, but not on ROW server [long Road / Segments Layer load time] Chrome Said “waiting for tiles1.waze.com/*]. It is most likely due to heavy server load
GeekDriverPeaceful
Posts: 706
Has thanked: 454 times
Been thanked: 166 times

Post by atrophicshiner
Not sure how long this has existed or if it is normal behaviour...

When selecting 2 segments that are identical except for the State in the name being different the left-hand panel refuses to show any information at all :!: Normally when names differ the left-hand panel displays all info but adds No common name and Multiple for attributes.

This is a minor hinderance when closures span State borders.
atrophicshiner  
Waze Local Champs
Waze Local Champs
Posts: 4244
Answers: 3
Has thanked: 1418 times
Been thanked: 1548 times
- Chris - (Catching up with the Ia{i}ns one Chris at a time)

https://cottagepi.uk/proud-wazer.gifhttps://cottagepi.uk/pirate.pnghttps://cottagepi.uk/Beta_app.pnghttps://cottagepi.uk/tolls.pnghttps://cottagepi.uk/Iain.png
UK Local Champ would you believe
AM the Middle bit of England
Usability | Simplicity | Retention

Post by Aztek985
wrocco wrote:
Rfrsw101 wrote:I've noticed that the Road Segments layer has some trouble coming back after performing a save. Unsure at this time if number of edits in a save has an effect on this. It eventually will fully repopulate all of the segments, but takes some time.

Have tried/experienced this on Incognito so I know it's not just a script having a negative effect on the loading.
I'm experiencing same issue. Sometimes I need to refresh entire page because some roads never loads (F5).
This is a constant problem for me the past week or so. Very annoying.

Unrelated note ... now that JBs supposedly don't require additional resources, any plan to lower them to R4 editors in a future WME release? Very useful tool as far as I'm concerned ... not very useful when only R5 can implement them.
Aztek985
State Manager
State Manager
Posts: 394
Has thanked: 78 times
Been thanked: 96 times