[Script] WME Place Interface Enhancements

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Fri Jul 26, 2019 10:03 pm

SeveriorumPatrem wrote:Sorry Justin.... when placing a new RPP, the entry fields are not opened up with the cursor parked in the HN field ready to go, and the HN field is back below the Street field.

But now I am suddenly doubting myself and wondering if WMEFU is involved in these fixes instead.

So many scripts - so easy to forget which one is doing what! :)

This is from PIE and it is working correctly last I checked (yesterday). Check the console immediately after creating a new RPP - another script is likely having an issue and interfering with this functionality
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Fri Jul 26, 2019 11:11 pm

SeveriorumPatrem wrote:I don't know enough about any of this to interpret except that I see a reference to Toolbox in there.
I'm lucky I even know how to access the error console - I only learned that much since becoming an editor here, lol.

Code: Select all
FancyPermalink.min.js:227 Uncaught TypeError: Cannot read property 'mainObjectID' of undefined
    at e.WMETB_FPnewSelectionAvailable (FancyPermalink.min.js:227)
    at initialize.triggerEvent (vendor-86dc9f4c83949efd6718.js:1)
    at e.value (app-1d3e5c24957b318a3943.js:1)
    at e.value (app-1d3e5c24957b318a3943.js:1)
    at e.value (app-1d3e5c24957b318a3943.js:1)
    at createPlace (userscript.html?id=6d4557a0-20b6-4839-b59c-14e63305c52c:5786)
    at endPlacementMode (userscript.html?id=6d4557a0-20b6-4839-b59c-14e63305c52c:5692)
    at HTMLDivElement.eval (userscript.html?id=6d4557a0-20b6-4839-b59c-14e63305c52c:5575)
    at HTMLDivElement.dispatch (vendor-86dc9f4c83949efd6718.js:1)
    at HTMLDivElement.f.handle (vendor-86dc9f4c83949efd6718.js:1)
WMETB_FPnewSelectionAvailable @ FancyPermalink.min.js:227
triggerEvent @ vendor-86dc9f4c83949efd6718.js:1
value @ app-1d3e5c24957b318a3943.js:1
value @ app-1d3e5c24957b318a3943.js:1
value @ app-1d3e5c24957b318a3943.js:1
createPlace @ userscript.html?id=6d4557a0-20b6-4839-b59c-14e63305c52c:5786
endPlacementMode @ userscript.html?id=6d4557a0-20b6-4839-b59c-14e63305c52c:5692
(anonymous) @ userscript.html?id=6d4557a0-20b6-4839-b59c-14e63305c52c:5575
dispatch @ vendor-86dc9f4c83949efd6718.js:1
f.handle @ vendor-86dc9f4c83949efd6718.js:1
userscript.html?id=fc739a23-e725-42e4-82e3-3cc468d31121:44302

Uncaught TypeError: Cannot read property '-101' of undefined
    at eval (userscript.html?id=fc739a23-e725-42e4-82e3-3cc468d31121:44302)
    at Array.forEach (<anonymous>)
    at eval (userscript.html?id=fc739a23-e725-42e4-82e3-3cc468d31121:44293)
    at Array.forEach (<anonymous>)
    at MutationObserver.eval (userscript.html?id=fc739a23-e725-42e4-82e3-3cc468d31121:44273)

That's a TB error. I'd report it in that thread and disable if it is interfering with other scripts
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Mon Jul 29, 2019 1:39 pm

RichardPyne wrote:Looks like the Parking Lot button has disappeared.


This parking lot button?
Screenshot - 7_29_2019 , 9_35_28 AM.png
(43.8 KiB) Downloaded 314 times


:lol:
Try turning off TB and see if it appears.
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Wed Sep 25, 2019 2:20 am

SeveriorumPatrem wrote:Bump - to check on status of issue where new RPPs by a no-city segment are not picking up the alt city when present.

I don't have much free time to work on scripts anymore due to a new job and helping with the wife's business, so getting things fixed may be a bit slower than before.

This should now be fixed in 2019.09.24.01
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Thu Jan 16, 2020 7:55 pm

G_W1Z wrote:Is there a max limit for photos to populate in the PhotoViewer feature?

No
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Fri Jan 24, 2020 12:16 pm

m4rc072 wrote:Can you check this out please?
in the Map Comment panel there's the options to change geometry like a Place, but doesn't works
[ img ]
when I try to load a new geometry by WKT or other is missing the apply button in the panel
[ img ]


See here
https://www.waze.com/forum/viewtopic.ph ... 0#p1935207
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Wed Feb 12, 2020 9:30 pm

iainhouse wrote:I suspect the problem is that the default font size for the main body of WME wa changed a couple of releases ago. Although most elements of WME define their font-size explicitly, there are a few things that depend on the body font-size. This is currently 14px and I suspect it must once have been smaller than that. Reducing that size seems to fix several problems I've seen, including the scroll bars on PIE.

I've already incorporated a specific font-size setting for the side-panel to override this change - it will be part of the next release of WME FixUI. But I haven't changed the font-size right up at the body level, because it could have multiple effects in other places.

Setting a font size of 13px on the photoViewerMainDiv div seems to fix the problem.


I noticed this as well and have just been too lazy to make the change :lol:
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Tue Mar 17, 2020 3:50 am

SuperDave1426 wrote:
G_W1Z wrote:Feature suggestion: when viewing place images in the picture browser and an image is clicked on, could the username and timestamp be displayed with it? Right now it's just the picture, which could be to simplify the viewing experience.

[ img ]

Why? What does it matter when you are in the picture browser? That is for mass maintaining images and I don't see how who took the picture or when really matters.
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Wed Mar 25, 2020 6:11 pm

SeveriorumPatrem wrote:I am assuming it is somehow related to latest WME, and I have not tested for interactions with other scripts that might also be freaking out over the new WME, but I have noted that after creating a single RPP, the dropdown of places for creation reverts to the default list. Entering HN mode for any road, even if no changes are made, and then exiting HN mode, restores the custom dropdown list of places.


This is due to any change to the map causing a complete rebuild to that toolbar, which is why the buttons that are added by scripts are disappearing, too. Iain has a question into staff inquiring if this is intended behavior.
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

Re: [Script] WME Place Interface Enhancements

Postby JustinS83 » Fri Mar 27, 2020 3:21 pm

Update released - 2020.03.27.01

Fixed the layer bug introduced with the latest WME update
Added the picture date & time when viewing a single picture in the Photo Viewer
Script Writing Community Coordinator
[ img ][ img ][ img ][ img ][ img ]
JustinS83
Waze Global Champs
Waze Global Champs
 
Posts: 1380
Joined: Wed Dec 03, 2014 4:33 am
Location: Franklin, OH
Has thanked: 348 times
Been thanked: 2474 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: bummerdude69, jm6087, Mapman44, umopapisdn