[Script] WME Toolbox (1.8.19)

Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Moderators: Unholy, bextein, Glodenox, JustinS83

Forum rules
Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

DO NOT START a new thread unless it is about a new idea. Keep discussion of existing tools within the main thread for that tool.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.

Re: [Script] WME Toolbox (1.6.8)

Postby vince1612 » Mon Nov 30, 2015 1:16 am

If I'd like to request a change in the country's Fancy Permalinks, I noticed there is nothing in the WMETB Country Framework sheet for me to do that. Could this be added? Or do you prefer if we just do it here or via PM ?
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: Waze.accelerators.events.listeners.disallowAllConnection

Postby vince1612 » Tue Dec 15, 2015 5:02 pm

Benny_An-n wrote:What does the text in a popupwindow,

´WME Junction Node Fixer has failed to load due to API check:
Waze.accelerators.events.listeners.disallowAllConnections´
indicate?

Please help!

Read this page https://www.waze.com/forum/viewtopic.ph ... 0#p1277836
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: [Script] WME Toolbox (1.6.9)

Postby vince1612 » Sun Dec 20, 2015 9:46 pm

Fredo-p wrote:Have you checked the Toolbox permissions France to see if they recently changed the settings or are having the same issues?

Good place to check.

Also as a tip, the guys that manage TB also have a public spreadsheet where you can see all country settings. If there is no tab for a country, then the settings are automatically the ones on the Default tab. (Link to the France WMETB settings tab)
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: [Script] WME Toolbox (1.6.9)

Postby vince1612 » Fri Jan 01, 2016 4:55 pm

paulkok_my wrote:What does "Idem" mean?

It's latin for "the same"
The french sometimes use it to replace another word: "pareil" which also means "the same"
Pareil pour moi = Idem pour moi = The same for me
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: [Script] WME Toolbox (1.6.9)

Postby vince1612 » Mon Jan 04, 2016 11:15 am

Is an update of the script planned in the coming weeks?

Though I have not had any issues in prod WME, many scripts seem to work less effectively now in beta WME.
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: [Script] WME Toolbox (1.6.9)

Postby vince1612 » Wed Jan 06, 2016 10:16 am

BellHouse wrote:
vince1612 wrote:Is an update of the script planned in the coming weeks?

Though I have not had any issues in prod WME, many scripts seem to work less effectively now in beta WME.

What in particular do you have in mind, i.e. what should we improve in Toolbox?

I wrote that message and this reply from work where I can't install scripts so I will get back to you about it this evening.
But basically in WME beta I think I saw that some Toolbox buttons were no longer working on Chrome. I've started noticing issues with various scripts around the same time this issue was reported:
https://www.waze.com/forum/viewtopic.php?f=211&t=172298
Probably due to a new release of WME beta.
Sorry to be vague for now, I'll post again when I've had the chance to test again so that I can be more clear.
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: [Script] WME Toolbox (1.6.9)

Postby vince1612 » Wed Jan 06, 2016 5:24 pm

Back home :)

I saw your post in GHO but just thought I'd post here anyway.

So I don't know if I was tired or something when I thought some Toolbox buttons where not working anymore in beta WME, because I can't find any issue with them now.

However there is still something that I had told you about before. Switzerland should have the Fix U-turns tool enabled and I had said that it appears for me on WME beta but not anymore in WME prod.

Well I just noticed something while loading WME prod:
Image

"User roles: AM" only, while I get "User roles AM CM" in beta WME. That may be why you couldn't find what was wrong about it in the permission sheet.
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: [Script] WME Toolbox (1.6.14)

Postby vince1612 » Fri Feb 19, 2016 10:19 am

WazingArch wrote:I want to make a second request for enabling "Auto Fix u-turns" by default for Level 6 editors. What are the reasons the highest ranked editors not to have access to this function? By default there is no difference in permissions between Level 5 and Level 6 editors, and this could be the difference. Level 6 is pretty high to achieve, and it is a good idea someone, beside developers, to has access to this function. Just saying.

This post should interest you:
https://www.waze.com/forum/viewtopic.php?f=1456&t=146704#p1136695 ;)

We have in back in Switzerland.
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: [Script] WME Toolbox (1.6.22)

Postby vince1612 » Fri Nov 11, 2016 9:05 am

I know this may not be the best time to ask for this but I have a question about the feasibility for a potential new function that would seem approriate for Toolbox.

There is a common hidden problem that makes it impossible to delete nodes under certain conditions as I'm sure you know. This is asked often and I was again asked today about why someone couln't delete a node where both segments seem to be exactly the same:
ImageImage

In fact they were not exactly the same, but the problem was hidden until you set them as two-way segments again and you could then see that the speed limits did not match for the opposite but hidden direction:
ImageImage

Would it be possible to have a highlight for such cases along with maybe a quick fix button similar to the highlight and autofix for RevCons?

I know this doesn't cause any routing problem, but it could make it easier for editors to realize what's wrong before posting the permalink in the forum asking why they can't delete the node.
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

Re: [Script] WME Toolbox (1.7.7)

Postby vince1612 » Wed Apr 26, 2017 3:51 pm

BellHouse wrote:If you feel this is not the wanted behavior, you should report it as WME bug. :geek: :)

Or suggestion, remember? :mrgreen:
Image :P :P :P
vince1612
Waze Global Champs
Waze Global Champs
 
Posts: 8324
Joined: Sun Mar 17, 2013 2:30 pm
Location: DACH Group (Germany, Austria, Switzerland)
Has thanked: 5069 times
Been thanked: 5324 times

PreviousNext

Return to Addons, Extensions, and Scripts

Who is online

Users browsing this forum: bummerdude69, glenan56, Mythdraug