Discussion for the unofficial, community-developed addons, extensions and scripts built for the Waze Map Editor.

The official index of these tools is the Community Plugins, Extensions and Tools wiki page.
Post by wxw777
I'm having some difficulty getting the MTE regex to match. Tried the full string and a ^beginning and it's not working for me. Any hints.

EDIT: Just saw that index 0 is needed, not 1 and GitHub Issue #43 relates to this.

BTW, very nice script. Thanks for the work.
wxw777
Waze Mentor
Waze Mentor
Posts: 72
Has thanked: 50 times
Been thanked: 25 times

Post by velezss
Is it possible to have the 6 months period in the Closure Length?

Thanks,
velezss
Waze Global Champs
Waze Global Champs
Posts: 4249
Answers: 11
Has thanked: 220 times
Been thanked: 1760 times
https://s.waze.tools/gc.png
velezss
Supervisor Región Centrosur (CDMX, Estado de México y Morelos) y Querétaro

Post by witoco
Nice tool, but it seems I catched a bug.

Some weeks ago I created a high number of closures (many segments, scheduled for many days) using WME Advanced Closures, but now I need to update the schedule, so I decided to remove all of them and recreate using the new schedule.

I tried to remove them using WME Closure Helper and only 28 were displayed at a time. I could select all the displayed ones using the "Select all closures" selector and then pressed the "Delete Selected Closures" button. After accepting the confirmation WME pupup 28 times, another set of closures was listed, and another "Select all closures" selector was appended to the heading of that list, on top of the previous checkbox. When I check that option, a new "Delete Selected Closures" button appeared on top of the previous one. I can repeat this many times and new selectors and buttons get appended to the existing ones.

I disabled the Advances Closures and any other plugin to test the behavior when it is isolated, and this time it showed me again 28 closures, and when I selected all of them and pressed the "Delete..." button, the confirmation poput appeared more than 100 times, and when it stopped to appear, I got a huge list of selector checkboxes, and the closures at the end where horizontally compressed (a thin and tall HTML box for each of the 28 remaining closures).

Thank you FourLoop for this tool... BTW, is localization in your roadmap?
witoco
Coordinators
Coordinators
Posts: 994
Has thanked: 87 times
Been thanked: 162 times

Post by witoco
FourLoop wrote:
witoco wrote:Nice tool, but it seems I catched a bug.

Some weeks ago I created a high number of closures (many segments, scheduled for many days) using WME Advanced Closures, but now I need to update the schedule, so I decided to remove all of them and recreate using the new schedule.

I tried to remove them using WME Closure Helper and only 28 were displayed at a time. I could select all the displayed ones using the "Select all closures" selector and then pressed the "Delete Selected Closures" button. After accepting the confirmation WME pupup 28 times, another set of closures was listed, and another "Select all closures" selector was appended to the heading of that list, on top of the previous checkbox. When I check that option, a new "Delete Selected Closures" button appeared on top of the previous one. I can repeat this many times and new selectors and buttons get appended to the existing ones.

I disabled the Advances Closures and any other plugin to test the behavior when it is isolated, and this time it showed me again 28 closures, and when I selected all of them and pressed the "Delete..." button, the confirmation poput appeared more than 100 times, and when it stopped to appear, I got a huge list of selector checkboxes, and the closures at the end where horizontally compressed (a thin and tall HTML box for each of the 28 remaining closures).

Thank you FourLoop for this tool... BTW, is localization in your roadmap?
I think that issue is documented, if I'm understanding it right. And nope.

Also, sorry for being a little behind on things, been a little busy with some other stuff right now.
I tried to describe this:

https://www.vitoco.cl/kk/waze-delete-closure.jpg

Thanks again...
witoco
Coordinators
Coordinators
Posts: 994
Has thanked: 87 times
Been thanked: 162 times

Post by SteveSnail
jm6087 wrote:
SteveSnail wrote:Hi

Don't know if this is something you can look at or fix, but after having installed WME Closure Helper, it seems to be having an effect on UR-MP Tracking.

As soon as you select a segment, WME Closure Helper seems to remove the scroll bar from UR-MP Tracking preventing you from scrolling up and down. Only comes back when you reload the WME and then only until you click on a segment again

Without WME Closure Helper enabled
screenshot 1.JPG


With WME Closure Helper enabled
screenshot 2.JPG
He has this bug on his list of things to fix
Ah, cool. Thank you :-)
SteveSnail
Waze Local Champs
Waze Local Champs
Posts: 2024
Answers: 2
Has thanked: 1474 times
Been thanked: 456 times

Post by YanisKyr
I installed this script a few weeks ago but haven't got the chance to use it until today, I have to say it saves a lot clicks so thank you for that!

There's one suggestion I'd like to make about the presets. Would it be possible to define the start date/time as well?
YanisKyr
Posts: 566
Has thanked: 332 times
Been thanked: 87 times